summaryrefslogtreecommitdiff
path: root/dev-lisp/trivial-gray-streams
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-lisp/trivial-gray-streams
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-lisp/trivial-gray-streams')
-rw-r--r--dev-lisp/trivial-gray-streams/Manifest5
-rw-r--r--dev-lisp/trivial-gray-streams/metadata.xml12
-rw-r--r--dev-lisp/trivial-gray-streams/trivial-gray-streams-20170830.ebuild17
-rw-r--r--dev-lisp/trivial-gray-streams/trivial-gray-streams-99999999.ebuild16
4 files changed, 50 insertions, 0 deletions
diff --git a/dev-lisp/trivial-gray-streams/Manifest b/dev-lisp/trivial-gray-streams/Manifest
new file mode 100644
index 000000000000..a61f4ea17501
--- /dev/null
+++ b/dev-lisp/trivial-gray-streams/Manifest
@@ -0,0 +1,5 @@
+DIST trivial-gray-streams-20170830.tar.bz2 7520 SHA256 0aa3640bb5862b3427950d6732c0d3cef18a7b3d401d50f2ec8537017bd9db07 SHA512 4fbcfff5f2875daaf9c9bb286e2f753fccbb9840bb3c3593b9755204475aaf34241c1ffc2c93b5bf2c3428400e91082b01f15812eb51251afcabe9a57d5df3fa WHIRLPOOL 0d18affea069d4871277cbe64d6e09a2b90ee6de189e3108fdd6c7b76faf84021b191509958dc3ffcc71af9f9ad5a8983ba4d3c7dc773b0e24981cabf02746fe
+EBUILD trivial-gray-streams-20170830.ebuild 427 SHA256 5f74795f9111fd0b8dcd5f4db25d10e3830e142d99819530735cf4d2a6579e06 SHA512 2dce2e1ae6fe587c3c73e8304c6237a42b4fe7b1c4186c2f1ceaff42c7e2bd395d9f82e2e2dc790cb0d783e0b69b7e136b94fd8c017688996e95cdd572e6bc14 WHIRLPOOL 550af2ae71100cf05806dcc3093f29baf607c0df074f85036ed44e37babdc9ec40a1d0bfc9a5d7d4349d2827f4f35e6ec73821df677118c1042240663296452e
+EBUILD trivial-gray-streams-99999999.ebuild 409 SHA256 8a15d5af7700b6a2fdd12fd0bf51c7eabeab900c81fb611ead37936d72e03751 SHA512 193bb970f025012af66a890758ee862d0b97d03e558b9b19fd4b4378c51b1811e33f10690e88b7804927f500c31cd332a07eec6b96e13a8e631517f51630860f WHIRLPOOL 61551506b38e5b7d34e1c871c1672bbf4f3c45f52bb09d8be1a783e5b5b276c38752562ea3f019875c2f74b61293557891dc2afd8d81d447c001eed1e2068ccf
+MISC ChangeLog 826 SHA256 38204dc95620daa128026efb3686bac9c59cea6d687a10a172b097f589f4ae52 SHA512 5d80b7400be7b02dbcfded28d6df2dc400b49c970b6435fe1a792b1bdfeba6c117da6edd35d4f2bae7519655b534b67723ac0b1781a703682490f68fce2d0e05 WHIRLPOOL 3080c9c7b6f86039dc4269ce2a1aa4d1285ead166618e71f55604b4634b7df8c36117f96ff580275b0da8e624744b6fc7ec196a69092ddda837dcab500a4d9e8
+MISC metadata.xml 394 SHA256 598a820ae92f6b7b9d784d4ae146d377d2cdd00fe472e9ddcc4342f8a6bb1ba3 SHA512 2aee230ee6fd936e5ba5d50c3e17e47aaa1dffc4cae7cddf2751ff331fe2191ad4c4e899aed7871ce90404c1b3e366282a9fcfaf928fea3dba8c159c64c6560f WHIRLPOOL 70f0f83a1a8a3183eab399d874e5f0981bccc5b2ffb35d10f4320345cadecc7276877f1843157698543f2fae223dafe74455a2b4ef14f947e879aad15a8890ea
diff --git a/dev-lisp/trivial-gray-streams/metadata.xml b/dev-lisp/trivial-gray-streams/metadata.xml
new file mode 100644
index 000000000000..53f2ee0bd5c2
--- /dev/null
+++ b/dev-lisp/trivial-gray-streams/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>common-lisp@gentoo.org</email>
+ <name>Gentoo Common Lisp Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ This system provides an extremely thin compatibility layer for
+ Gray streams
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-lisp/trivial-gray-streams/trivial-gray-streams-20170830.ebuild b/dev-lisp/trivial-gray-streams/trivial-gray-streams-20170830.ebuild
new file mode 100644
index 000000000000..63d5924ffdb0
--- /dev/null
+++ b/dev-lisp/trivial-gray-streams/trivial-gray-streams-20170830.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3
+
+DESCRIPTION="A thin compatibility layer between Gray Stream Common Lisp implementations"
+HOMEPAGE="https://common-lisp.net/project/trivial-gray-streams/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="!dev-lisp/cl-${PN}"
diff --git a/dev-lisp/trivial-gray-streams/trivial-gray-streams-99999999.ebuild b/dev-lisp/trivial-gray-streams/trivial-gray-streams-99999999.ebuild
new file mode 100644
index 000000000000..9fa802eff228
--- /dev/null
+++ b/dev-lisp/trivial-gray-streams/trivial-gray-streams-99999999.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3 git-r3
+
+DESCRIPTION="A thin compatibility layer between Gray Stream Common Lisp implementations"
+HOMEPAGE="https://common-lisp.net/project/trivial-gray-streams/"
+EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="!dev-lisp/cl-${PN}"