summaryrefslogtreecommitdiff
path: root/dev-lisp/flexi-streams/flexi-streams-1.0.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-lisp/flexi-streams/flexi-streams-1.0.16.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-lisp/flexi-streams/flexi-streams-1.0.16.ebuild')
-rw-r--r--dev-lisp/flexi-streams/flexi-streams-1.0.16.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-lisp/flexi-streams/flexi-streams-1.0.16.ebuild b/dev-lisp/flexi-streams/flexi-streams-1.0.16.ebuild
new file mode 100644
index 000000000000..f9d5b59764d1
--- /dev/null
+++ b/dev-lisp/flexi-streams/flexi-streams-1.0.16.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3
+
+DESCRIPTION="Flexible bivalent streams for Common Lisp"
+HOMEPAGE="http://weitz.de/flexi-streams/
+ http://www.cliki.net/flexi-streams/"
+SRC_URI="https://github.com/edicl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="!dev-lisp/cl-${PN}
+ >=dev-lisp/trivial-gray-streams-20060925"
+
+src_install() {
+ common-lisp-install-sources *.lisp
+ common-lisp-install-asdf
+ dodoc doc/index.html
+}