summaryrefslogtreecommitdiff
path: root/dev-lisp/cl-unicode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-lisp/cl-unicode
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lisp/cl-unicode')
-rw-r--r--dev-lisp/cl-unicode/Manifest3
-rw-r--r--dev-lisp/cl-unicode/cl-unicode-0.1.5.ebuild42
-rw-r--r--dev-lisp/cl-unicode/metadata.xml29
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-lisp/cl-unicode/Manifest b/dev-lisp/cl-unicode/Manifest
new file mode 100644
index 000000000000..a283f8bafd0c
--- /dev/null
+++ b/dev-lisp/cl-unicode/Manifest
@@ -0,0 +1,3 @@
+DIST cl-unicode-0.1.5.tar.gz 485666 BLAKE2B 9db0714c24de4c5c79f3d7eeb471ac5d7a06dd29abd1c3c4b728c9ce98b175ea97ed20923c957a75ac7dee290f095a5c28c92da5ddc7e808d28ca624d84a37cd SHA512 0b66c0e711f7e37423aa638b43017adff648189a32032702b082dff140b2255847a15572a20f21e6f82a2e8cbd547f7f99bf9176e4fa464aa1d938575d8a2390
+EBUILD cl-unicode-0.1.5.ebuild 1068 BLAKE2B 934f0abff66f151646c4e884c540bc80ff58e50cfb6ae6b9c7a21c4c4499c7727c64c61a4cb30fefd990bd4bb26b121be91cb4ee2b78405fe6d979c35832b8ff SHA512 0b314acfac0367f59ec5690e71052a78a400f7e1631845a82152eff78328322b5f065ad227a3c74174385fe1ef4387361a9048dcc0e65bd6bb736daf48bc0a7a
+MISC metadata.xml 1362 BLAKE2B 667231d4f1487ab486db549b0fbc7d641909596712ded57569f9eedb60f73952fd87e7d3a54057eba0f042c63a725715839f8f49736fbcac89d95a947d5ed34c SHA512 cde1545cbd82dbe5758fca85783022153f2f19a187128082c0f58f10740af62eae8be0abf800bb9c58a1037868fb6eaeab7ba7e3f52aae5eafd0f8a1a226a0bb
diff --git a/dev-lisp/cl-unicode/cl-unicode-0.1.5.ebuild b/dev-lisp/cl-unicode/cl-unicode-0.1.5.ebuild
new file mode 100644
index 000000000000..bff440548364
--- /dev/null
+++ b/dev-lisp/cl-unicode/cl-unicode-0.1.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3 xdg-utils
+
+MY_P="v${PV}"
+
+DESCRIPTION="Provides Common Lisp implementations with knowledge about Unicode characters."
+HOMEPAGE="http://weitz.de/cl-unicode/"
+SRC_URI="https://github.com/edicl/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+DEPEND="virtual/commonlisp
+ dev-lisp/flexi-streams"
+RDEPEND="dev-lisp/cl-ppcre"
+
+src_configure() {
+ xdg_environment_reset
+}
+
+src_compile() {
+ # cl-unicode builds parts of its source code automatically the first time it
+ # is compiled, so we compile it here.
+ local initclunicode="(progn (push \"${S}/\" asdf:*central-registry*) (require :${PN}))"
+
+ common-lisp-export-impl-args "$(common-lisp-find-lisp-impl)"
+ ${CL_BINARY} ${CL_EVAL} "${initclunicode}"
+}
+
+src_install() {
+ common-lisp-install-sources *.lisp test/
+ common-lisp-install-sources -t all build/
+ common-lisp-install-asdf
+ dodoc CHANGELOG
+ dodoc doc/index.html
+}
diff --git a/dev-lisp/cl-unicode/metadata.xml b/dev-lisp/cl-unicode/metadata.xml
new file mode 100644
index 000000000000..739846335fdf
--- /dev/null
+++ b/dev-lisp/cl-unicode/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>common-lisp@gentoo.org</email>
+ <name>Gentoo Common Lisp Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ CL-UNICODE is a library which provides Common Lisp implementations
+ with knowledge about Unicode characters including their name, their
+ general category, the scripts and blocks they belong to, their
+ numerical value, and several other properties. It also provides the
+ ability to replace the standard syntax for reading Lisp characters
+ with one that is Unicode-aware and is used to enhance CL-PPCRE with
+ Unicode properties.
+ </longdescription>
+ <longdescription lang="es">
+ CL-UNICODE es una biblioteca que ofrece implmentaciones de Common
+ Lisp que reconoce caracteres Unicode incluyendo su nombre, categoría
+ general, los guiones y bloques a los que pertenecen, su valor
+ numérico y algunas otras propiedades. También ofrece la capacidad
+ de reemplazar la sintaxis estándar para la lectura de caracteres
+ Lisp por otra que reconoce Unicode y se utiliza para mejorar
+ CL-PPCRE con propiedades Unicode.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">edicl/cl-unicode</remote-id>
+ </upstream>
+</pkgmetadata>