summaryrefslogtreecommitdiff
path: root/dev-lisp/cl-unicode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-lisp/cl-unicode
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-lisp/cl-unicode')
-rw-r--r--dev-lisp/cl-unicode/Manifest4
-rw-r--r--dev-lisp/cl-unicode/cl-unicode-0.1.5.ebuild42
-rw-r--r--dev-lisp/cl-unicode/metadata.xml29
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-lisp/cl-unicode/Manifest b/dev-lisp/cl-unicode/Manifest
new file mode 100644
index 000000000000..847dd260a863
--- /dev/null
+++ b/dev-lisp/cl-unicode/Manifest
@@ -0,0 +1,4 @@
+DIST cl-unicode-0.1.5.tar.gz 485666 SHA256 9e9f1dda5133c3c94e09f638fec01410254c0020b89cc7342416d8ed1d377ee3 SHA512 0b66c0e711f7e37423aa638b43017adff648189a32032702b082dff140b2255847a15572a20f21e6f82a2e8cbd547f7f99bf9176e4fa464aa1d938575d8a2390 WHIRLPOOL e0b973416ff76f4e66b203ea5545c782a4bf59dccbbc7f1d26c6a78870efa31a4fe0b2e7eae17be25f49efc06272201ce9472fbb9e22d5332de8014aea1bc14c
+EBUILD cl-unicode-0.1.5.ebuild 1068 SHA256 620042dc20eafc655eafea3c4dd193a042d58d8c209637e4851d50b23d646203 SHA512 0b314acfac0367f59ec5690e71052a78a400f7e1631845a82152eff78328322b5f065ad227a3c74174385fe1ef4387361a9048dcc0e65bd6bb736daf48bc0a7a WHIRLPOOL 4ac9fae1a80c04b2317b6a333be9aac246ee3d42a9e43b354207b9d8115ce5932451cb52900919929562febbd0be7909ceb9656b26d656bd4bc242012ec6abd9
+MISC ChangeLog 1587 SHA256 bfdaf7c7e841b2a1667088e1ee5b5230d04c2527b38c8333743b8f93458ba592 SHA512 e9ab642c8b104e8994f92231a9c764dc33548ec5fb03cbaeee6468b7f229d6c2eb8b5224aa4dd5eced8903d07311a7e8153c1e26680b1c26bb7430615a0e1707 WHIRLPOOL 704b5d220ac91eb77f9357fb30650ac97fcd3d6f6483e7b86783c189e5a0b3f6a4a054e76882c2735f09d10dd695565dd55525ac0722c014e7aa2e4105fbbc25
+MISC metadata.xml 1362 SHA256 8ae81c164ceb64ca0b8c367ae0e0717d572c491543541b41c3646994aacfc83a SHA512 cde1545cbd82dbe5758fca85783022153f2f19a187128082c0f58f10740af62eae8be0abf800bb9c58a1037868fb6eaeab7ba7e3f52aae5eafd0f8a1a226a0bb WHIRLPOOL d9dd90b0c8cdb3af5591821bb21ff939eaaf5e929e2dc9953b80097ae15aef93b8d0c94b3b5322111163f4a4aeaa70aed1f6ee5b3d77d1f7302adce8cf63efff
diff --git a/dev-lisp/cl-unicode/cl-unicode-0.1.5.ebuild b/dev-lisp/cl-unicode/cl-unicode-0.1.5.ebuild
new file mode 100644
index 000000000000..bff440548364
--- /dev/null
+++ b/dev-lisp/cl-unicode/cl-unicode-0.1.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3 xdg-utils
+
+MY_P="v${PV}"
+
+DESCRIPTION="Provides Common Lisp implementations with knowledge about Unicode characters."
+HOMEPAGE="http://weitz.de/cl-unicode/"
+SRC_URI="https://github.com/edicl/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+DEPEND="virtual/commonlisp
+ dev-lisp/flexi-streams"
+RDEPEND="dev-lisp/cl-ppcre"
+
+src_configure() {
+ xdg_environment_reset
+}
+
+src_compile() {
+ # cl-unicode builds parts of its source code automatically the first time it
+ # is compiled, so we compile it here.
+ local initclunicode="(progn (push \"${S}/\" asdf:*central-registry*) (require :${PN}))"
+
+ common-lisp-export-impl-args "$(common-lisp-find-lisp-impl)"
+ ${CL_BINARY} ${CL_EVAL} "${initclunicode}"
+}
+
+src_install() {
+ common-lisp-install-sources *.lisp test/
+ common-lisp-install-sources -t all build/
+ common-lisp-install-asdf
+ dodoc CHANGELOG
+ dodoc doc/index.html
+}
diff --git a/dev-lisp/cl-unicode/metadata.xml b/dev-lisp/cl-unicode/metadata.xml
new file mode 100644
index 000000000000..739846335fdf
--- /dev/null
+++ b/dev-lisp/cl-unicode/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>common-lisp@gentoo.org</email>
+ <name>Gentoo Common Lisp Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ CL-UNICODE is a library which provides Common Lisp implementations
+ with knowledge about Unicode characters including their name, their
+ general category, the scripts and blocks they belong to, their
+ numerical value, and several other properties. It also provides the
+ ability to replace the standard syntax for reading Lisp characters
+ with one that is Unicode-aware and is used to enhance CL-PPCRE with
+ Unicode properties.
+ </longdescription>
+ <longdescription lang="es">
+ CL-UNICODE es una biblioteca que ofrece implmentaciones de Common
+ Lisp que reconoce caracteres Unicode incluyendo su nombre, categoría
+ general, los guiones y bloques a los que pertenecen, su valor
+ numérico y algunas otras propiedades. También ofrece la capacidad
+ de reemplazar la sintaxis estándar para la lectura de caracteres
+ Lisp por otra que reconoce Unicode y se utiliza para mejorar
+ CL-PPCRE con propiedades Unicode.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">edicl/cl-unicode</remote-id>
+ </upstream>
+</pkgmetadata>