summaryrefslogtreecommitdiff
path: root/dev-lisp/cl-ppcre
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-lisp/cl-ppcre
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lisp/cl-ppcre')
-rw-r--r--dev-lisp/cl-ppcre/Manifest3
-rw-r--r--dev-lisp/cl-ppcre/cl-ppcre-2.0.11.ebuild30
-rw-r--r--dev-lisp/cl-ppcre/metadata.xml33
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-lisp/cl-ppcre/Manifest b/dev-lisp/cl-ppcre/Manifest
new file mode 100644
index 000000000000..41258222b4bd
--- /dev/null
+++ b/dev-lisp/cl-ppcre/Manifest
@@ -0,0 +1,3 @@
+DIST cl-ppcre-2.0.11.tar.gz 158418 BLAKE2B d65aa1a565dbe6c9d10e4dafe323ab1332929e46e00ea2e9775ad940ed5ac983520c0e423daa17bf0173420d2269b5af2fd9b52f8d3dbcb0c778e03e61ef052d SHA512 c693c568065c0571e5509599018e58951425a857cec3793312af0d22e248e32233f924eafc8ba67fbedad38cb3f4efa11343b785b073eaac53c31871422488b1
+EBUILD cl-ppcre-2.0.11.ebuild 714 BLAKE2B 6ac97f59ba11da102219ac54c28ef70b8880d0104296506c1f4fb348f508c9029d05dbfdf94a943c98e515dd13c6884f6b836812896f4d673c3bbe30473a99d8 SHA512 989a3f6dbf2468d8bf3dfb8e70a6189acd7fc63cee69bea26a81519d777a96b03d7722a2d9651f7cf82d1933dba1a5a912d0782bb520300dbc78e875caf551cc
+MISC metadata.xml 1060 BLAKE2B 0cf37fa128f6a0d3995cee3f201206f60258ec3d9ceb57850880ab12d9b05671ae6061e7970784252bce9f340929dc59f3d48416c55069c8e9380e6bda38436f SHA512 fac4dca2369c4b636209e7406122b2dbb490a2ba35bd0d4e04ec58e6777f09ef5a1a0a4ddecb07beee2aa34a887e819acacac195c1a928ba6c1e06a7af7204b4
diff --git a/dev-lisp/cl-ppcre/cl-ppcre-2.0.11.ebuild b/dev-lisp/cl-ppcre/cl-ppcre-2.0.11.ebuild
new file mode 100644
index 000000000000..df216d535ff0
--- /dev/null
+++ b/dev-lisp/cl-ppcre/cl-ppcre-2.0.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3
+
+DESCRIPTION="CL-PPCRE is a portable regular expression library for Common Lisp."
+HOMEPAGE="http://weitz.de/cl-ppcre/
+ http://www.cliki.net/cl-ppcre"
+SRC_URI="https://github.com/edicl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="dev-lisp/flexi-streams"
+PDEPEND="dev-lisp/cl-ppcre-unicode"
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+ rm -rf cl-ppcre-unicode test/unicode*
+}
+
+src_install() {
+ common-lisp-install-sources *.lisp test/
+ common-lisp-install-asdf ${PN}
+ dodoc CHANGELOG doc/index.html
+}
diff --git a/dev-lisp/cl-ppcre/metadata.xml b/dev-lisp/cl-ppcre/metadata.xml
new file mode 100644
index 000000000000..36bca3f8dbdf
--- /dev/null
+++ b/dev-lisp/cl-ppcre/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>common-lisp@gentoo.org</email>
+ <name>Gentoo Common Lisp Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ CL-PPCRE is a portable regular expression library for Common Lisp
+ which has the following features:
+
+ * compatible with Perl
+ * fast (outperforms Perl)
+ * portable (ANSI Common Lisp)
+ * thread-safe
+ * includes convenience features
+ * well-documented
+ </longdescription>
+ <longdescription lang="es">
+ CL-PPCRE es una biblioteca de expressiones regulares portable
+ para Common Lisp que tiene las siguientes características:
+
+ * Compatible con Perl
+ * Rápida (más rápida que la versión para Perl)
+ * Portable (ANSI Common Lisp)
+ * Segura en la ejecución de hilos (thread-safe)
+ * Incluye características para hacerla cómoda
+ * Bien documentada
+ </longdescription>
+ <upstream>
+ <remote-id type="github">edicl/cl-ppcre</remote-id>
+ </upstream>
+</pkgmetadata>