summaryrefslogtreecommitdiff
path: root/dev-lisp/cl-ppcre-unicode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-lisp/cl-ppcre-unicode
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lisp/cl-ppcre-unicode')
-rw-r--r--dev-lisp/cl-ppcre-unicode/Manifest3
-rw-r--r--dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.0.11.ebuild26
-rw-r--r--dev-lisp/cl-ppcre-unicode/metadata.xml22
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-lisp/cl-ppcre-unicode/Manifest b/dev-lisp/cl-ppcre-unicode/Manifest
new file mode 100644
index 000000000000..319f01746f3d
--- /dev/null
+++ b/dev-lisp/cl-ppcre-unicode/Manifest
@@ -0,0 +1,3 @@
+DIST cl-ppcre-2.0.11.tar.gz 158418 BLAKE2B d65aa1a565dbe6c9d10e4dafe323ab1332929e46e00ea2e9775ad940ed5ac983520c0e423daa17bf0173420d2269b5af2fd9b52f8d3dbcb0c778e03e61ef052d SHA512 c693c568065c0571e5509599018e58951425a857cec3793312af0d22e248e32233f924eafc8ba67fbedad38cb3f4efa11343b785b073eaac53c31871422488b1
+EBUILD cl-ppcre-unicode-2.0.11.ebuild 639 BLAKE2B 85753d445f675c5b3d5be5360dbc63f68c3d03eda705ad2528342911ad815b0e2b4fe7b519b7c92b3e4c89443c635e61c2526ee28b1d1f25e08fc2bc3af5dd39 SHA512 2cd35a3f05ca5e96febb6886abce59229c65abf7b662b32deb8ed47f560606b6e6030a94bb9d19a2ebd43b6bbca1a989b78861dbaa2b82240c9f3162809bbe80
+MISC metadata.xml 647 BLAKE2B d8bfd48db3b7e6b455bbfdb1aeba49c14c3d958ca17089165d18776fc7a18068fdd8080e85944ed57cdb5d9b15ec504511396046308452012551706060b06c8b SHA512 297e93b9bb8205c5729834dcb3f5686001f0f1aeedc1df83701c1350a853104463b37dc902013cd6cbaeddc1b83b1102f29ae55ab7b8f0ad98b6fccecef2ef28
diff --git a/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.0.11.ebuild b/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.0.11.ebuild
new file mode 100644
index 000000000000..34ef1cfdf678
--- /dev/null
+++ b/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.0.11.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3
+
+DESCRIPTION="CL-PPCRE is a portable regular expression library for Common Lisp."
+HOMEPAGE="http://weitz.de/cl-ppcre/
+ http://www.cliki.net/cl-ppcre"
+SRC_URI="https://github.com/edicl/cl-ppcre/archive/v${PV}.tar.gz -> cl-ppcre-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="=dev-lisp/cl-ppcre-${PV}
+ dev-lisp/cl-unicode"
+
+S="${WORKDIR}/cl-ppcre-${PV}"
+
+src_install() {
+ common-lisp-install-sources ${PN}/ test/unicode*
+ common-lisp-install-asdf ${PN}
+}
diff --git a/dev-lisp/cl-ppcre-unicode/metadata.xml b/dev-lisp/cl-ppcre-unicode/metadata.xml
new file mode 100644
index 000000000000..f7036b0f160e
--- /dev/null
+++ b/dev-lisp/cl-ppcre-unicode/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>common-lisp@gentoo.org</email>
+ <name>Gentoo Common Lisp Project</name>
+ </maintainer>
+ <longdescription>
+ CL-PPCRE is a portable regular expression library for Common Lisp
+ which has the following features:
+
+ * compatible with Perl
+ * fast (outperforms Perl)
+ * portable (ANSI Common Lisp)
+ * thread-safe
+ * includes convenience features
+ * well-documented.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">edicl/cl-ppcre</remote-id>
+ </upstream>
+</pkgmetadata>