summaryrefslogtreecommitdiff
path: root/dev-lisp/c2ffi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-lisp/c2ffi
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-lisp/c2ffi')
-rw-r--r--dev-lisp/c2ffi/Manifest5
-rw-r--r--dev-lisp/c2ffi/c2ffi-9.0.0.20191017.ebuild26
-rw-r--r--dev-lisp/c2ffi/c2ffi-9.0.0.9999.ebuild (renamed from dev-lisp/c2ffi/c2ffi-8.0.0.9999.ebuild)12
-rw-r--r--dev-lisp/c2ffi/files/c2ffi-9.0.0.20191017-fix-lib-location.patch49
4 files changed, 86 insertions, 6 deletions
diff --git a/dev-lisp/c2ffi/Manifest b/dev-lisp/c2ffi/Manifest
index 94e0149fc234..3b5b5404e779 100644
--- a/dev-lisp/c2ffi/Manifest
+++ b/dev-lisp/c2ffi/Manifest
@@ -1,2 +1,5 @@
-EBUILD c2ffi-8.0.0.9999.ebuild 420 BLAKE2B d61f069a42debda210f3677ef5114e84ed7e9aeb72a4f1cc23f1e457280f35df834664fd3a96a58d4d35f30167fb293b0f277584b2356e329a057747994d41da SHA512 cf493464a8afbbdf964df0933dc61d9dabcbbcc12254b3c63d68908192f80f2551a64660b5b76bd9df8be98a61a812f91d894b839c4e31a7fe24f0e8378b4984
+AUX c2ffi-9.0.0.20191017-fix-lib-location.patch 1382 BLAKE2B 93f11c43da622cf4bf9e5ee495117ff8613720af543bbfe9ff2e70b4893f86c26aaa5880c8cdba1ee283b3a7e81a5584218427129dce1debd9a58879f56d65e6 SHA512 21556242a0efdbf7bad98ac624ae5854aa7527cfa00a6ccb7cae4af08d2ead7328aa637bdfb8d3637d133b7de2d6110e6096d7766010f039b017d63b7994f46d
+DIST c2ffi-9.0.0.20191017.tar.gz 35139 BLAKE2B a080f2cf7743aab630365fd305c106ada0318afb24093508c7667d8d702ec8dfd95a0ea9f54233a3a4b4c9b411e2f4aba5dacf7b2f35f1545b7ca63e765a7e55 SHA512 7a4743d89f431fd9ca42808358bdde03bbd85fc56f3350fddc94532c524ce373989671e706fadeb03eb240a81fb3f418176169acbf3ccd0f0f0c595d0f697832
+EBUILD c2ffi-9.0.0.20191017.ebuild 606 BLAKE2B 4e70b22a69be7691fd14d5fdb3758a5faa8fc2d6dfefb7cc0fa43a234487d3affcf1039033564535a65655a5c79ec5cdffc17687b82bc4449f32d66e37045bb0 SHA512 33f38a53aab0f89e0e8c3a7c4dc28ab23c8a403330e1806b22caeafc8e2e53f4dd61952d69250e6aed02e4d58818a5bcb7afb0d31094e301fd29c0b394168be1
+EBUILD c2ffi-9.0.0.9999.ebuild 498 BLAKE2B de121239dfcf89d7999063b85c32aa4400414df1df26fa0e51b60351d7f49cf333de22c9580fea7473c14b20b21daaa7aff202ac949d4a396f2c1fbf7e4b0f4d SHA512 18fc4778afaa607e68be7e8bf18a6575bdfe80b176b4ce77f50305f6962f65e35c772fc8594215dfc6ef79d6715881647f8e8f159a41c999fd57671a26a9e160
MISC metadata.xml 421 BLAKE2B 2df9693805f6968df30c8df0dbb1578c11b064b5f3b23f96321832c7551dbc751ebaeb81845147a7526f891b658aaaff8efeea185b239576e2885d3606944e87 SHA512 7bf517258ecbdf98192c055c451fe16315b34ac8875528b0fac4e844c15f2a4656d2252a88bbb642b54bc608a21d83af158cb5e6872b46e70d7c32f557b83de1
diff --git a/dev-lisp/c2ffi/c2ffi-9.0.0.20191017.ebuild b/dev-lisp/c2ffi/c2ffi-9.0.0.20191017.ebuild
new file mode 100644
index 000000000000..4f2748bb7f4c
--- /dev/null
+++ b/dev-lisp/c2ffi/c2ffi-9.0.0.20191017.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils llvm
+
+MY_COMMIT="15fda06de0bad97bf91f5590f7f24623eab2f580"
+
+DESCRIPTION="Clang-based FFI wrapper generator for Common Lisp"
+HOMEPAGE="https://github.com/rpav/c2ffi"
+SRC_URI="https://github.com/rpav/c2ffi/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="sys-devel/clang:9=
+ sys-devel/llvm:9=
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/c2ffi-${MY_COMMIT}"
+
+PATCHES=( "${FILESDIR}"/${PN}-9.0.0.20191017-fix-lib-location.patch )
diff --git a/dev-lisp/c2ffi/c2ffi-8.0.0.9999.ebuild b/dev-lisp/c2ffi/c2ffi-9.0.0.9999.ebuild
index 52bbf27c3bde..34977fe7f69d 100644
--- a/dev-lisp/c2ffi/c2ffi-8.0.0.9999.ebuild
+++ b/dev-lisp/c2ffi/c2ffi-9.0.0.9999.ebuild
@@ -3,18 +3,20 @@
EAPI=7
-inherit cmake-utils git-r3
+inherit cmake-utils git-r3 llvm
DESCRIPTION="Clang-based FFI wrapper generator for Common Lisp"
HOMEPAGE="https://github.com/rpav/c2ffi"
EGIT_REPO_URI="https://github.com/rpav/c2ffi.git"
-EGIT_BRANCH="llvm-8.0.0"
+EGIT_BRANCH="llvm-9.0.0"
LICENSE="LGPL-2.1"
-SLOT="8"
+SLOT="0"
IUSE=""
-DEPEND="sys-devel/clang:8
- sys-devel/llvm:8
+DEPEND="sys-devel/clang:9=
+ sys-devel/llvm:9=
"
RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-9.0.0.20191017-fix-lib-location.patch )
diff --git a/dev-lisp/c2ffi/files/c2ffi-9.0.0.20191017-fix-lib-location.patch b/dev-lisp/c2ffi/files/c2ffi-9.0.0.20191017-fix-lib-location.patch
new file mode 100644
index 000000000000..8b09b25aa739
--- /dev/null
+++ b/dev-lisp/c2ffi/files/c2ffi-9.0.0.20191017-fix-lib-location.patch
@@ -0,0 +1,49 @@
+From 3a496f89064de85af04ce101918c2ec5cebf7846 Mon Sep 17 00:00:00 2001
+From: Harald Judt <h.judt@gmx.at>
+Date: Fri, 8 Nov 2019 10:35:02 +0100
+Subject: Fix CLANG and LLVM libraries not found
+
+This commit gets the build working again here on Gentoo.
+
+Adding LLVM_LIBRARY_DIRS fixes the CLANG libs not found error.
+
+Adding llvm_map_components_to_libnames fixes LLMV not found error.
+---
+ CMakeLists.txt | 12 ++++++++++--
+ 1 file changed, 10 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 99dbe4b..f93b9b3 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -39,6 +39,15 @@ target_include_directories(c2ffi PUBLIC
+ ${LLVM_INCLUDE_DIRS}
+ ${SOURCE_ROOT}/src/include
+ )
++target_link_directories(c2ffi PUBLIC
++ ${LLVM_LIBRARY_DIRS}
++)
++message(STATUS "LLVM_LIBRARY_DIRS=${LLVM_LIBRARY_DIRS}")
++
++llvm_map_components_to_libnames(llvm_libs core support mcparser bitreader profiledata)
++
++message(STATUS "llvm_libs=${llvm_libs}")
++
+ target_link_libraries(c2ffi PUBLIC
+ clangFrontendTool
+ clangFrontend
+@@ -64,10 +73,9 @@ target_link_libraries(c2ffi PUBLIC
+ clangIndex
+ clangToolingCore
+ clangTooling
++ ${llvm_libs}
+ )
+
+-llvm_config(c2ffi USE_SHARED core support mcparser bitreader profiledata)
+-
+ set(APP_BIN_DIR "${CMAKE_BINARY_DIR}/bin")
+ set_target_properties(c2ffi PROPERTIES
+ RUNTIME_OUTPUT_DIRECTORY "${APP_BIN_DIR}"
+--
+2.23.0
+