summaryrefslogtreecommitdiff
path: root/dev-lisp/c2ffi/c2ffi-14.0.0.20220729-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
commitb89a664f266dab3b9b5ddac2cb874f8869142370 (patch)
tree21d127b0b99c1505ba548bc05975b9fcecda871e /dev-lisp/c2ffi/c2ffi-14.0.0.20220729-r1.ebuild
parent7e662ec84fc13cef513542e4030f47017d030187 (diff)
gentoo auto-resync : 13:10:2022 - 01:41:21
Diffstat (limited to 'dev-lisp/c2ffi/c2ffi-14.0.0.20220729-r1.ebuild')
-rw-r--r--dev-lisp/c2ffi/c2ffi-14.0.0.20220729-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-lisp/c2ffi/c2ffi-14.0.0.20220729-r1.ebuild b/dev-lisp/c2ffi/c2ffi-14.0.0.20220729-r1.ebuild
new file mode 100644
index 000000000000..a67ff86bbfa7
--- /dev/null
+++ b/dev-lisp/c2ffi/c2ffi-14.0.0.20220729-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LLVM_MAX_SLOT=14
+inherit cmake llvm
+
+MY_COMMIT="25fcec13381f495460f4a4eafdd1b939c799df4a"
+
+DESCRIPTION="Clang-based FFI wrapper generator for Common Lisp"
+HOMEPAGE="https://github.com/rpav/c2ffi"
+SRC_URI="https://github.com/rpav/c2ffi/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/c2ffi-${MY_COMMIT}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="sys-devel/clang:${LLVM_MAX_SLOT}
+ sys-devel/llvm:${LLVM_MAX_SLOT}"
+RDEPEND="${DEPEND}"