summaryrefslogtreecommitdiff
path: root/dev-lisp/alexandria
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-lisp/alexandria
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-lisp/alexandria')
-rw-r--r--dev-lisp/alexandria/Manifest5
-rw-r--r--dev-lisp/alexandria/alexandria-1.4.ebuild39
-rw-r--r--dev-lisp/alexandria/alexandria-20171029.ebuild39
-rw-r--r--dev-lisp/alexandria/files/alexandria-fix-docstrings.patch29
4 files changed, 41 insertions, 71 deletions
diff --git a/dev-lisp/alexandria/Manifest b/dev-lisp/alexandria/Manifest
index d171eee397d2..95dcfc073c98 100644
--- a/dev-lisp/alexandria/Manifest
+++ b/dev-lisp/alexandria/Manifest
@@ -1,4 +1,3 @@
-AUX alexandria-fix-docstrings.patch 1128 BLAKE2B 2f632045dd9871665b436aff50bf2e2a66058c4cde46e6f337abc98a9252fbdb7ccc69e68fc555e367057e3f9985ae559cee5dce2e2d8482098f7c47e413185b SHA512 04b80319839f3f39f1156a7604eb2565419a203e9c5520f6fd773f1865b57bade58e13769a26c03292ef666839b89fd5abb6dd5f952718513449f4862be5d2e9
-DIST alexandria-20171029.tar.bz2 45812 BLAKE2B 812f43483a0b25e4c4d481deec90ac1681a3c76062f5bf43b14530b239b2978e8d0cf735249b1093298db2761dc80a7d81e54da1e763db469b691b60d6db5d20 SHA512 a0a7386af94bae00139e3d06306169883cb1c5498c84d7a6db552a5dfa2ff8516d62609cb8a059c11f4200d507737ba99032d81b5a97112a2f3e7850572060e2
-EBUILD alexandria-20171029.ebuild 869 BLAKE2B cb6b94b705822a000f07740e0e3a909857b4ea886505a3503824a0093c851d04a8c087266e90331ea0f23aaa8aa21e85b34f410aa23ab0dbc9e5f2df9b78caa2 SHA512 c614e70b4acd377a65c92141d9a79166c6fa58b705538327f7e1ca0c69f75e2797b345e7569a6e611d630fbd4d6a96c72da91b4ce5d70e89bea5898fcd9ee87b
+DIST alexandria-v1.4.tar.gz 57634 BLAKE2B e552d44f0b4db326f09246f88af57ccd233dbb3b4354d2b9a55c8b9ddaf441016010fb4645f32ad0fbc82fb6755957fe7c989c67af62dd04f39baf78478e4b1c SHA512 4343be8eb2bac1924aaa8c890895aa885205af4c84110d7f8ceaf6c9ba1390e6037ffa3697fd1630266aede01bb596fd84c332ca43ded80326795637583332af
+EBUILD alexandria-1.4.ebuild 883 BLAKE2B 4a428d01464391d552e02a5c3de85b53c659b20fbf275e7c50baa2fd646cf0afba54be160e4f7f3475bcd9a7cfaf53718bcebb7ac3652ded249944d5550375b5 SHA512 1106aaee3045092b2359d78200b1b326db9d09eb67e7ec7289a8b9540c3ee7f2b419fef5d20c4a660b8cab6c277426a54c44b185b65d986ffb4263ff38a46839
MISC metadata.xml 2285 BLAKE2B c0b9cd300876a62c2b414e06b2bf5546e03c9903bb807bda1cec1c45f84afb775efd3c34649b701545fad9ddb812c1933b2bb314f40882f030fe6c67c5459a4d SHA512 e91b92f790466ef2b3688c8f93c7c0ff00d06d7b81818225655a60b79a213f0c2306a3e2dd073c2c6e2a227ddc86eff7603a9bb67d63cc971e3378b73d076c44
diff --git a/dev-lisp/alexandria/alexandria-1.4.ebuild b/dev-lisp/alexandria/alexandria-1.4.ebuild
new file mode 100644
index 000000000000..e1ecae812700
--- /dev/null
+++ b/dev-lisp/alexandria/alexandria-1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit common-lisp-3
+
+DESCRIPTION="A collection of portable utilities for Common Lisp"
+HOMEPAGE="http://common-lisp.net/project/alexandria/ https://gitlab.common-lisp.net/alexandria/alexandria"
+SRC_URI="https://gitlab.common-lisp.net/${PN}/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
+S="${WORKDIR}/${PN}-v${PV}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+# sbcl is hardcoded in Makefile
+BDEPEND="doc? (
+ dev-lisp/sbcl
+ sys-apps/texinfo
+)
+"
+
+DOCS=( README AUTHORS )
+
+src_compile() {
+ use doc && emake -C doc
+}
+
+src_install() {
+ common-lisp-install-sources -t all alexandria-1 alexandria-2 LICENCE
+ common-lisp-install-asdf
+ if use doc; then
+ doinfo doc/${PN}.info
+ HTML_DOCS=( doc/{"${PN}.html","${PN}.pdf"} )
+ fi
+ einstalldocs
+}
diff --git a/dev-lisp/alexandria/alexandria-20171029.ebuild b/dev-lisp/alexandria/alexandria-20171029.ebuild
deleted file mode 100644
index 9d6ceebd20e6..000000000000
--- a/dev-lisp/alexandria/alexandria-20171029.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit common-lisp-3
-
-DESCRIPTION="A collection of portable utilities for Common Lisp"
-HOMEPAGE="http://common-lisp.net/project/alexandria/"
-if [[ ${PV} == 9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.common-lisp.net/alexandria/alexandria.git"
-else
- SRC_URI="mirror://gentoo/${P}.tar.bz2"
- KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-fi
-
-LICENSE="public-domain"
-SLOT="0"
-IUSE="doc"
-
-DEPEND="doc? ( sys-apps/texinfo )"
-RDEPEND=""
-
-src_prepare() {
- eapply "${FILESDIR}/${PN}-fix-docstrings.patch"
- eapply_user
-}
-
-src_compile() {
- use doc && emake -C doc
-}
-
-src_install() {
- common-lisp-install-sources -t all *.lisp LICENCE
- common-lisp-install-asdf
- dodoc README AUTHORS
- use doc && doinfo doc/${PN}.info && dodoc doc/{"${PN}.html","${PN}.pdf"}
-}
diff --git a/dev-lisp/alexandria/files/alexandria-fix-docstrings.patch b/dev-lisp/alexandria/files/alexandria-fix-docstrings.patch
deleted file mode 100644
index 747c9e3bf59d..000000000000
--- a/dev-lisp/alexandria/files/alexandria-fix-docstrings.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff -Nuar a/doc/docstrings.lisp b/doc/docstrings.lisp
---- a/doc/docstrings.lisp 2016-12-11 00:04:21.272877121 +0100
-+++ b/doc/docstrings.lisp 2016-12-11 00:05:03.752876882 +0100
-@@ -718,7 +718,7 @@
- ;; sbcl.texinfo defines macros that expand @&key and friends to &key.
- (mapcar (lambda (name)
- (if (member name lambda-list-keywords)
-- (format nil "@~A" name)
-+ (format nil "~A" name)
- name))
- (lambda-list doc)))))
-
-@@ -833,11 +833,11 @@
- (flet ((macro (name)
- (let ((string (string-downcase name)))
- (format *texinfo-output* "@macro ~A~%~A~%@end macro~%" string string))))
-- (macro '&allow-other-keys)
-- (macro '&optional)
-- (macro '&rest)
-- (macro '&key)
-- (macro '&body)))
-+ (macro 'allow-other-keys)
-+ (macro 'optional)
-+ (macro 'rest)
-+ (macro 'key)
-+ (macro 'body)))
-
- (defun generate-includes (directory packages &key (base-package :cl-user))
- "Create files in `directory' containing Texinfo markup of all