summaryrefslogtreecommitdiff
path: root/dev-libs/zlog/zlog-1.2.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-libs/zlog/zlog-1.2.15.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-libs/zlog/zlog-1.2.15.ebuild')
-rw-r--r--dev-libs/zlog/zlog-1.2.15.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/zlog/zlog-1.2.15.ebuild b/dev-libs/zlog/zlog-1.2.15.ebuild
new file mode 100644
index 000000000000..12d8d51008b2
--- /dev/null
+++ b/dev-libs/zlog/zlog-1.2.15.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A reliable, thread safe, clear-model, pure C logging library."
+HOMEPAGE="http://hardysimpson.github.io/zlog/"
+SRC_URI="https://github.com/HardySimpson/${PN}/archive/${PV}.tar.gz -> ${PN}-v${PV}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+PATCHES="${FILESDIR}/zlog_no_static_lib.patch"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_test() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" test
+}
+
+src_install() {
+ emake LIBRARY_PATH="$(get_libdir)" PREFIX="${D}/usr" install
+}