summaryrefslogtreecommitdiff
path: root/dev-libs/zlog/zlog-1.2.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/zlog/zlog-1.2.12.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/zlog/zlog-1.2.12.ebuild')
-rw-r--r--dev-libs/zlog/zlog-1.2.12.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/zlog/zlog-1.2.12.ebuild b/dev-libs/zlog/zlog-1.2.12.ebuild
new file mode 100644
index 000000000000..be45a805faac
--- /dev/null
+++ b/dev-libs/zlog/zlog-1.2.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="A reliable, thread safe, clear-model, pure C logging library."
+HOMEPAGE="http://hardysimpson.github.io/zlog/"
+SRC_URI="https://github.com/HardySimpson/${PN}/archive/${PV}.tar.gz -> ${PN}-v${PV}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default_src_prepare
+ epatch "${FILESDIR}/zlog_no_werr.patch"
+}
+
+src_test () {
+ emake test || die "Tests failed."
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+}