summaryrefslogtreecommitdiff
path: root/dev-libs/yyjson/yyjson-0.7.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-15 12:15:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-15 12:15:20 +0100
commit4f064d2f2d61a575a6e418623bd2dc3c8599ad13 (patch)
treeb4969a550417293bfcb239af37c68d8578a706a6 /dev-libs/yyjson/yyjson-0.7.0-r1.ebuild
parent78f392693b4d21958c3f9e73171c7c65cb437bb5 (diff)
gentoo auto-resync : 15:08:2023 - 12:15:20
Diffstat (limited to 'dev-libs/yyjson/yyjson-0.7.0-r1.ebuild')
-rw-r--r--dev-libs/yyjson/yyjson-0.7.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/yyjson/yyjson-0.7.0-r1.ebuild b/dev-libs/yyjson/yyjson-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..506382b3e617
--- /dev/null
+++ b/dev-libs/yyjson/yyjson-0.7.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Fast JSON library in C"
+HOMEPAGE="https://github.com/ibireme/yyjson https://ibireme.github.io/yyjson/doc/doxygen/html/"
+SRC_URI="https://github.com/ibireme/yyjson/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT test? ( BSD )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.0-disable-werror.patch
+ "${FILESDIR}"/${PN}-0.7.0-fix-clang-16-valgrind.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DYYJSON_BUILD_DOC=$(usex doc)
+ -DYYJSON_BUILD_TESTS=$(usex test)
+ -DYYJSON_ENABLE_VALGRIND=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ use doc && dodoc -r "${BUILD_DIR}"/doxygen/html
+}