summaryrefslogtreecommitdiff
path: root/dev-libs/yajl/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/yajl/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/yajl/files')
-rw-r--r--dev-libs/yajl/files/yajl-2.0.4-pkgconfig_multilib.patch40
-rw-r--r--dev-libs/yajl/files/yajl-fix_static_linking.patch24
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/yajl/files/yajl-2.0.4-pkgconfig_multilib.patch b/dev-libs/yajl/files/yajl-2.0.4-pkgconfig_multilib.patch
new file mode 100644
index 000000000000..4a01848acd49
--- /dev/null
+++ b/dev-libs/yajl/files/yajl-2.0.4-pkgconfig_multilib.patch
@@ -0,0 +1,40 @@
+From 409098e97292aa1698ddff7f34dd8099db41a550 Mon Sep 17 00:00:00 2001
+From: ksergey <inndie@gmail.com>
+Date: Tue, 28 Jan 2014 00:35:36 -0500
+Subject: [PATCH] fixed pkgconfig file path
+
+---
+ src/CMakeLists.txt | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index e36b736..27b7c7d 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -30,7 +30,7 @@ ADD_DEFINITIONS(-DYAJL_BUILD)
+ # set up some paths
+ SET (libDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/lib)
+ SET (incDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/include/yajl)
+-SET (shareDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/share/pkgconfig)
++SET (pkgConfigDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/lib/pkgconfig)
+
+ # set the output path for libraries
+ SET(LIBRARY_OUTPUT_PATH ${libDir})
+@@ -61,7 +61,7 @@ FILE(MAKE_DIRECTORY ${incDir})
+ # generate build-time source
+ SET(dollar $)
+ CONFIGURE_FILE(api/yajl_version.h.cmake ${incDir}/yajl_version.h)
+-CONFIGURE_FILE(yajl.pc.cmake ${shareDir}/yajl.pc)
++CONFIGURE_FILE(yajl.pc.cmake ${pkgConfigDir}/yajl.pc)
+
+ # copy public headers to output directory
+ FOREACH (header ${PUB_HDRS})
+@@ -82,5 +82,5 @@ IF(NOT WIN32)
+ INSTALL(TARGETS yajl_s ARCHIVE DESTINATION lib${LIB_SUFFIX})
+ INSTALL(FILES ${PUB_HDRS} DESTINATION include/yajl)
+ INSTALL(FILES ${incDir}/yajl_version.h DESTINATION include/yajl)
+- INSTALL(FILES ${shareDir}/yajl.pc DESTINATION share/pkgconfig)
++ INSTALL(FILES ${pkgConfigDir}/yajl.pc DESTINATION lib${LIB_SUFFIX}/pkgconfig)
+ ENDIF()
+--
+1.8.5.5
diff --git a/dev-libs/yajl/files/yajl-fix_static_linking.patch b/dev-libs/yajl/files/yajl-fix_static_linking.patch
new file mode 100644
index 000000000000..56bf0e737319
--- /dev/null
+++ b/dev-libs/yajl/files/yajl-fix_static_linking.patch
@@ -0,0 +1,24 @@
+diff -urN lloyd-yajl-f4baae0.old//reformatter/CMakeLists.txt lloyd-yajl-f4baae0//reformatter/CMakeLists.txt
+--- lloyd-yajl-f4baae0.old//reformatter/CMakeLists.txt 2010-07-22 00:12:15.000000000 +0200
++++ lloyd-yajl-f4baae0//reformatter/CMakeLists.txt 2011-02-11 19:28:40.006756997 +0100
+@@ -42,7 +42,7 @@
+
+ ADD_EXECUTABLE(json_reformat ${SRCS})
+
+-TARGET_LINK_LIBRARIES(json_reformat yajl_s)
++TARGET_LINK_LIBRARIES(json_reformat yajl)
+
+ # copy the binary into the output directory
+ GET_TARGET_PROPERTY(binPath json_reformat LOCATION)
+diff -urN lloyd-yajl-f4baae0.old//verify/CMakeLists.txt lloyd-yajl-f4baae0//verify/CMakeLists.txt
+--- lloyd-yajl-f4baae0.old//verify/CMakeLists.txt 2010-07-22 00:12:15.000000000 +0200
++++ lloyd-yajl-f4baae0//verify/CMakeLists.txt 2011-02-11 19:28:58.296756998 +0100
+@@ -42,7 +42,7 @@
+
+ ADD_EXECUTABLE(json_verify ${SRCS})
+
+-TARGET_LINK_LIBRARIES(json_verify yajl_s)
++TARGET_LINK_LIBRARIES(json_verify yajl)
+
+ # copy in the binary
+ GET_TARGET_PROPERTY(binPath json_verify LOCATION)