summaryrefslogtreecommitdiff
path: root/dev-libs/xxhash
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /dev-libs/xxhash
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'dev-libs/xxhash')
-rw-r--r--dev-libs/xxhash/Manifest3
-rw-r--r--dev-libs/xxhash/metadata.xml12
-rw-r--r--dev-libs/xxhash/xxhash-0.6.4.ebuild24
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/xxhash/Manifest b/dev-libs/xxhash/Manifest
new file mode 100644
index 000000000000..c8ee43431d12
--- /dev/null
+++ b/dev-libs/xxhash/Manifest
@@ -0,0 +1,3 @@
+DIST xxhash-0.6.4.tar.gz 28995 BLAKE2B 2556ac14e6a6b1341adeeba244ad5bac7b52ff43b5d85acfc51de903771f1a7b32defeab657db765d21a33ec49aee1a892617d6656a152ad5ce6e1636a743e18 SHA512 6c914bac5092dfd01349c8223c382d3c13ba1b22e08300ce86ea9663a9a934f930debdeb71c14365ec57d72b95088a4354da92dfb7fcf7d07ec01c0f4fb70ca7
+EBUILD xxhash-0.6.4.ebuild 602 BLAKE2B 0893da7a8e081a13e40d97167e8784edab1494b1e3bfd107ec7baebb7c261bedda06cf4b6310c8ddbeb277c8c2a5edbccb3ba06de66ce1307c7729c9d0396bf7 SHA512 77a9f7b217cf6d664a80ef707e1d5c1c99eb60a4ae86f3506542676f73991831fe16ca62b52237d18f58c3688be0f36363771fd2513871728ca035873bb1866a
+MISC metadata.xml 392 BLAKE2B 6a06ef26d04abe71ca14dda2435abf49b8f1adffbca5b0af6947b73e48bb6696b216bc6da4b5cdcf9eb61ead18154af6e51679b1be350d063eaccad5a5c86303 SHA512 96be044c0faa5d67ebe60b1d1c11ce876ad3e031d605846d6623a51cf0f57615db3855dda4ff129190bc12b137c9c05395464efb150ad57da4804b852ee6802e
diff --git a/dev-libs/xxhash/metadata.xml b/dev-libs/xxhash/metadata.xml
new file mode 100644
index 000000000000..ffe46e89cab8
--- /dev/null
+++ b/dev-libs/xxhash/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>amadio@gentoo.org</email>
+ <name>Guilherme Amadio</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Cyan4973/xxHash</remote-id>
+ <bugs-to>https://github.com/Cyan4973/xxHash/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/xxhash/xxhash-0.6.4.ebuild b/dev-libs/xxhash/xxhash-0.6.4.ebuild
new file mode 100644
index 000000000000..e21fdc1aa0d7
--- /dev/null
+++ b/dev-libs/xxhash/xxhash-0.6.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Extremely fast non-cryptographic hash algorithm"
+HOMEPAGE="http://www.xxhash.com"
+SRC_URI="https://github.com/Cyan4973/xxHash/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND=""
+
+S="${WORKDIR}/xxHash-${PV}"
+
+src_install() {
+ PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" emake DESTDIR="${D}" install
+ if ! use static-libs ; then
+ rm "${ED}"/usr/$(get_libdir)/libxxhash.a || die
+ fi
+}