summaryrefslogtreecommitdiff
path: root/dev-libs/xmlrpc-c
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-libs/xmlrpc-c
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-libs/xmlrpc-c')
-rw-r--r--dev-libs/xmlrpc-c/Manifest4
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.51.06-r2.ebuild4
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.54.05.ebuild76
3 files changed, 82 insertions, 2 deletions
diff --git a/dev-libs/xmlrpc-c/Manifest b/dev-libs/xmlrpc-c/Manifest
index 0c1f48bdefca..70efe38f79b2 100644
--- a/dev-libs/xmlrpc-c/Manifest
+++ b/dev-libs/xmlrpc-c/Manifest
@@ -1,3 +1,5 @@
DIST xmlrpc-c-1.51.06.tgz 933161 BLAKE2B 8023444e14e7e41f5433cebeb0fcb7a7323dd734f658155e117d3547b4d61ef81c189395662bf68074dcf1ec5c47ee550cd18773ce8bf0bd53cb0a1764cce945 SHA512 2927fc8c01d42b6f838d8b0c839f09a7dd0d1ddc5a3d7b36c9d479f1c7bf7fdf14923f640883f98ba66067eda0f5379737bf3a5bc9d4b9abe1a7eff7d7def066
-EBUILD xmlrpc-c-1.51.06-r2.ebuild 2067 BLAKE2B 27d86c5e7121e26db6bea1cf4944502f97029255e7db2f9fc2bd8f7131eb25ec4a58ad3734b9efd5998c7bbb90d7631bee625ab2a64e92e554b1c57879e28dba SHA512 7a7b0e51672b25172015a1aeebf2009d9bd7d70b29da33b27d4a9216a7390503fa69407e6c1d772bebb3c63909d0963ddaec81d7ef75a22a4acf916dabdb746a
+DIST xmlrpc-c-1.54.05.tgz 933228 BLAKE2B 50d73fe22454f04ffebf11d4b88986eaac571d107abce4e04244ad0b74469fc5233178967e3dd832a8525514912e4f835fa1ce13c439caf918a2b2d0c05021a0 SHA512 81bf8f398e9cb73b421907d8e304b9a6dc8da931f573f7296457486ade432f4a00a94b6850391690f7b229928f785522e5852db8aca68cb462c71d139e4f27b1
+EBUILD xmlrpc-c-1.51.06-r2.ebuild 2176 BLAKE2B f6b372741bbc6cddaaf967ab17433632866172f97626ea817d0ee487707b1cb9398224d3703989e96e0fe1f6e2309057aae4a92f9d3098b37acd5a748dea2e94 SHA512 b9f7aa3a4b26d1a7af841d6717c95b62d5d3f7aa77594e0e8bebe9b052107d84f15011ff453895f786da5298f14faea427c1f0847c0605205b439f3154349016
+EBUILD xmlrpc-c-1.54.05.ebuild 2182 BLAKE2B 45d6e9e9db40438a650ac2022ac151d6082e6c68c65bccabe8ebb1f8d0f8940f14a053af25ab768b778fa81f0c7211afa90750b68959f0e5fbcf71b2c595e524 SHA512 79452c94a3dd4f4fd43a6e0a88e4d3c6e08ce7db84d4e955d25f57611452122e79daa8aede48abfb8baefe714efe96108131b17040160ca6301da21724732309
MISC metadata.xml 617 BLAKE2B b0c8cee5453b850768e8c91bcd2cbe265eb19956644798b3219c9739ec666bedb543e924d2e4fce6874bdab3ac865c4ce94ba5032775fcc2359804ede0c92053 SHA512 729a5c14973bb4bd11a138299e05db0c43dce67a58a9eb4bb60600b097c1fc479231dea287ef9e824a093c9cf15064adb9bc6e0dee2820078c2ee79d9ea9d581
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.51.06-r2.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.51.06-r2.ebuild
index 29b329aaa875..54cf9c58c907 100644
--- a/dev-libs/xmlrpc-c/xmlrpc-c-1.51.06-r2.ebuild
+++ b/dev-libs/xmlrpc-c/xmlrpc-c-1.51.06-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -64,6 +64,8 @@ multilib_src_configure() {
multilib_src_compile() {
default_src_compile
+ # Needed for tests, bug #836469
+ cp "${BUILD_DIR}"/include/xmlrpc-c/config.h "${S}"/include/xmlrpc-c || die
# Tools building is broken in this release
#multilib_is_native_abi && use tools && emake -rC "${S}"/tools
}
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.54.05.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.54.05.ebuild
new file mode 100644
index 000000000000..05c4799f8bdf
--- /dev/null
+++ b/dev-libs/xmlrpc-c/xmlrpc-c-1.54.05.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+# Upstream maintains 3 release channels: http://xmlrpc-c.sourceforge.net/release.html
+# 1. Only the "Super Stable" series is released as a tarball
+# 2. SVN tagging of releases seems spotty: http://svn.code.sf.net/p/xmlrpc-c/code/release_number/
+# Because of this, we are following the "Super Stable" release channel
+
+DESCRIPTION="A lightweigt RPC library based on XML and HTTP"
+HOMEPAGE="http://xmlrpc-c.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0/4.54"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="abyss +cgi +curl +cxx +libxml2 threads test"
+
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="test? ( abyss curl cxx )"
+
+RDEPEND="
+ sys-libs/ncurses:0=[${MULTILIB_USEDEP}]
+ sys-libs/readline:0=[${MULTILIB_USEDEP}]
+ curl? ( net-misc/curl[${MULTILIB_USEDEP}] )
+ libxml2? ( dev-libs/libxml2[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use curl || ewarn "Curl support disabled: No client library will be built"
+}
+
+src_prepare() {
+ sed -i \
+ -e "/CFLAGS_COMMON/s|-g -O3$||" \
+ -e "/CXXFLAGS_COMMON/s|-g$||" \
+ common.mk || die
+
+ default
+
+ # Out-of-source install phase is broken
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-libwww-client \
+ --disable-wininet-client \
+ --without-libwww-ssl \
+ $(use_enable abyss abyss-server) \
+ $(use_enable cgi cgi-server) \
+ $(use_enable curl curl-client) \
+ $(use_enable cxx cplusplus) \
+ $(use_enable libxml2 libxml2-backend) \
+ $(use_enable threads abyss-threads)
+}
+
+multilib_src_compile() {
+ default_src_compile
+ # Needed for tests, bug #836469
+ cp "${BUILD_DIR}"/include/xmlrpc-c/config.h "${S}"/include/xmlrpc-c || die
+ # Tools building is broken in this release
+ #multilib_is_native_abi && use tools && emake -rC "${S}"/tools
+}
+
+#multilib_src_install_all() {
+# # Tools building is broken in this release
+# #use tools && emake DESTDIR="${D}" -rC "${S}"/tools install
+#}