summaryrefslogtreecommitdiff
path: root/dev-libs/wlc/wlc-0.0.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
commit73c318acdaf6f8309d68bd266051e6dd1f1bd787 (patch)
tree2878053f3e7faed19a1f82c733d3bd29df69991e /dev-libs/wlc/wlc-0.0.11.ebuild
parent2018227e9344edb9da15fc6a4a8298086cc2aa77 (diff)
gentoo resync : 08.06.2019
Diffstat (limited to 'dev-libs/wlc/wlc-0.0.11.ebuild')
-rw-r--r--dev-libs/wlc/wlc-0.0.11.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-libs/wlc/wlc-0.0.11.ebuild b/dev-libs/wlc/wlc-0.0.11.ebuild
deleted file mode 100644
index 9786fe291a83..000000000000
--- a/dev-libs/wlc/wlc-0.0.11.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="A helper library for Wayland compositors"
-HOMEPAGE="https://github.com/Cloudef/wlc"
-
-SRC_URI="https://github.com/Cloudef/wlc/releases/download/v${PV}/${P}.tar.bz2"
-
-LICENSE="MIT ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="X static-libs systemd +xwayland"
-
-RDEPEND="virtual/opengl
- virtual/libudev
- media-libs/mesa[wayland,gbm,gles2,egl]
- x11-libs/libdrm
- x11-libs/pixman
- x11-libs/libxkbcommon
- x11-misc/xkeyboard-config
- dev-libs/libinput
- dev-libs/wayland
- X? (
- x11-libs/libX11
- x11-libs/libxcb[xkb]
- x11-libs/xcb-util-image
- x11-libs/xcb-util-wm
- x11-libs/libXfixes
- )
- xwayland? (
- x11-libs/libxcb[xkb]
- x11-libs/xcb-util-image
- x11-libs/xcb-util-wm
- x11-base/xorg-server[wayland]
- )
- systemd? ( sys-apps/systemd sys-apps/dbus )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- >=dev-libs/wayland-protocols-1.7"
-
-src_configure() {
- local mycmakeargs=(
- -DWLC_BUILD_EXAMPLES=OFF
- -DWLC_BUILD_TESTS=OFF
-
- -DWLC_BUILD_STATIC=$(usex static-libs)
-
- -DWLC_X11_BACKEND_SUPPORT=$(usex X)
- -DWLC_XWAYLAND_SUPPORT=$(usex xwayland)
-
- $(cmake-utils_use_find_package systemd Systemd)
- $(cmake-utils_use_find_package systemd Dbus)
- )
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- if use X && ! use xwayland; then
- elog "xwayland use flag is required for X11 applications support"
- fi
-}