summaryrefslogtreecommitdiff
path: root/dev-libs/weston/weston-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-libs/weston/weston-9999.ebuild
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-libs/weston/weston-9999.ebuild')
-rw-r--r--dev-libs/weston/weston-9999.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/dev-libs/weston/weston-9999.ebuild b/dev-libs/weston/weston-9999.ebuild
index 44880eb96399..40aa43e4412b 100644
--- a/dev-libs/weston/weston-9999.ebuild
+++ b/dev-libs/weston/weston-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -25,7 +25,7 @@ fi
LICENSE="MIT CC-BY-SA-3.0"
SLOT="0"
-IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi jpeg +launch lcms rdp +resize-optimization screen-sharing static-libs +suid systemd test unwind wayland-compositor webp +X xwayland"
+IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi jpeg +launch lcms rdp remoting +resize-optimization screen-sharing static-libs +suid systemd test wayland-compositor webp +X xwayland"
REQUIRED_USE="
drm? ( gles2 )
@@ -38,13 +38,13 @@ REQUIRED_USE="
RDEPEND="
>=dev-libs/libinput-0.8.0
>=dev-libs/wayland-1.12.0
- >=dev-libs/wayland-protocols-1.8
+ >=dev-libs/wayland-protocols-1.14
lcms? ( media-libs/lcms:2 )
media-libs/libpng:0=
webp? ( media-libs/libwebp:0= )
jpeg? ( virtual/jpeg:0= )
>=x11-libs/cairo-1.11.3
- >=x11-libs/libdrm-2.4.30
+ >=x11-libs/libdrm-2.4.68
>=x11-libs/libxkbcommon-0.5.0
>=x11-libs/pixman-0.25.2
x11-misc/xkeyboard-config
@@ -55,7 +55,7 @@ RDEPEND="
colord? ( >=x11-misc/colord-0.1.27 )
dbus? ( >=sys-apps/dbus-1.6 )
drm? (
- media-libs/mesa[gbm]
+ >=media-libs/mesa-17.1[gbm]
>=sys-libs/mtdev-1.1.0
>=virtual/udev-136
)
@@ -63,13 +63,16 @@ RDEPEND="
gles2? (
media-libs/mesa[gles2,wayland]
)
- rdp? ( >=net-misc/freerdp-1.1.0_beta1_p20130710 )
+ rdp? ( >=net-misc/freerdp-1.1.0:= )
+ remoting? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ )
systemd? (
sys-auth/pambase[systemd]
>=sys-apps/systemd-209[pam]
)
launch? ( sys-auth/pambase )
- unwind? ( sys-libs/libunwind )
X? (
>=x11-libs/libxcb-1.9
x11-libs/libX11
@@ -95,11 +98,12 @@ src_prepare() {
}
src_configure() {
- local myconf
+ local myconf=()
+
if use examples || use test; then
- myconf="--enable-simple-clients"
+ myconf+=( --enable-simple-clients )
else
- myconf="--disable-simple-clients"
+ myconf+=( --disable-simple-clients )
fi
econf \
@@ -116,7 +120,7 @@ src_configure() {
$(use_enable launch weston-launch) \
$(use_enable colord) \
$(use_enable gles2 egl) \
- $(use_enable unwind libunwind) \
+ $(use_enable remoting) \
$(use_enable resize-optimization) \
$(use_enable screen-sharing) \
$(use_enable suid setuid-install) \
@@ -132,7 +136,7 @@ src_configure() {
--disable-simple-dmabuf-v4l-client \
--disable-simple-egl-clients \
--disable-vaapi-recorder \
- ${myconf}
+ "${myconf[@]}"
}
src_test() {