summaryrefslogtreecommitdiff
path: root/dev-libs/wayland
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
commitf616ce4660c92a3fcb4f05663c2ab47c9defa0c3 (patch)
tree66ba5228853030737ae2dd9c9894b96266213246 /dev-libs/wayland
parent1bfb8c3d7e00e7ff828008510f5a7568c81d8889 (diff)
gentoo auto-resync : 30:11:2022 - 01:22:10
Diffstat (limited to 'dev-libs/wayland')
-rw-r--r--dev-libs/wayland/Manifest3
-rw-r--r--dev-libs/wayland/wayland-1.21.0-r1.ebuild66
-rw-r--r--dev-libs/wayland/wayland-9999.ebuild9
3 files changed, 77 insertions, 1 deletions
diff --git a/dev-libs/wayland/Manifest b/dev-libs/wayland/Manifest
index 17ad0ab88e71..edc54fc7f278 100644
--- a/dev-libs/wayland/Manifest
+++ b/dev-libs/wayland/Manifest
@@ -1,4 +1,5 @@
DIST wayland-1.21.0.tar.xz 225936 BLAKE2B 2b43eb1517d476bb2b4daed1083373655b57d047968fdb93dbbbbe4235af12e25557627e30b5c3d2575bac4beaf1e0a0b8ef10a3c673538d9097501f33c05836 SHA512 5575216d30fdf5c63caa6bcad071e15f2a4f3acb12df776806073f65db37a50b5b5b3cc7957c5497636f4ac01893e2eaab26e453ded44b287acde01762f5fdc3
+EBUILD wayland-1.21.0-r1.ebuild 1675 BLAKE2B f278a266e2635568419ceed5bd71c12ad13f8bafc905912f11e9e20b9866ee7ef2b2fec255da0fd5e40aa9a448e6e3c3e93dfff254836a471b9ee94e1bf8ed83 SHA512 82972eec97e3a4a1b709edc74a52fa4e290044eb7e5addbf4c58677d1386b66fdb045669e64d1d7d1644858d15e91fd784c2641e50b4b297556b5f2c35e1b587
EBUILD wayland-1.21.0.ebuild 1478 BLAKE2B 0884da89055eb938e9dd782c9ad0e50358205e4752ed4600f8f216f08081f34252c9f1122edffd1123be6f3693d0fe4ddbfd3ad4d2a908e2410ba911d18e44ad SHA512 f6a4e29a0bd5c0bf567a378dd3a715ba3b1f37731777766591467707b426fa845c33e5726e69028093cd5debb300368a73d41190bcbc2e5132479ba0d1397fe4
-EBUILD wayland-9999.ebuild 1485 BLAKE2B 8e82cc08d4efab01be9e60daa08f568c9c2760cd5247f66ac2aac0886ec0dcb3b9d5cc262ed7612e08c77f97c08371b454a35f2af693eb6a8cc88a19c23575d0 SHA512 fbb427c35c1e5df874e99391438babcca5c943b548dfc8c4380e694979833045a94be367d920d696c9e5b332171351e2ff298214e7e82c0c4bbc42a669ca9f12
+EBUILD wayland-9999.ebuild 1675 BLAKE2B f278a266e2635568419ceed5bd71c12ad13f8bafc905912f11e9e20b9866ee7ef2b2fec255da0fd5e40aa9a448e6e3c3e93dfff254836a471b9ee94e1bf8ed83 SHA512 82972eec97e3a4a1b709edc74a52fa4e290044eb7e5addbf4c58677d1386b66fdb045669e64d1d7d1644858d15e91fd784c2641e50b4b297556b5f2c35e1b587
MISC metadata.xml 337 BLAKE2B af249efc25c3eadde73d0b49cba0e6c8a021fb4b7c9a0b96f27a4e71185c76f8ac7ff0b9efdfeadf2df324cfa578db3a73fc7bee8c249cba35d41e2145017e16 SHA512 771b226f8e16d8c570bc2ea89ee3c5176e1d0f2209afb3b2af5a9d19fbdc2037a411b84d546bea054449c8074fb0fb3c3726fb2692d084521c64cda60600c0b8
diff --git a/dev-libs/wayland/wayland-1.21.0-r1.ebuild b/dev-libs/wayland/wayland-1.21.0-r1.ebuild
new file mode 100644
index 000000000000..c232ff0e5669
--- /dev/null
+++ b/dev-libs/wayland/wayland-1.21.0-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/wayland.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+inherit meson-multilib
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="https://wayland.freedesktop.org/ https://gitlab.freedesktop.org/wayland/wayland"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ ~dev-util/wayland-scanner-${PV}
+ virtual/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.6[dot]
+ app-text/xmlto
+ >=media-gfx/graphviz-2.26.0
+ )
+"
+DEPEND="
+ >=dev-libs/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_bool doc documentation)
+ $(meson_native_true dtd_validation)
+ -Dlibraries=true
+ -Dscanner=false
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # We set it on purpose to only a short subdir name, as socket paths are
+ # created in there, which are 108 byte limited. With this it hopefully
+ # barely fits to the limit with /var/tmp/portage/${CATEGORY}/${PF}/temp/x
+ export XDG_RUNTIME_DIR="${T}"/x
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ multilib-minimal_src_test
+}
+
+src_install() {
+ meson-multilib_src_install
+
+ if use doc; then
+ mv "${ED}"/usr/share/doc/"${PN}"/* "${ED}"/usr/share/doc/"${PF}"/ || die
+ rmdir "${ED}"/usr/share/doc/"${PN}" || die
+ fi
+}
diff --git a/dev-libs/wayland/wayland-9999.ebuild b/dev-libs/wayland/wayland-9999.ebuild
index bbe4c3904bca..c232ff0e5669 100644
--- a/dev-libs/wayland/wayland-9999.ebuild
+++ b/dev-libs/wayland/wayland-9999.ebuild
@@ -55,3 +55,12 @@ src_test() {
multilib-minimal_src_test
}
+
+src_install() {
+ meson-multilib_src_install
+
+ if use doc; then
+ mv "${ED}"/usr/share/doc/"${PN}"/* "${ED}"/usr/share/doc/"${PF}"/ || die
+ rmdir "${ED}"/usr/share/doc/"${PN}" || die
+ fi
+}