summaryrefslogtreecommitdiff
path: root/dev-libs/wayland
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-libs/wayland
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-libs/wayland')
-rw-r--r--dev-libs/wayland/Manifest2
-rw-r--r--dev-libs/wayland/wayland-9999.ebuild57
2 files changed, 28 insertions, 31 deletions
diff --git a/dev-libs/wayland/Manifest b/dev-libs/wayland/Manifest
index f434bf8e74fb..28bcf51ce89f 100644
--- a/dev-libs/wayland/Manifest
+++ b/dev-libs/wayland/Manifest
@@ -1,4 +1,4 @@
DIST wayland-1.16.0.tar.xz 435216 BLAKE2B 862cc8ca9da060f9b8345aa0a62a4af76a31562246b75d2679bcf30cc894cc94ec28f97951f766b6e5297b2e113cd8b08e5682dacbfc79544c0085995693ec55 SHA512 64eca2b1c0bc7913508a5499dae87e2723c712d8024acbb4c77c3c4a6c20de78c10704ae9827fd034116ca540a547aeec28c5a1e3bd382b23f85231424b0f49c
EBUILD wayland-1.16.0.ebuild 1752 BLAKE2B f091f185f5ff13ec427e7a4eb10f7df7fed6f86aec4a5fd7c14ff470aa16c10273ae536cf677d5948b6e4416e4a8dc606f7eacd35f2044754dec0a575d95b9f2 SHA512 64fdb6c6dd3fc052e82d238e2675ce20b8aa3315e1e69931d8b338ae451b0e6afa2b605c3fa54bf1d93cf1a8c0f72499e0219bf7a6b9374a7922ad17217841c8
-EBUILD wayland-9999.ebuild 1763 BLAKE2B f8c1e3518caf8c3506c8d966a1ad804a626727358a9d34d31b3afb2a2ad25d304d282ad424b41f95d406ad3dc4044bb4b204c04572e8baaf1d8ec0c9878bd7c5 SHA512 0168aee43cef82ac67c1e1a44611d14a2a5454a23f54c6959d5d66a7210860567524f0b7a38354d391b339ae9393256338b531f63845784ca6ab02e053cbaacb
+EBUILD wayland-9999.ebuild 1715 BLAKE2B 2c9c6bca8dd1faf75ec9fc9abeaf4ec84951de07723b801a881bbbbba1281368245f50fd6bb11005f0fa7556863b9c6c77669fca94dbec215c56ccd5c920b54c SHA512 71bfe7ea68d5f391ac499b195f17a878cd3c77acb4dbd609fbf34d0365fc084b3ac413a1d62381c47d4fd48801d4bed02b8dffda9fbb097f47e709ffb693f8fd
MISC metadata.xml 230 BLAKE2B 70bf59e64305ef14908197f2aa7ffbc1769ade265097da68e001245451658af5921760c91cb74aae717543ea0017e2471fd94bfc5c4c447d2d60e2c23aa3b007 SHA512 d7a2643abd1904cc5ff4d91cbb6f1baeb7f75fd1db542c5e14f19412f4f0bd4b903f8e703a7662ba7482c79dac5529057760b6427599d35e0842755fd946e057
diff --git a/dev-libs/wayland/wayland-9999.ebuild b/dev-libs/wayland/wayland-9999.ebuild
index df8f72793cfe..7e909b198261 100644
--- a/dev-libs/wayland/wayland-9999.ebuild
+++ b/dev-libs/wayland/wayland-9999.ebuild
@@ -1,42 +1,41 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/wayland/wayland.git"
-
-if [[ ${PV} = 9999* ]]; then
- GIT_ECLASS="git-r3"
-fi
-
-inherit autotools libtool multilib-minimal toolchain-funcs $GIT_ECLASS
-
-DESCRIPTION="Wayland protocol libraries"
-HOMEPAGE="https://wayland.freedesktop.org/"
-
-if [[ $PV = 9999* ]]; then
- SRC_URI=""
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/wayland.git"
+ inherit git-r3
else
SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
+inherit autotools libtool multilib-minimal toolchain-funcs
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="https://wayland.freedesktop.org/"
LICENSE="MIT"
SLOT="0"
IUSE="doc static-libs"
-RDEPEND=">=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
- >=virtual/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]
- dev-libs/libxml2:=
- !<media-libs/mesa-18.1.1-r1"
-DEPEND="${RDEPEND}
+BDEPEND="
+ virtual/pkgconfig
doc? (
>=app-doc/doxygen-1.6[dot]
app-text/xmlto
>=media-gfx/graphviz-2.26.0
sys-apps/grep[pcre]
)
- virtual/pkgconfig"
+"
+DEPEND="
+ >=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
+ dev-libs/libxml2:=
+ >=virtual/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ !<media-libs/mesa-18.1.1-r1
+"
src_prepare() {
default
@@ -44,16 +43,14 @@ src_prepare() {
}
multilib_src_configure() {
- local myconf
- if tc-is-cross-compiler ; then
- myconf+=' --with-host-scanner '
- fi
+ local myeconfargs=(
+ --disable-static
+ $(multilib_native_use_enable doc documentation)
+ $(multilib_native_enable dtd-validation)
+ )
+ tc-is-cross-compiler && myeconfargs+=( --with-host-scanner )
- ECONF_SOURCE="${S}" econf \
- --disable-static \
- $(multilib_native_use_enable doc documentation) \
- $(multilib_native_enable dtd-validation) \
- ${myconf}
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {