summaryrefslogtreecommitdiff
path: root/dev-libs/wayland
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-libs/wayland
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-libs/wayland')
-rw-r--r--dev-libs/wayland/Manifest4
-rw-r--r--dev-libs/wayland/wayland-1.20.0.ebuild59
-rw-r--r--dev-libs/wayland/wayland-9999.ebuild6
3 files changed, 66 insertions, 3 deletions
diff --git a/dev-libs/wayland/Manifest b/dev-libs/wayland/Manifest
index bed86d4aa0bc..2a4c3af81f02 100644
--- a/dev-libs/wayland/Manifest
+++ b/dev-libs/wayland/Manifest
@@ -1,4 +1,6 @@
DIST wayland-1.19.0.tar.xz 456380 BLAKE2B 0f70bb02e890898c4763001884527067adb686abe9a2b9325badf1730d411d269c437037afc298eec8075eb1e3845f5b81b8ed3d702908388a54e7063cbea91a SHA512 d8a86f5e23e4a88e7c84b82fdb51eb350419086afe462ecb2f4d5c3ba9290ede310cbbcffd60215219ddccf5bad4adec21a5ebfbef6577200f66ac7a1b64a5ef
+DIST wayland-1.20.0.tar.xz 225188 BLAKE2B d607610ad8b30b6b3bbfc3945679f698030f271766cfb72425f98f170a96469fb085fb9a746a866b8562d7f452c844e61ad57f634dcf365474c7d050b76022e9 SHA512 e8a1f410994b947f850799bdd0d95a2429d8467f853e62a0ab3915a4e9fe130f8aa977e03715114ab740c6ec546edea63d275ce7f927d4f3029ea126e6a7d215
EBUILD wayland-1.19.0.ebuild 1469 BLAKE2B a44e69efbd172377a84d8bfe46ca35a9f10652f37ffc949d7b59d9130ea460ab42db6affacf076bc2bd574c70629d814cf829d452a88ae7cfc0c135097a08d72 SHA512 3a368fef2f2170c29ffc2598b0cf634109c10cb1d845803299a07a3a6634864650283190fe81cda401c2e4de488cdd0f632145a590caee959c25387461fe380f
-EBUILD wayland-9999.ebuild 1476 BLAKE2B f367b4aff2adba99306d601b4abe4c41fcf803eba363ef8f265e4893beafab9477ebdcc7f1373734cdb58ee0205aeb0dba0087691d858a649396cfede9f0adcf SHA512 1f5076f2c7699bdbd14d2d5e63c43eaee550d109a39709e1435204c721036af9eddb13bf4b6fa57d930e142347d2cfae139c037677e7474d967908b9d23578f9
+EBUILD wayland-1.20.0.ebuild 1516 BLAKE2B e22d931ee9acbbb3649fb888e0bbbe911a7ce34824fff5187c1476e0614d152b2f7afa9537561e3ec8791ec51fe0683c812e35081f456b729e193fbc649442c4 SHA512 08c911a8941744012b548c16278b9c687cbcac2487cef6cd4409081aad531a22b663aa5008ee7c14866364a7ef5ac95d73f69a9c50c296ab0ba3c7a71ce9e9e4
+EBUILD wayland-9999.ebuild 1516 BLAKE2B e22d931ee9acbbb3649fb888e0bbbe911a7ce34824fff5187c1476e0614d152b2f7afa9537561e3ec8791ec51fe0683c812e35081f456b729e193fbc649442c4 SHA512 08c911a8941744012b548c16278b9c687cbcac2487cef6cd4409081aad531a22b663aa5008ee7c14866364a7ef5ac95d73f69a9c50c296ab0ba3c7a71ce9e9e4
MISC metadata.xml 231 BLAKE2B 6373a9c04316f777f87754fbb7cbc856493138d32bdb05d1015946ebbb359c4b8adb9372554097833d5c9a20e00e32fa0a1c90995d9299dd2215a2cadcccbb73 SHA512 bf6ad5078a6775cd61d257939d41ec53d006124475da2949c55b4b3ac138ec85a88b9068c5920b1e781fadda963939b8f120f8864d82e10cf50e09cc8052a6dc
diff --git a/dev-libs/wayland/wayland-1.20.0.ebuild b/dev-libs/wayland/wayland-1.20.0.ebuild
new file mode 100644
index 000000000000..49ec2b8a68f5
--- /dev/null
+++ b/dev-libs/wayland/wayland-1.20.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/wayland.git"
+ inherit git-r3
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+inherit meson-multilib
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="https://wayland.freedesktop.org/ https://gitlab.freedesktop.org/wayland/wayland"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ ~dev-util/wayland-scanner-${PV}
+ virtual/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.6[dot]
+ app-text/xmlto
+ >=media-gfx/graphviz-2.26.0
+ )
+"
+DEPEND="
+ >=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
+ dev-libs/libxml2:=
+ >=dev-libs/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_bool doc documentation)
+ $(meson_native_true dtd_validation)
+ -Dlibraries=true
+ -Dscanner=false
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # We set it on purpose to only a short subdir name, as socket paths are
+ # created in there, which are 108 byte limited. With this it hopefully
+ # barely fits to the limit with /var/tmp/portage/${CATEGORY}/${PF}/temp/x
+ export XDG_RUNTIME_DIR="${T}"/x
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ multilib-minimal_src_test
+}
diff --git a/dev-libs/wayland/wayland-9999.ebuild b/dev-libs/wayland/wayland-9999.ebuild
index 058e90a73824..49ec2b8a68f5 100644
--- a/dev-libs/wayland/wayland-9999.ebuild
+++ b/dev-libs/wayland/wayland-9999.ebuild
@@ -17,10 +17,11 @@ HOMEPAGE="https://wayland.freedesktop.org/ https://gitlab.freedesktop.org/waylan
LICENSE="MIT"
SLOT="0"
-IUSE="doc"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
BDEPEND="
- ~dev-util/wayland-scanner-${PV}[$MULTILIB_USEDEP]
+ ~dev-util/wayland-scanner-${PV}
virtual/pkgconfig
doc? (
>=app-doc/doxygen-1.6[dot]
@@ -41,6 +42,7 @@ multilib_src_configure() {
$(meson_native_true dtd_validation)
-Dlibraries=true
-Dscanner=false
+ $(meson_use test tests)
)
meson_src_configure
}