summaryrefslogtreecommitdiff
path: root/dev-libs/wayland
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-09 05:33:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-09 05:33:51 +0100
commit3e1b17a1a1b2bac1314c0ea171fbd05bb098f02b (patch)
tree894494ae2d3f739b3d903c4331c6ac82b57f14e4 /dev-libs/wayland
parent900dd293f8087dff1643b45d7b836702a9ea8fd9 (diff)
gentoo auto-resync : 09:04:2023 - 05:33:50
Diffstat (limited to 'dev-libs/wayland')
-rw-r--r--dev-libs/wayland/Manifest4
-rw-r--r--dev-libs/wayland/wayland-1.22.0.ebuild66
-rw-r--r--dev-libs/wayland/wayland-9999.ebuild2
3 files changed, 70 insertions, 2 deletions
diff --git a/dev-libs/wayland/Manifest b/dev-libs/wayland/Manifest
index 87c3d4f780d9..3803d10fbbc7 100644
--- a/dev-libs/wayland/Manifest
+++ b/dev-libs/wayland/Manifest
@@ -1,4 +1,6 @@
DIST wayland-1.21.0.tar.xz 225936 BLAKE2B 2b43eb1517d476bb2b4daed1083373655b57d047968fdb93dbbbbe4235af12e25557627e30b5c3d2575bac4beaf1e0a0b8ef10a3c673538d9097501f33c05836 SHA512 5575216d30fdf5c63caa6bcad071e15f2a4f3acb12df776806073f65db37a50b5b5b3cc7957c5497636f4ac01893e2eaab26e453ded44b287acde01762f5fdc3
+DIST wayland-1.22.0.tar.xz 229544 BLAKE2B b0bb366e7f3494813d1574228ae5dd48eccde035120d6dd8709e3a24738681ab9dd9ba6a13924b6a35982d331fa8911fa7346911da9f618be9c9109da0288629 SHA512 fb1974efc8433e97254eb83fe28974198f2b4d8246418eb3d34ce657055461e0c97bc06dd52e5066ae91bbe05bac611dc49a0937ba226ac6388d5a47241efb12
EBUILD wayland-1.21.0-r1.ebuild 1668 BLAKE2B f2f70d2c7a580f7fc47078f9ddf260080f5e2a0adc4146c32606ce44ae2e3928163065953f892647db6cdc932ebb94d2d8db1bcc2c227d39c71be9158dd9e020 SHA512 85e4890ff57e01d07b9b004e2c1e2ab279b493940b03ade166a03769e43cfe3f5c069c46b9dfc801a0d26f9b27720d67cf93baf9b2343e3ee90262a3d3e2ed92
-EBUILD wayland-9999.ebuild 1675 BLAKE2B f278a266e2635568419ceed5bd71c12ad13f8bafc905912f11e9e20b9866ee7ef2b2fec255da0fd5e40aa9a448e6e3c3e93dfff254836a471b9ee94e1bf8ed83 SHA512 82972eec97e3a4a1b709edc74a52fa4e290044eb7e5addbf4c58677d1386b66fdb045669e64d1d7d1644858d15e91fd784c2641e50b4b297556b5f2c35e1b587
+EBUILD wayland-1.22.0.ebuild 1675 BLAKE2B b160422ea60c3ca45c6c6b66535c867dc2fc5f8826657e8a1c50f1a247e4637151d7f26cb0b3fa16d36b348ee87db721de2304d853f49175f0d98accca23ba9d SHA512 8717923ed058538e6947d42c4448775bbf201079cb28f3230aef57cdc512db7ebe1f0eddd785fc71e0813df0a1b8521b7166a1704d13f7230d419c32ddd687fa
+EBUILD wayland-9999.ebuild 1675 BLAKE2B b160422ea60c3ca45c6c6b66535c867dc2fc5f8826657e8a1c50f1a247e4637151d7f26cb0b3fa16d36b348ee87db721de2304d853f49175f0d98accca23ba9d SHA512 8717923ed058538e6947d42c4448775bbf201079cb28f3230aef57cdc512db7ebe1f0eddd785fc71e0813df0a1b8521b7166a1704d13f7230d419c32ddd687fa
MISC metadata.xml 337 BLAKE2B af249efc25c3eadde73d0b49cba0e6c8a021fb4b7c9a0b96f27a4e71185c76f8ac7ff0b9efdfeadf2df324cfa578db3a73fc7bee8c249cba35d41e2145017e16 SHA512 771b226f8e16d8c570bc2ea89ee3c5176e1d0f2209afb3b2af5a9d19fbdc2037a411b84d546bea054449c8074fb0fb3c3726fb2692d084521c64cda60600c0b8
diff --git a/dev-libs/wayland/wayland-1.22.0.ebuild b/dev-libs/wayland/wayland-1.22.0.ebuild
new file mode 100644
index 000000000000..9fe3f14c9121
--- /dev/null
+++ b/dev-libs/wayland/wayland-1.22.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/wayland.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+inherit meson-multilib
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="https://wayland.freedesktop.org/ https://gitlab.freedesktop.org/wayland/wayland"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ ~dev-util/wayland-scanner-${PV}
+ virtual/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.6[dot]
+ app-text/xmlto
+ >=media-gfx/graphviz-2.26.0
+ )
+"
+DEPEND="
+ >=dev-libs/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_bool doc documentation)
+ $(meson_native_true dtd_validation)
+ -Dlibraries=true
+ -Dscanner=false
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # We set it on purpose to only a short subdir name, as socket paths are
+ # created in there, which are 108 byte limited. With this it hopefully
+ # barely fits to the limit with /var/tmp/portage/${CATEGORY}/${PF}/temp/x
+ export XDG_RUNTIME_DIR="${T}"/x
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ multilib-minimal_src_test
+}
+
+src_install() {
+ meson-multilib_src_install
+
+ if use doc; then
+ mv "${ED}"/usr/share/doc/"${PN}"/* "${ED}"/usr/share/doc/"${PF}"/ || die
+ rmdir "${ED}"/usr/share/doc/"${PN}" || die
+ fi
+}
diff --git a/dev-libs/wayland/wayland-9999.ebuild b/dev-libs/wayland/wayland-9999.ebuild
index c232ff0e5669..9fe3f14c9121 100644
--- a/dev-libs/wayland/wayland-9999.ebuild
+++ b/dev-libs/wayland/wayland-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8