summaryrefslogtreecommitdiff
path: root/dev-libs/wayland
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-libs/wayland
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-libs/wayland')
-rw-r--r--dev-libs/wayland/Manifest4
-rw-r--r--dev-libs/wayland/wayland-1.21.0.ebuild57
-rw-r--r--dev-libs/wayland/wayland-9999.ebuild6
3 files changed, 62 insertions, 5 deletions
diff --git a/dev-libs/wayland/Manifest b/dev-libs/wayland/Manifest
index 6c6d6e5e6e14..14c5fcd7ae56 100644
--- a/dev-libs/wayland/Manifest
+++ b/dev-libs/wayland/Manifest
@@ -1,4 +1,6 @@
DIST wayland-1.20.0.tar.xz 225188 BLAKE2B d607610ad8b30b6b3bbfc3945679f698030f271766cfb72425f98f170a96469fb085fb9a746a866b8562d7f452c844e61ad57f634dcf365474c7d050b76022e9 SHA512 e8a1f410994b947f850799bdd0d95a2429d8467f853e62a0ab3915a4e9fe130f8aa977e03715114ab740c6ec546edea63d275ce7f927d4f3029ea126e6a7d215
+DIST wayland-1.21.0.tar.xz 225936 BLAKE2B 2b43eb1517d476bb2b4daed1083373655b57d047968fdb93dbbbbe4235af12e25557627e30b5c3d2575bac4beaf1e0a0b8ef10a3c673538d9097501f33c05836 SHA512 5575216d30fdf5c63caa6bcad071e15f2a4f3acb12df776806073f65db37a50b5b5b3cc7957c5497636f4ac01893e2eaab26e453ded44b287acde01762f5fdc3
EBUILD wayland-1.20.0.ebuild 1516 BLAKE2B 1a602cda157f1184410d3d1bb71969f182ce9098e9ea0c9be023c1cf158850bd2b9fa3958caa7f3f5fd3974697e408425abe65c1a34d7fc8a826e21e3411325f SHA512 8f2522a515137cab3c4682b136b5a733ef155db57f88e49e4ccb6cfd79911f57173df94d2233ca8a9d9cfe94ad4f6f5ef243d3586345dc9b8e5856409717dfc4
-EBUILD wayland-9999.ebuild 1523 BLAKE2B bcd553154db7ad457c3d818911c5272fa438e61ad56171d6a53e392089f1056be46c2e20929c9e2d6f377cc6a1e926a1a9a39c8ee05661f4b53680e215154e98 SHA512 36d479b19a8235ac63f35a7bcfded0e6d2f6db7bcbf9f98cb92347a638bde53ed2ee8959eeb32450bf0d0a6159f76ed0499947e250366ecf85b66a5d6a7c8a39
+EBUILD wayland-1.21.0.ebuild 1485 BLAKE2B 8e82cc08d4efab01be9e60daa08f568c9c2760cd5247f66ac2aac0886ec0dcb3b9d5cc262ed7612e08c77f97c08371b454a35f2af693eb6a8cc88a19c23575d0 SHA512 fbb427c35c1e5df874e99391438babcca5c943b548dfc8c4380e694979833045a94be367d920d696c9e5b332171351e2ff298214e7e82c0c4bbc42a669ca9f12
+EBUILD wayland-9999.ebuild 1485 BLAKE2B 8e82cc08d4efab01be9e60daa08f568c9c2760cd5247f66ac2aac0886ec0dcb3b9d5cc262ed7612e08c77f97c08371b454a35f2af693eb6a8cc88a19c23575d0 SHA512 fbb427c35c1e5df874e99391438babcca5c943b548dfc8c4380e694979833045a94be367d920d696c9e5b332171351e2ff298214e7e82c0c4bbc42a669ca9f12
MISC metadata.xml 231 BLAKE2B 6373a9c04316f777f87754fbb7cbc856493138d32bdb05d1015946ebbb359c4b8adb9372554097833d5c9a20e00e32fa0a1c90995d9299dd2215a2cadcccbb73 SHA512 bf6ad5078a6775cd61d257939d41ec53d006124475da2949c55b4b3ac138ec85a88b9068c5920b1e781fadda963939b8f120f8864d82e10cf50e09cc8052a6dc
diff --git a/dev-libs/wayland/wayland-1.21.0.ebuild b/dev-libs/wayland/wayland-1.21.0.ebuild
new file mode 100644
index 000000000000..bbe4c3904bca
--- /dev/null
+++ b/dev-libs/wayland/wayland-1.21.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/wayland.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+inherit meson-multilib
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="https://wayland.freedesktop.org/ https://gitlab.freedesktop.org/wayland/wayland"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ ~dev-util/wayland-scanner-${PV}
+ virtual/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.6[dot]
+ app-text/xmlto
+ >=media-gfx/graphviz-2.26.0
+ )
+"
+DEPEND="
+ >=dev-libs/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_bool doc documentation)
+ $(meson_native_true dtd_validation)
+ -Dlibraries=true
+ -Dscanner=false
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # We set it on purpose to only a short subdir name, as socket paths are
+ # created in there, which are 108 byte limited. With this it hopefully
+ # barely fits to the limit with /var/tmp/portage/${CATEGORY}/${PF}/temp/x
+ export XDG_RUNTIME_DIR="${T}"/x
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ multilib-minimal_src_test
+}
diff --git a/dev-libs/wayland/wayland-9999.ebuild b/dev-libs/wayland/wayland-9999.ebuild
index 5a701656ff6d..bbe4c3904bca 100644
--- a/dev-libs/wayland/wayland-9999.ebuild
+++ b/dev-libs/wayland/wayland-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/wayland.git"
inherit git-r3
else
- SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
inherit meson-multilib
@@ -30,8 +30,6 @@ BDEPEND="
)
"
DEPEND="
- >=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
- dev-libs/libxml2:=
>=dev-libs/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]
"
RDEPEND="${DEPEND}"