summaryrefslogtreecommitdiff
path: root/dev-libs/wayland-protocols
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-11 07:37:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-11 07:37:54 +0100
commit81db58116c7a9c27f54243a4d8f364c7e94c6f36 (patch)
treeeb568d2a6d5b95a55b7f5a5ec305e1e6f5566e93 /dev-libs/wayland-protocols
parent179be85ade6b2b47bf362865b5c375969ab5ddc8 (diff)
gentoo auto-resync : 11:10:2022 - 07:37:54
Diffstat (limited to 'dev-libs/wayland-protocols')
-rw-r--r--dev-libs/wayland-protocols/Manifest4
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.27.ebuild38
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-9999.ebuild4
3 files changed, 43 insertions, 3 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index eed9e4283bb0..80bef5a61530 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1,4 +1,6 @@
DIST wayland-protocols-1.26.tar.xz 81028 BLAKE2B 0813b8117c48b965560c3f112f67fa209f29b0c40fab2b46f46ccae227d68902277cce06281a6bd938fb3c2186e0cf4ea3670ed6d3b48b51ed655012bb1452ce SHA512 fa9c3963b548197461c8c0b9e16ebbf9cfa5b60053fc17f51b41e63a55b8c5420dd7e42313f93946b438ab47f04e1cd17bc92aae9e1074b47177dc7ce7042167
+DIST wayland-protocols-1.27.tar.xz 82604 BLAKE2B ae1c19dffcf255c88e6d646f321ec194639500994f9e5a2759bd7081dc16872777c993d35d81000796e3e5044dc62f169c9b2fe89de081fd395eaaf09e6206e2 SHA512 c0a49bc46c663c9f602998dfe2e184c09756790fbcc7acbc2bf9d9cf8f7d6dcdd00259b768222a30e5d134e6f97f7f4faf252947b544e8b32f53278b70da0390
EBUILD wayland-protocols-1.26.ebuild 755 BLAKE2B 3fc5c050521210e255e4f84757d8db55799f8f1f24a29cb80212e7961f73c16e043a64f76dfa3185aa56ed20a3e0759247f87cc41ff9f1adde61b147a276d2f4 SHA512 9ba008e0875dbcc8b3c597eb49073bce8afc3d94c0bf6837a684ef692e202b85eeb162640229199965922625763107080e4bf76388fc31b30d3eac2c758e08b6
-EBUILD wayland-protocols-9999.ebuild 762 BLAKE2B 4f80b6c474c0ea97061ef6fb7703479bb82831a9a25450269356f967855e5b2d255d09a55db9a876ff7789dd8eab5d32c875c3947bf6e64c8eeabeb4c3faed4d SHA512 09dab59db34d5361d9630dc45c7728cf20c5f4491f6022093062b37756b776404964031664dd97efaaa878eb6fc850ce861b32d8e764173ecb28d432452ed719
+EBUILD wayland-protocols-1.27.ebuild 793 BLAKE2B 3988e887ac66b0b91eab437d03c0ef24ba50d88d96241bd9e8d746c67a71ab49a65f63bf36be45b8f94d49e92d122cf9dbc7eb941b630ddc4afbf4ac8e3081de SHA512 c4c856228ccdb277168dae9d53a24928ce6515a20e7a4a7849b895125393bef4f0c188843fe992d08e70a8d7f27ea5a3a9d6d6150e78a4ea07f22a3f5a68dda3
+EBUILD wayland-protocols-9999.ebuild 793 BLAKE2B 3988e887ac66b0b91eab437d03c0ef24ba50d88d96241bd9e8d746c67a71ab49a65f63bf36be45b8f94d49e92d122cf9dbc7eb941b630ddc4afbf4ac8e3081de SHA512 c4c856228ccdb277168dae9d53a24928ce6515a20e7a4a7849b895125393bef4f0c188843fe992d08e70a8d7f27ea5a3a9d6d6150e78a4ea07f22a3f5a68dda3
MISC metadata.xml 231 BLAKE2B 6373a9c04316f777f87754fbb7cbc856493138d32bdb05d1015946ebbb359c4b8adb9372554097833d5c9a20e00e32fa0a1c90995d9299dd2215a2cadcccbb73 SHA512 bf6ad5078a6775cd61d257939d41ec53d006124475da2949c55b4b3ac138ec85a88b9068c5920b1e781fadda963939b8f120f8864d82e10cf50e09cc8052a6dc
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.27.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.27.ebuild
new file mode 100644
index 000000000000..4eff41270cb0
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.27.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+RDEPEND=""
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
diff --git a/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
index fd84b9649f01..4eff41270cb0 100644
--- a/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
+++ b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson
@@ -12,7 +12,7 @@ if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
inherit git-r3
else
- SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi