summaryrefslogtreecommitdiff
path: root/dev-libs/wayland-protocols
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-19 20:11:46 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-19 20:11:46 +0000
commit5b5df25227111ef465caf5c52bcfb66dac3219cd (patch)
tree31b713cac6188358125cbb66b8804030328740f0 /dev-libs/wayland-protocols
parent02e2208f46f4e2c00fb9743cbc47350bdd233bfa (diff)
gentoo resync : 19.01.2018
Diffstat (limited to 'dev-libs/wayland-protocols')
-rw-r--r--dev-libs/wayland-protocols/Manifest4
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.12.ebuild43
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-9999.ebuild24
3 files changed, 60 insertions, 11 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index db39712b2cb0..37d03c29c706 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1,4 +1,6 @@
DIST wayland-protocols-1.11.tar.xz 117852 BLAKE2B 314f247efdffd0dbc46664e2abe7fade0cb0a36ef77310660f978ea9677c33acd60b1512a5dc2fdbfc40b8e1444da7bb4089e091433bbf2bc4b5ab41e97514ca SHA512 6a6f816dd24f338182ddf11e2daa2db4f048f9153c618bd75712b6e02fccc41294c6c5f33692e858f54bab6b644b1dff49ca223ca2c8410a4afb8aa1b39e34a6
+DIST wayland-protocols-1.12.tar.xz 98920 BLAKE2B f6625f91ce5ba9e4ef88b296969e67d99f2889e405f3a416ab00c62d866a78fb554ff9baccfcd8cad2662ab0e5c7908866a9a04a1f16ec36c8a5af250c42564d SHA512 84f913aeaf9786c5ddff4952fa4c318435569ccdc00c625f088b1dc9d6e61f3c439b2d217db9fcf2f0c37da954e266314749e2c3130bf3328cffdc3bdce5695a
EBUILD wayland-protocols-1.11.ebuild 891 BLAKE2B 89bd528ac051ac71795318ed2bb4b68a32585dbf28ee72dd5e1284819d9acc28154d6bf7c0e6acc784461a8ee948bb0e25dabfe8d1745e0ea41ae62f027604f7 SHA512 d246c9ff9a9520dbf039f67cede7150892366748a26f8f3eb7d6f4650efa1f43a2bfcfe33961a98174061dbbb74665edd7cd74d0b2a1b2e7acd971862a60791f
-EBUILD wayland-protocols-9999.ebuild 900 BLAKE2B 526608e7ef610933915839746260b1689bddc97b2964300ac301b55f4d7b9663ee1c008894c03893877a0f1509044eefb9d59919c5be1543d28cda74a2747377 SHA512 fdfbcb2e75363768a2589ba25218181ae2d501131aed11287b3d35c7a0ff03199c5780d94cb8b10e0ac278d81d145cc7ef19a4556debc107312e32948dee509c
+EBUILD wayland-protocols-1.12.ebuild 885 BLAKE2B d492535004c630e7a2ed6096b5c1983526fdbad572a565c04428d3f5a02cf4f2c09b61d796df394f33d803d6afcdd796fbb6f637cdc99561abd95741083a250a SHA512 72e4d27a56920ebc5e5164f606327f1a5799513ae2fd0a9891889838ae1a5b75706b3f8e6da392e4ef2d3280d07a3d74b63fdd40982e09fb4b24e3ffa9f1df4f
+EBUILD wayland-protocols-9999.ebuild 885 BLAKE2B d492535004c630e7a2ed6096b5c1983526fdbad572a565c04428d3f5a02cf4f2c09b61d796df394f33d803d6afcdd796fbb6f637cdc99561abd95741083a250a SHA512 72e4d27a56920ebc5e5164f606327f1a5799513ae2fd0a9891889838ae1a5b75706b3f8e6da392e4ef2d3280d07a3d74b63fdd40982e09fb4b24e3ffa9f1df4f
MISC metadata.xml 230 BLAKE2B 70bf59e64305ef14908197f2aa7ffbc1769ade265097da68e001245451658af5921760c91cb74aae717543ea0017e2471fd94bfc5c4c447d2d60e2c23aa3b007 SHA512 d7a2643abd1904cc5ff4d91cbb6f1baeb7f75fd1db542c5e14f19412f4f0bd4b903f8e703a7662ba7482c79dac5529057760b6427599d35e0842755fd946e057
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.12.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.12.ebuild
new file mode 100644
index 000000000000..4948be07ff86
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.12.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/wayland/wayland-protocols.git"
+ EXPERIMENTAL="true"
+
+ inherit git-r3 autotools
+else
+ inherit autotools
+fi
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ $PV != 9999* ]]; then
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/wayland"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ default
+}
diff --git a/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
index 15cac561d897..4948be07ff86 100644
--- a/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
+++ b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
@@ -1,23 +1,21 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://anongit.freedesktop.org/git/wayland/wayland-protocols.git"
- GIT_ECLASS="git-r3"
EXPERIMENTAL="true"
- AUTOTOOLS_AUTORECONF=1
-fi
-inherit autotools-utils ${GIT_ECLASS}
+ inherit git-r3 autotools
+else
+ inherit autotools
+fi
DESCRIPTION="Wayland protocol files"
HOMEPAGE="https://wayland.freedesktop.org/"
-if [[ $PV = 9999* ]]; then
- SRC_URI="${SRC_PATCHES}"
-else
+if [[ $PV != 9999* ]]; then
SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
@@ -30,10 +28,16 @@ RDEPEND="dev-libs/wayland"
DEPEND="${RDEPEND}
virtual/pkgconfig"
+src_prepare() {
+ default
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
src_test() {
export XDG_RUNTIME_DIR="${T}/runtime-dir"
mkdir "${XDG_RUNTIME_DIR}" || die
chmod 0700 "${XDG_RUNTIME_DIR}" || die
- autotools-utils_src_test
+ default
}