summaryrefslogtreecommitdiff
path: root/dev-libs/wayland-protocols
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-22 06:30:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-22 06:30:44 +0000
commit5a2cecfc8661e1d3a762adf05cf8eb142cd41710 (patch)
tree341806a72603cc8845e7e1595289e7a8b9570f2a /dev-libs/wayland-protocols
parentd2bcdab82e5f5f38a8ab54026e8aa94edb1b77a6 (diff)
gentoo auto-resync : 22:12:2024 - 06:30:44
Diffstat (limited to 'dev-libs/wayland-protocols')
-rw-r--r--dev-libs/wayland-protocols/Manifest4
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.39.ebuild37
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-9999.ebuild2
3 files changed, 41 insertions, 2 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index e49f7673f514..85a11047069d 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1,4 +1,6 @@
DIST wayland-protocols-1.38.tar.xz 102648 BLAKE2B b07abed74b2f83247f3746414dc1f9e317793f9bc6ae7c1cb955d94149577964dee2ed0d658d4b9d9d7bd446509966393f4060b85db09b56292ddd9702bd1aee SHA512 43fc36d35bedb245deed0e2de246f42d2bbfa6ecafa094f2a7fb103d6df8ae28f3cc200bc5aa24745b9131a28381883c24779da0a6d9ac954753bd5ebb1405db
+DIST wayland-protocols-1.39.tar.xz 108844 BLAKE2B ca0350acdce8e2b3803ef4582576fd2db61228f54cebfa232ebbf85377a7201ceb9a96650c8940dc91c193681fa70a0fcb3d5fa9e541acfe77ae07448e998f9d SHA512 480a195ec0846400d93160e3d0a7ba12948ed841835ee4661f54b0101ae0027affd9c0f660a73244786fecd70e4f609830489a6b95e00d750cf2379734aacbe0
EBUILD wayland-protocols-1.38.ebuild 769 BLAKE2B c2a4d37a807bba72de674824610a0a8128390d876af363e86ffd6f2234a5a647fa36e85ec358c0bc8768dd46e2e7f9ba65a809a871144cd57e9b3ea63353de5b SHA512 cb18b4fc2ab33815005544ee2b2cd2f69b633e70c57aa4beb94d21cd51b266dba7821f24cdc0f2691f1ef6e85c83b2fa0ec2e1c440c8419bbf02b23c7ba13796
-EBUILD wayland-protocols-9999.ebuild 776 BLAKE2B 94456d3441f35114ec811ac742b6b0714e60f5ca397f4a08f3a2de1b98fd86838c12f8173b2bfa59a39233413e7bc1ee38cc67493ce8f3792c50eae8ce8154fc SHA512 88948515d1f82998868b8b871af0b9582da04277c1281419187f03c742b367b820a4bd99441202e5d84421d2e935801cec2c93337e4662920ecafdfe4f1f3ba5
+EBUILD wayland-protocols-1.39.ebuild 785 BLAKE2B d6d355660e85518b18aa11ab4cdd37ab7e496ce6f91a92cece804e02c4b212ce98ac90e817767aa9061fb3a2ff7986a8b3e71a5f987fe6bf622787ecc94b28e8 SHA512 00f6eddf096ba24aca61fc25200f8e9a8a6bc1b1101b464445f98067bf81b4b078436d25d9d6f5b0f44b0fd3caa54acf6c90848ab548f3130e40f0da695314cb
+EBUILD wayland-protocols-9999.ebuild 785 BLAKE2B d6d355660e85518b18aa11ab4cdd37ab7e496ce6f91a92cece804e02c4b212ce98ac90e817767aa9061fb3a2ff7986a8b3e71a5f987fe6bf622787ecc94b28e8 SHA512 00f6eddf096ba24aca61fc25200f8e9a8a6bc1b1101b464445f98067bf81b4b078436d25d9d6f5b0f44b0fd3caa54acf6c90848ab548f3130e40f0da695314cb
MISC metadata.xml 347 BLAKE2B e4265a94e0261094355613ac8617c362f90dc7207188658bf37d7d3d0ea87f598d0a5367d44c95cd3688cd68aeaad6be95ca1707430d06ad8b34bfaed9395f29 SHA512 4db809b42f57946d21f5c0ece2ccba39684da283ddfb72ed2bd6c1ace305c18381904dafa2abce56950cfb2bd1ead0839124c59302b1bb71c0fd8fc8f4a52846
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.39.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.39.ebuild
new file mode 100644
index 000000000000..64f0b55ccbb3
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.39.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+BDEPEND="
+ >=dev-util/wayland-scanner-1.23.0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
diff --git a/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
index 0bdb61d9ef92..64f0b55ccbb3 100644
--- a/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
+++ b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
@@ -25,7 +25,7 @@ DEPEND="
test? ( dev-libs/wayland )
"
BDEPEND="
- dev-util/wayland-scanner
+ >=dev-util/wayland-scanner-1.23.0
virtual/pkgconfig
"