summaryrefslogtreecommitdiff
path: root/dev-libs/wayland-protocols
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-03 12:28:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-03 12:28:20 +0100
commit3f559ef486314f9b3b48d48eb303d6be68463af9 (patch)
tree3b70212f31ce4d000911c001ce13363d0909dfd1 /dev-libs/wayland-protocols
parent20b6ab983b55b022c6e4af317154089e18ad41cb (diff)
gentoo auto-resync : 03:09:2024 - 12:28:20
Diffstat (limited to 'dev-libs/wayland-protocols')
-rw-r--r--dev-libs/wayland-protocols/Manifest2
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.37.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index d1b55958b1ab..74b674876ff7 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1,4 +1,6 @@
DIST wayland-protocols-1.36.tar.xz 95512 BLAKE2B 6c460106a2069ff9ce0b6c8221f85462e74d726ead69f6918417aac0cd24567251873ea05ec111a90f3385f4128e7e8d76aca42c7b1f89a070943c604b87573c SHA512 5448b9aedc953ce6be0f378da900c195c8743cb6001f615823b5fc9cab3e3ee54271132055743278e10decef7f8e9dcdeef31593a2a12062575fb90eb0084be0
+DIST wayland-protocols-1.37.tar.xz 100356 BLAKE2B f341bdb50f4169112a89b1d834a4b62b59ab7c5d9b7640a3bb5a7d84dc055f390429b171de2038a70ec564c1431ecb95a036b053f18353f3ff936651240050de SHA512 57936a23d08957afa9563b51b2b195aa10410fa74176c0503f83b1544e243d4e5b99c3daf5fc14c0a68a78d3f5759e1a5ca9fe4ba22220cbf5328168903c7575
EBUILD wayland-protocols-1.36.ebuild 775 BLAKE2B fc40e447290503ced6c8a592586bd7fdc0f390188923ee9919ec2858b603b5ddb89eda8b2600b39bcddafafe8212dacf54dd9561f71702071d1dd1cb588d91c0 SHA512 a88d020f6d34709c70422a73e2ab59bb95b266dc4eaf27f8dcb4e14118e761a9e344c1971698a921e49444539be81f03394053ea897760442528d578e03788a9
+EBUILD wayland-protocols-1.37.ebuild 782 BLAKE2B 028aa55ee023c349611b3c5ad7d23cdf0f0ea539ce1b9bfa2efaa4c7639f1149abfc83d217fe0fa7005a62467b31a06c5e82cd6e07ce6c88c49217365470cb54 SHA512 9a7769631992d9f5da2a7af180eded745fdd499df45475273c9305c30dcc956095b02aef46465dcd2405b9515bfb9a63cadd7edd21febf578813e3fe4c1c0ed2
EBUILD wayland-protocols-9999.ebuild 782 BLAKE2B 028aa55ee023c349611b3c5ad7d23cdf0f0ea539ce1b9bfa2efaa4c7639f1149abfc83d217fe0fa7005a62467b31a06c5e82cd6e07ce6c88c49217365470cb54 SHA512 9a7769631992d9f5da2a7af180eded745fdd499df45475273c9305c30dcc956095b02aef46465dcd2405b9515bfb9a63cadd7edd21febf578813e3fe4c1c0ed2
MISC metadata.xml 347 BLAKE2B e4265a94e0261094355613ac8617c362f90dc7207188658bf37d7d3d0ea87f598d0a5367d44c95cd3688cd68aeaad6be95ca1707430d06ad8b34bfaed9395f29 SHA512 4db809b42f57946d21f5c0ece2ccba39684da283ddfb72ed2bd6c1ace305c18381904dafa2abce56950cfb2bd1ead0839124c59302b1bb71c0fd8fc8f4a52846
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.37.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.37.ebuild
new file mode 100644
index 000000000000..7310be696158
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.37.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}