summaryrefslogtreecommitdiff
path: root/dev-libs/vanessa-logger/vanessa-logger-0.0.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/vanessa-logger/vanessa-logger-0.0.10.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/vanessa-logger/vanessa-logger-0.0.10.ebuild')
-rw-r--r--dev-libs/vanessa-logger/vanessa-logger-0.0.10.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/vanessa-logger/vanessa-logger-0.0.10.ebuild b/dev-libs/vanessa-logger/vanessa-logger-0.0.10.ebuild
new file mode 100644
index 000000000000..bad41b65fdc1
--- /dev/null
+++ b/dev-libs/vanessa-logger/vanessa-logger-0.0.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Generic logging layer that to log to syslog, an open file handle or a file name"
+HOMEPAGE="http://horms.net/projects/vanessa/"
+SRC_URI="http://horms.net/projects/vanessa/download/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ make DESTDIR="${D}" install || die "error installing"
+ dodoc AUTHORS NEWS README TODO sample/*.c sample/*.h
+}