summaryrefslogtreecommitdiff
path: root/dev-libs/vanessa-adt/vanessa-adt-0.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/vanessa-adt/vanessa-adt-0.0.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/vanessa-adt/vanessa-adt-0.0.6.ebuild')
-rw-r--r--dev-libs/vanessa-adt/vanessa-adt-0.0.6.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/vanessa-adt/vanessa-adt-0.0.6.ebuild b/dev-libs/vanessa-adt/vanessa-adt-0.0.6.ebuild
new file mode 100644
index 000000000000..22c83a923de7
--- /dev/null
+++ b/dev-libs/vanessa-adt/vanessa-adt-0.0.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Abstract Data Types. Includes queue, dynamic array, hash and key value ADT"
+HOMEPAGE="http://horms.net/projects/vanessa/"
+SRC_URI="http://horms.net/projects/vanessa/download/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+
+DEPEND=">=dev-libs/vanessa-logger-0.0.6"
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf || die "error configure"
+ emake || die "error compiling"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "error installing"
+ dodoc AUTHORS NEWS README TODO
+}