summaryrefslogtreecommitdiff
path: root/dev-libs/uriparser/uriparser-0.9.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-libs/uriparser/uriparser-0.9.5.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-libs/uriparser/uriparser-0.9.5.ebuild')
-rw-r--r--dev-libs/uriparser/uriparser-0.9.5.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-libs/uriparser/uriparser-0.9.5.ebuild b/dev-libs/uriparser/uriparser-0.9.5.ebuild
deleted file mode 100644
index 9b07a35769dd..000000000000
--- a/dev-libs/uriparser/uriparser-0.9.5.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Strictly RFC 3986 compliant URI parsing library in C"
-HOMEPAGE="https://uriparser.github.io/"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-IUSE="+doc qt5 test unicode" # +doc to address warning RequiredUseDefaults
-
-REQUIRED_USE="qt5? ( doc ) test? ( unicode )"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? ( >=dev-cpp/gtest-1.8.1 )
-"
-BDEPEND="
- virtual/pkgconfig
- doc? (
- >=app-doc/doxygen-1.5.8
- media-gfx/graphviz
- qt5? ( dev-qt/qthelp:5 )
- )
-"
-
-DOCS=( AUTHORS ChangeLog THANKS )
-
-src_configure() {
- local mycmakeargs=(
- -DURIPARSER_BUILD_CHAR=ON
- -DURIPARSER_BUILD_DOCS=$(usex doc ON OFF)
- -DURIPARSER_BUILD_TESTS=$(usex test ON OFF)
- -DURIPARSER_BUILD_TOOLS=ON
- -DURIPARSER_BUILD_WCHAR_T=$(usex unicode ON OFF)
-
- # The usex wrapper is here to address this warning:
- # One or more CMake variables were not used by the project:
- # CMAKE_DISABLE_FIND_PACKAGE_Qt5Help
- $(usex doc "$(cmake_use_find_package qt5 Qt5Help)")
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- if use doc && use qt5; then
- dodoc "${BUILD_DIR}"/doc/*.qch
- docompress -x /usr/share/doc/${PF}/${P}.qch
- fi
-}