summaryrefslogtreecommitdiff
path: root/dev-libs/uriparser/uriparser-0.8.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /dev-libs/uriparser/uriparser-0.8.6.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'dev-libs/uriparser/uriparser-0.8.6.ebuild')
-rw-r--r--dev-libs/uriparser/uriparser-0.8.6.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/uriparser/uriparser-0.8.6.ebuild b/dev-libs/uriparser/uriparser-0.8.6.ebuild
new file mode 100644
index 000000000000..94133b732358
--- /dev/null
+++ b/dev-libs/uriparser/uriparser-0.8.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Uriparser is a strictly RFC 3986 compliant URI parsing library in C"
+HOMEPAGE="https://uriparser.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc qt5 test unicode"
+
+RDEPEND=""
+DEPEND="virtual/pkgconfig
+ doc? ( >=app-doc/doxygen-1.5.8
+ qt5? ( dev-qt/qthelp:5 ) )
+ test? ( >=dev-util/cpptest-1.1.1 )"
+
+REQUIRED_USE="test? ( unicode )"
+
+DOCS=( AUTHORS ChangeLog THANKS )
+
+src_configure() {
+ econf \
+ --disable-sizedown \
+ $(use_enable test) \
+ --enable-char \
+ $(use_enable unicode wchar_t) \
+ $(use_enable doc) \
+ --docdir=/usr/share/doc/${PF}/
+}
+
+src_install() {
+ default
+
+ if use doc && use qt5; then
+ dodoc doc/*.qch
+ docompress -x /usr/share/doc/${PF}/${P}.qch
+ fi
+}