summaryrefslogtreecommitdiff
path: root/dev-libs/tvision/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/tvision/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/tvision/files')
-rw-r--r--dev-libs/tvision/files/tvision-2.1.0_pre2-asneeded.patch45
-rw-r--r--dev-libs/tvision/files/tvision-2.1.0_pre2-build-system.patch30
-rw-r--r--dev-libs/tvision/files/tvision-2.1.0_pre2-flags.patch11
-rw-r--r--dev-libs/tvision/files/tvision-2.1.0_pre2-gcc41.patch11
-rw-r--r--dev-libs/tvision/files/tvision-2.1.0_pre2-gcc44.patch21
-rw-r--r--dev-libs/tvision/files/tvision-2.1.0_pre2-gcc6.patch147
-rw-r--r--dev-libs/tvision/files/tvision-2.1.0_pre2-ldconfig.patch15
-rw-r--r--dev-libs/tvision/files/tvision-2.1.0_pre2-outb.patch41
-rw-r--r--dev-libs/tvision/files/tvision-2.1.0_pre2-underflow.patch14
9 files changed, 335 insertions, 0 deletions
diff --git a/dev-libs/tvision/files/tvision-2.1.0_pre2-asneeded.patch b/dev-libs/tvision/files/tvision-2.1.0_pre2-asneeded.patch
new file mode 100644
index 000000000000..314ab225f051
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.1.0_pre2-asneeded.patch
@@ -0,0 +1,45 @@
+--- tvision/config.pl
++++ tvision/config.pl
+@@ -206,6 +206,7 @@
+ }
+ # Flags to link as a dynamic lib
+ $MakeDefsRHIDE[6]='RHIDE_LDFLAGS=';
++$MakeDefsRHIDE[7]='RHIDE_LIBS=';
+ if ($OS eq 'UNIX')
+ {
+ if ($OSf ne 'Darwin')
+@@ -229,15 +230,15 @@
+ }
+ $libs=$conf{'X11Lib'};
+ $libs=~s/(\S+)/-l$1/g;
+- $MakeDefsRHIDE[6].=" -L".$conf{'X11LibPath'}." $libs" if @conf{'HAVE_X11'} eq 'yes';
++ $MakeDefsRHIDE[7].=" -L".$conf{'X11LibPath'}." $libs" if @conf{'HAVE_X11'} eq 'yes';
+- $MakeDefsRHIDE[6].=' -lgpm' if @conf{'HAVE_GPM'} eq 'yes';
++ $MakeDefsRHIDE[7].=' -lgpm' if @conf{'HAVE_GPM'} eq 'yes';
+- $MakeDefsRHIDE[6].=(($OSf eq 'QNXRtP') ? ' -lncursesS' : ' -lncurses') unless $conf{'ncurses'} eq 'no';
++ $MakeDefsRHIDE[7].=(($OSf eq 'QNXRtP') ? ' -lncursesS' : ' -lncurses') unless $conf{'ncurses'} eq 'no';
+- $MakeDefsRHIDE[6].=" $stdcxx -lm -lc";
++ $MakeDefsRHIDE[7].=" $stdcxx -lm -lc";
+- $MakeDefsRHIDE[6].=' -lpthread' if $conf{'HAVE_LINUX_PTHREAD'} eq 'yes';
++ $MakeDefsRHIDE[7].=' -lpthread' if $conf{'HAVE_LINUX_PTHREAD'} eq 'yes';
+- $MakeDefsRHIDE[6].=' libtvfintl.a' if ($OSf eq 'Darwin') && $UseDummyIntl;
++ $MakeDefsRHIDE[7].=' libtvfintl.a' if ($OSf eq 'Darwin') && $UseDummyIntl;
+ }
+-$MakeDefsRHIDE[7]="LIB_VER=$Version";
++$MakeDefsRHIDE[8]="LIB_VER=$Version";
+-$MakeDefsRHIDE[8]="LIB_VER_MAJOR=$VersionMajor";
++$MakeDefsRHIDE[9]="LIB_VER_MAJOR=$VersionMajor";
+
+ ModifyMakefiles('intl/dummy/Makefile');
+ CreateRHIDEenvs('examples/rhide.env','makes/rhide.env','compat/rhide.env');
+--- tvision/makes/common.imk
++++ tvision/makes/common.imk
+@@ -54,7 +54,7 @@
+ C_EXTRA_FLAGS=$(SHARED_CODE_OPTION)
+ RHIDE_COMPILE_ARCHIVE=$(RHIDE_LD) $(RHIDE_LIBDIRS) $(LDFLAGS) \
+ $(RHIDE_LDFLAGS) $(C_EXTRA_FLAGS) -o $(OUTFILE) \
+- $(OBJFILES)
++ $(OBJFILES) $(addprefix -l,$(RHIDE_OS_LIBS))
+ else
+ RHIDE_COMPILE_ARCHIVE=$(RHIDE_AR) $(RHIDE_ARFLAGS) $(OUTFILE)\
+ $(ALL_PREREQ)
diff --git a/dev-libs/tvision/files/tvision-2.1.0_pre2-build-system.patch b/dev-libs/tvision/files/tvision-2.1.0_pre2-build-system.patch
new file mode 100644
index 000000000000..8ba26208948a
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.1.0_pre2-build-system.patch
@@ -0,0 +1,30 @@
+index 8b78ba3..92aa570 100644
+--- a/config.pl
++++ b/config.pl
+@@ -1111,7 +1111,7 @@ sub GenerateMakefile
+ $rep.="\t\$(MAKE) prefix=\$(prefix) -C intl\n";
+ }
+ $text=~s/\@target_rules\@/$rep/g;
+- $rep="intl-dummy:\n\t\$(MAKE) -C intl/dummy\n";
++ $rep="intl-dummy:\n\t\$(MAKE) prefix=\$(prefix) -C intl/dummy\n";
+ $rep.="\tcp intl/dummy/libtvfintl.a $makeDir\n";
+ $rep.="\tranlib $makeDir/libtvfintl.a\n" if $conf{'UseRanLib'};
+ $text=~s/\@intl_dummy_rule\@/$rep/g;
+@@ -1196,7 +1196,7 @@ sub GenerateMakefile
+ }
+ if ($internac)
+ {
+- $rep.="\ninstall-internac:\n\t\$(MAKE) -C intl install\n";
++ $rep.="\ninstall-internac:\n\t\$(MAKE) prefix=\$(prefix) -C intl install\n";
+ }
+ $text=~s/\@install_rules\@/$rep/g;
+
+@@ -1216,7 +1216,7 @@ sub GenerateMakefile
+ $rep.="\trm -f intl/dummy/*.lo\n";
+ $rep.="\trm -f intl/dummy/*.a\n";
+ $rep.="\t-\$(MAKE) -C examples clean\n";
+- $rep.="\t-\$(MAKE) -C intl clean\n";
++ $rep.="\t-\$(MAKE) prefix=\$(prefix) -C intl clean\n";
+ $rep.="\trm -f configure.cache\n";
+ $rep.="\trm -f rhtv-config\$(EXE_EXT)\n";
+ $text=~s/\@clean\@/$rep/g;
diff --git a/dev-libs/tvision/files/tvision-2.1.0_pre2-flags.patch b/dev-libs/tvision/files/tvision-2.1.0_pre2-flags.patch
new file mode 100644
index 000000000000..e74b09ee57d0
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.1.0_pre2-flags.patch
@@ -0,0 +1,11 @@
+--- tvision/Makefile.in
++++ tvision/Makefile.in
+@@ -31,7 +31,7 @@ examples:
+ $(MAKE) -C examples
+
+ rhtv-config$(EXE_EXT): rhtv-config.c include/tv/configtv.h
+- @GCC@ -o rhtv-config$(EXE_EXT) -Iinclude rhtv-config.c
++ @GCC@ -o rhtv-config$(EXE_EXT) $(CFLAGS) $(LDFLAGS) -Iinclude rhtv-config.c
+
+ install-headers:
+ @install_headers@
diff --git a/dev-libs/tvision/files/tvision-2.1.0_pre2-gcc41.patch b/dev-libs/tvision/files/tvision-2.1.0_pre2-gcc41.patch
new file mode 100644
index 000000000000..36246b214f99
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.1.0_pre2-gcc41.patch
@@ -0,0 +1,11 @@
+--- tvision/include/tv/inputln.h
++++ tvision/include/tv/inputln.h
+@@ -201,7 +201,7 @@
+ { return name; }
+
+ protected:
+- TInputLine::TInputLine(StreamableInit) :
++ TInputLine(StreamableInit) :
+ TInputLineBaseT<char,TDrawBuffer>(streamableInit) {}
+
+ public:
diff --git a/dev-libs/tvision/files/tvision-2.1.0_pre2-gcc44.patch b/dev-libs/tvision/files/tvision-2.1.0_pre2-gcc44.patch
new file mode 100644
index 000000000000..40911f3a3e29
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.1.0_pre2-gcc44.patch
@@ -0,0 +1,21 @@
+--- tvision/classes/ipstream.cc
++++ tvision/classes/ipstream.cc
+@@ -19,6 +19,7 @@
+ *
+ */
+ #include <assert.h>
++#include <stdio.h>
+ #define Uses_string
+ #define Uses_TStreamable
+ #define Uses_TStreamableClass
+--- tvision/include/tv/textdev.h
++++ tvision/include/tv/textdev.h
+@@ -16,6 +16,8 @@
+ #if defined( Uses_TTextDevice ) && !defined( __TTextDevice )
+ #define __TTextDevice
+
++#include <stdio.h>
++
+ class TRect;
+ class TScrollBar;
+
diff --git a/dev-libs/tvision/files/tvision-2.1.0_pre2-gcc6.patch b/dev-libs/tvision/files/tvision-2.1.0_pre2-gcc6.patch
new file mode 100644
index 000000000000..8570bb04222e
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.1.0_pre2-gcc6.patch
@@ -0,0 +1,147 @@
+Fix gcc-6 compilation errors; bug 594176
+
+--- a/classes/tdesktop.cc
++++ b/classes/tdesktop.cc
+@@ -26,6 +26,10 @@ Modified cursor behavior while desktop locked by Salvador E. Tropea (SET)
+ #define Uses_TVCodePage
+ #include <tv.h>
+
++#include <cmath>
++
++using std::abs;
++
+ TDeskInit::TDeskInit( TBackground *(*cBackground)( TRect ) ) :
+ createBackground( cBackground )
+ {
+--- a/classes/tdisplay.cc
++++ b/classes/tdisplay.cc
+@@ -22,6 +22,10 @@ same used in original Turbo Vision for compatibility purposes.
+ #define Uses_TVCodePage
+ #include <tv.h>
+
++#include <cmath>
++
++using std::abs;
++
+ // Remove me please!
+ int TDisplay::dual_display=0;
+
+--- a/classes/tvtext1.cc
++++ b/classes/tvtext1.cc
+@@ -110,8 +110,8 @@
+ char TCheckBoxes::button[] = " [ ] ";
+ char TCheckBoxes::obutton[] = " [ ] ";
+
+-TScrollChars TScrollBar::vChars = {30, 31, 177, 254, 178};
+-TScrollChars TScrollBar::ovChars = {30, 31, 177, 254, 178};
+-TScrollChars TScrollBar::hChars = {17, 16, 177, 254, 178};
+-TScrollChars TScrollBar::ohChars = {17, 16, 177, 254, 178};
++TScrollChars TScrollBar::vChars = {30, 31, (char) 177, (char) 254, (char) 178};
++TScrollChars TScrollBar::ovChars = {30, 31, (char) 177, (char) 254, (char) 178};
++TScrollChars TScrollBar::hChars = {17, 16, (char) 177, (char) 254, (char) 178};
++TScrollChars TScrollBar::ohChars = {17, 16, (char) 177, (char) 254, (char) 178};
+
+--- a/classes/x11/x11src.cc
++++ b/classes/x11/x11src.cc
+@@ -94,6 +94,10 @@
+ #define TIMER_ALARM SIGALRM
+ #endif
+
++#include <cmath>
++
++using std::abs;
++
+ const unsigned foWmin=5, foHmin=7, foWmax=20, foHmax=32;
+ const int cursorDelay=300000;
+
+@@ -2555,49 +2559,49 @@ Cursor TScreenX11::busyCursor,
+ TScreenX11::leftPtr;
+ char TScreenX11::busyCursorMap[]=
+ {
+- 0xff, 0xff, 0xff, 0x1f,
+- 0xfd, 0xff, 0xff, 0x1f,
+- 0xf9, 0xff, 0xff, 0x1f,
+- 0xf1, 0xff, 0xff, 0x1f,
+- 0xe1, 0x7f, 0xc0, 0x1f,
+- 0xc1, 0x7f, 0xc0, 0x1f,
+- 0x81, 0x3f, 0x80, 0x1f,
+- 0x01, 0x9f, 0x3b, 0x1f,
+- 0x01, 0xce, 0x7b, 0x1e,
+- 0xc1, 0xef, 0xfb, 0x1e,
+- 0xc9, 0xef, 0xf1, 0x18,
+- 0x9d, 0xef, 0xf1, 0x18,
+- 0x9f, 0xef, 0xfe, 0x18,
+- 0x3f, 0x6f, 0xff, 0x1e,
+- 0x3f, 0xcf, 0x7f, 0x1e,
+- 0xff, 0x9f, 0x3f, 0x1f,
+- 0xff, 0x3f, 0x80, 0x1f,
+- 0xff, 0x7f, 0xc0, 0x1f,
+- 0xff, 0x7f, 0xc0, 0x1f,
+- 0xff, 0xff, 0xff, 0x1f
++ (char)0xff, (char)0xff, (char)0xff, (char)0x1f,
++ (char)0xfd, (char)0xff, (char)0xff, (char)0x1f,
++ (char)0xf9, (char)0xff, (char)0xff, (char)0x1f,
++ (char)0xf1, (char)0xff, (char)0xff, (char)0x1f,
++ (char)0xe1, (char)0x7f, (char)0xc0, (char)0x1f,
++ (char)0xc1, (char)0x7f, (char)0xc0, (char)0x1f,
++ (char)0x81, (char)0x3f, (char)0x80, (char)0x1f,
++ (char)0x01, (char)0x9f, (char)0x3b, (char)0x1f,
++ (char)0x01, (char)0xce, (char)0x7b, (char)0x1e,
++ (char)0xc1, (char)0xef, (char)0xfb, (char)0x1e,
++ (char)0xc9, (char)0xef, (char)0xf1, (char)0x18,
++ (char)0x9d, (char)0xef, (char)0xf1, (char)0x18,
++ (char)0x9f, (char)0xef, (char)0xfe, (char)0x18,
++ (char)0x3f, (char)0x6f, (char)0xff, (char)0x1e,
++ (char)0x3f, (char)0xcf, (char)0x7f, (char)0x1e,
++ (char)0xff, (char)0x9f, (char)0x3f, (char)0x1f,
++ (char)0xff, (char)0x3f, (char)0x80, (char)0x1f,
++ (char)0xff, (char)0x7f, (char)0xc0, (char)0x1f,
++ (char)0xff, (char)0x7f, (char)0xc0, (char)0x1f,
++ (char)0xff, (char)0xff, (char)0xff, (char)0x1f
+ };
+ char TScreenX11::busyCursorMask[]=
+ {
+- 0xfc, 0xff, 0xff, 0x1f,
+- 0xf8, 0xff, 0xff, 0x1f,
+- 0xf0, 0xff, 0xff, 0x1f,
+- 0xe0, 0x3f, 0x80, 0x1f,
+- 0xc0, 0x3f, 0x80, 0x1f,
+- 0x80, 0x3f, 0x80, 0x1f,
+- 0x00, 0x1f, 0x00, 0x1f,
+- 0x00, 0x0e, 0x00, 0x1e,
+- 0x00, 0x04, 0x00, 0x1c,
+- 0x00, 0x04, 0x00, 0x10,
+- 0x80, 0x07, 0x00, 0x10,
+- 0x08, 0x07, 0x00, 0x10,
+- 0x0c, 0x07, 0x00, 0x10,
+- 0x1f, 0x06, 0x00, 0x10,
+- 0x1f, 0x06, 0x00, 0x1c,
+- 0x3f, 0x0f, 0x00, 0x1e,
+- 0xff, 0x1f, 0x00, 0x1f,
+- 0xff, 0x3f, 0x80, 0x1f,
+- 0xff, 0x3f, 0x80, 0x1f,
+- 0xff, 0x3f, 0x80, 0x1f
++ (char)0xfc, (char)0xff, (char)0xff, (char)0x1f,
++ (char)0xf8, (char)0xff, (char)0xff, (char)0x1f,
++ (char)0xf0, (char)0xff, (char)0xff, (char)0x1f,
++ (char)0xe0, (char)0x3f, (char)0x80, (char)0x1f,
++ (char)0xc0, (char)0x3f, (char)0x80, (char)0x1f,
++ (char)0x80, (char)0x3f, (char)0x80, (char)0x1f,
++ (char)0x00, (char)0x1f, (char)0x00, (char)0x1f,
++ (char)0x00, (char)0x0e, (char)0x00, (char)0x1e,
++ (char)0x00, (char)0x04, (char)0x00, (char)0x1c,
++ (char)0x00, (char)0x04, (char)0x00, (char)0x10,
++ (char)0x80, (char)0x07, (char)0x00, (char)0x10,
++ (char)0x08, (char)0x07, (char)0x00, (char)0x10,
++ (char)0x0c, (char)0x07, (char)0x00, (char)0x10,
++ (char)0x1f, (char)0x06, (char)0x00, (char)0x10,
++ (char)0x1f, (char)0x06, (char)0x00, (char)0x1c,
++ (char)0x3f, (char)0x0f, (char)0x00, (char)0x1e,
++ (char)0xff, (char)0x1f, (char)0x00, (char)0x1f,
++ (char)0xff, (char)0x3f, (char)0x80, (char)0x1f,
++ (char)0xff, (char)0x3f, (char)0x80, (char)0x1f,
++ (char)0xff, (char)0x3f, (char)0x80, (char)0x1f
+ };
+
+ /* This is the function which creates cursors. On success it return
+
diff --git a/dev-libs/tvision/files/tvision-2.1.0_pre2-ldconfig.patch b/dev-libs/tvision/files/tvision-2.1.0_pre2-ldconfig.patch
new file mode 100644
index 000000000000..6d7d94fe8a0d
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.1.0_pre2-ldconfig.patch
@@ -0,0 +1,15 @@
+--- tvision/config.pl
++++ tvision/config.pl
+@@ -1193,12 +1193,6 @@
+ $rep.="\t".GenInstallFiles('0644',"$makeDir/$ver",'$(libdir)');
+ $stripDebug=($OSf eq 'Darwin') ? '-S' : '--strip-debug';
+ $rep.="\tstrip $stripDebug \$(libdir)/$ver\n" unless $conf{'debugInfo'} eq 'yes';
+- # FreeBSD: merge data from libdir.
+- # Darwin: doesn't have ldconfig.
+- if ($OSf ne 'Darwin')
+- {
+- $rep.=($OSf eq 'FreeBSD') ? "\t-ldconfig -m \$(libdir)\n" : "\t-ldconfig\n";
+- }
+ }
+ if ($internac)
+ {
diff --git a/dev-libs/tvision/files/tvision-2.1.0_pre2-outb.patch b/dev-libs/tvision/files/tvision-2.1.0_pre2-outb.patch
new file mode 100644
index 000000000000..0735f8ffeb77
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.1.0_pre2-outb.patch
@@ -0,0 +1,41 @@
+Recent kernel headers no longer provide asm/io.h.
+
+--- tvision/classes/linux/linuxdis.cc
++++ tvision/classes/linux/linuxdis.cc
+@@ -300,7 +300,11 @@
+ *****************************************************************************/
+
+ #ifdef h386LowLevel
++#if HAVE_OUTB_IN_SYS
++#include <sys/io.h>
++#else
+ #include <asm/io.h>
++#endif
+
+ static inline
+ unsigned char I(unsigned char i)
+--- tvision/classes/linux/linuxscr.cc
++++ tvision/classes/linux/linuxscr.cc
+@@ -123,7 +123,11 @@
+ #include <tv/linux/log.h>
+
+ #ifdef h386LowLevel
++ #if HAVE_OUTB_IN_SYS
++ #include <sys/io.h>
++ #else
+ #include <asm/io.h>
++ #endif
+ #endif
+
+ // What a hell is that?!
+--- tvision/config.pl
++++ tvision/config.pl
+@@ -77,7 +77,7 @@
+ # glibc I use but the fact is that the needed tricks make it very Linux
+ # dependent.
+ LookForPThread() if $OSf eq 'Linux';
+- #LookForOutB();
++ LookForOutB();
+ }
+ if ($Compf eq 'Cygwin')
+ {# Cygwin incorporates a XFree86 port
diff --git a/dev-libs/tvision/files/tvision-2.1.0_pre2-underflow.patch b/dev-libs/tvision/files/tvision-2.1.0_pre2-underflow.patch
new file mode 100644
index 000000000000..d693a359a6cf
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.1.0_pre2-underflow.patch
@@ -0,0 +1,14 @@
+Bug #160591; fixes a buffer underflow.
+Reported by B Douglas Hilton <b.d.hilton@verizon.net>
+
+--- tvision/classes/ttermina.cc
++++ tvision/classes/ttermina.cc
+@@ -233,7 +233,7 @@
+ }
+ }
+ }
+- while (pos-->=queBack);
++ while (pos-->queBack);
+
+ return queBack;
+ }