summaryrefslogtreecommitdiff
path: root/dev-libs/trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-17 11:17:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-17 11:17:07 +0100
commit0e6a8a6c51115943235f06224d9fd14b0eb41df3 (patch)
treef4911a7c07b15bd1bdef1e4f9a5c6ab23f3af58c /dev-libs/trio
parent8900e3e6f840b95c1c8126f9c283ca5c99f5f4fd (diff)
gentoo auto-resync : 17:09:2022 - 11:17:07
Diffstat (limited to 'dev-libs/trio')
-rw-r--r--dev-libs/trio/Manifest3
-rw-r--r--dev-libs/trio/files/trio-1.16-no-inline.patch8
-rw-r--r--dev-libs/trio/trio-1.16.ebuild41
3 files changed, 0 insertions, 52 deletions
diff --git a/dev-libs/trio/Manifest b/dev-libs/trio/Manifest
index 999651d38c4e..1a1a6459e308 100644
--- a/dev-libs/trio/Manifest
+++ b/dev-libs/trio/Manifest
@@ -1,6 +1,3 @@
-AUX trio-1.16-no-inline.patch 197 BLAKE2B 6d4eaad93ef8bafe450d9dce6a6b676e649be525184a313af55f82916090a0c73edcc606f96097009700a8c1dfaae3c1a5081e0ed32b7b22f2c88a0cb385edbf SHA512 ee581daa9e957c6bbfc080f688b664bf04df29cd2dfb5ce59cc9e6f41ec005258a2584ac81505760a939f23b14991913b42d67742fa44e16000bd0552518aaa0
-DIST trio-1.16.tar.gz 167337 BLAKE2B 0f284e0a130723f7511c0e874276c79c1addc1329833d14f0b76bae9808d90b76a2b26817ee85da71c3997360918cb534917a11bbe35ba627d1012cd8a2f6299 SHA512 3a8bac3ed001f70f498bd2ab0881ed6d3760bc978bf9ff587c3fc1d5d7a38205f779c5fe445f41edaa9e23c15bc1b4a521916e19161277741bc8e2f744b46c69
DIST trio-1.17.tar.gz 452237 BLAKE2B 77ff673cc103b07b1424720d28c49d2e33a1402a98d8d21124fabb0cafd3498a99976d808cbbc5a90e1b3a063c6af68c3daf94768d533e4a762b730a253fa012 SHA512 19f4732b32c6a3754677d5766399fa70083c6a78c0d04b1dfa10a578b21405ba3e3d3af6543e4811f5fd305ec2727781a1b0f2888e59c574ca735f8406da7954
-EBUILD trio-1.16.ebuild 860 BLAKE2B cb67c7210025e47731cfe8aca3aa8f95a6b43ce82574e7f3c5129508ba51736652955d9c7428d79d2bc77b7195ffd80ba4beeebc70a490766207d877d3d830ca SHA512 9ce79b1dcdead5e65097eb89d456c63af2538d9c267e8f864a33b060beec73dd62bbe298cf7eb589eb9a3fba5ddf0189ae704c769b79c42a348224c54f65812a
EBUILD trio-1.17.ebuild 544 BLAKE2B da4a36e2ac24aa7e116bddd1401f19e87b682f2c44d95cd4bd4d7fa819c4d37f1a557a089619e1a57961c545567e51730d77b7554f0d1c23cc36e2bfe0e22b62 SHA512 2a995659a8da3cea24dfc4830c40b74488a5583bd7a38d0ec70d6133a6ee7df6dbf45212b5f96b621cc737a4042456ef62047878813f7ad4f799b52108ec53f2
MISC metadata.xml 329 BLAKE2B 5863c898baa0c23c810edcdc6ae637b0a391579d1fee8db773c899bb936e36c76fb847e2d6de1410d9b6b286154459fb7d515f0a7f270c16a762274f4c19457f SHA512 5ee6ecb624bca2b159b5a6ebd0605d5ccef265c21f37e5f440317032a4144851b0b2eeaabf5fa89f710b9b18b85ad6812827cf9d32f4cfefc4d44e6592c98de2
diff --git a/dev-libs/trio/files/trio-1.16-no-inline.patch b/dev-libs/trio/files/trio-1.16-no-inline.patch
deleted file mode 100644
index b1584344a111..000000000000
--- a/dev-libs/trio/files/trio-1.16-no-inline.patch
+++ /dev/null
@@ -1,8 +0,0 @@
-Let compiler decide what to inline (fixes build with -Os).
-https://bugs.gentoo.org/792075
---- a/triodef.h
-+++ b/triodef.h
-@@ -315,2 +315,3 @@
- #endif
-+#undef TRIO_INLINE
- #if !defined(TRIO_INLINE)
diff --git a/dev-libs/trio/trio-1.16.ebuild b/dev-libs/trio/trio-1.16.ebuild
deleted file mode 100644
index bf7d164f5baf..000000000000
--- a/dev-libs/trio/trio-1.16.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Portable string functions, focus on the *printf() and *scanf() clones"
-HOMEPAGE="https://daniel.haxx.se/projects/trio/"
-SRC_URI="mirror://sourceforge/ctrio/${P}.tar.gz"
-
-LICENSE="trio"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-PATCHES=(
- "${FILESDIR}"/${P}-no-inline.patch
-)
-HTML_DOCS=( html/. )
-
-src_prepare() {
- default
- sed -i '/$(CC)/s/-o/$(LOCAL_LDFLAGS) -o/' Makefile.in || die
-}
-
-src_compile() {
- emake AR="$(tc-getAR)" LOCAL_LDFLAGS="${LDFLAGS}"
- ln -s libtrio.so.2{.0.0,} || die
- ln -s libtrio.so{.2.0.0,} || die
-}
-
-src_test() {
- emake LOCAL_LDFLAGS="${LDFLAGS}" regression
- LD_LIBRARY_PATH=".:${LD_LIBRARY_PATH}" ./regression || die
-}
-
-src_install() {
- doheader trio*.h
- dolib.so libtrio.so*
- einstalldocs
-}