summaryrefslogtreecommitdiff
path: root/dev-libs/tre
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/tre
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/tre')
-rw-r--r--dev-libs/tre/Manifest4
-rw-r--r--dev-libs/tre/files/0.8.0-pkgcfg.patch14
-rw-r--r--dev-libs/tre/metadata.xml11
-rw-r--r--dev-libs/tre/tre-0.8.0-r1.ebuild64
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-libs/tre/Manifest b/dev-libs/tre/Manifest
new file mode 100644
index 000000000000..fd9aa4c4c16a
--- /dev/null
+++ b/dev-libs/tre/Manifest
@@ -0,0 +1,4 @@
+AUX 0.8.0-pkgcfg.patch 420 BLAKE2B 6b04ff4db2abc5dffdbca50bcbbe20974fdaa24ab25875f2538eca5af42921a729550e7ea5188225d3d73661e9ba05b96ff345fb4d931130ba4255b14c3944d2 SHA512 a6e4713aa0f9619abe256e9e1ea7c5bc8cbeb9ed173dd856972af70612ac435206e2b294ca5947e93223c17de875ba2620bf57949332b19ecff9965e2ee1a9e6
+DIST tre-0.8.0.tar.bz2 380714 BLAKE2B b2af6e805e9e19fd69debf2f881ddfb591317f69db4e29a04e1899eb69100b8ac7744f86fa438530509ca2ee8aa1d346d416c6391f13247cd9398f4c59c2ed85 SHA512 db7465993e0d25eee8e52f974427b8a040234cf0f017769eb94ee88bc6261821336aad7f762bfa82db7e2212d8449bc221592586f061c528a59a550773cbc263
+EBUILD tre-0.8.0-r1.ebuild 1417 BLAKE2B 3116aa7c2529daa19d049b5c2d2f07ad9092e1183f0665f14b15f27bba5cd925123cdf945d06ad617a0b96b1157e71d456deb655c60401c0ab1a443c026fc747 SHA512 dcd95d238b9974bde331f1974ec4cb389355d6859126091138b833497847b0edcfa829a15afbb2d67b69a17379af0ed7440221695754d24ceab6b1a6143651d4
+MISC metadata.xml 353 BLAKE2B 0346462595f8f9a38758ce0817e787b87b35b329aef65d2921214d32bd9313023f006ee2ab31084a03a2f8a8ecf1d556dd11f190ac2467ebcd061bc144b977e4 SHA512 907b341e747fb9d7ba7b76f300d373284a21a59e3d649275c4a53ac681177f94e9d0d9f56b15365008262b2aba91236d9ac5623387313c7b74b65b2b70871d3b
diff --git a/dev-libs/tre/files/0.8.0-pkgcfg.patch b/dev-libs/tre/files/0.8.0-pkgcfg.patch
new file mode 100644
index 000000000000..82f803504282
--- /dev/null
+++ b/dev-libs/tre/files/0.8.0-pkgcfg.patch
@@ -0,0 +1,14 @@
+ tre.pc.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/tre.pc.in b/tre.pc.in
+index fdc45fa..b8d0676 100644
+--- a/tre.pc.in
++++ b/tre.pc.in
+@@ -6,5 +6,5 @@ includedir=@includedir@
+ Name: TRE
+ Description: TRE regexp matching library
+ Version: @PACKAGE_VERSION@
+-Libs: -L${libdir} -ltre @LDFLAGS@ @LIBINTL@ @LIBS@
++Libs: -L${libdir} -ltre @LIBINTL@ @LIBS@
+ Cflags: -I${includedir} @CPPFLAGS@
diff --git a/dev-libs/tre/metadata.xml b/dev-libs/tre/metadata.xml
new file mode 100644
index 000000000000..b675c9f5b843
--- /dev/null
+++ b/dev-libs/tre/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">laurikari/tre</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/tre/tre-0.8.0-r1.ebuild b/dev-libs/tre/tre-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..462846e4dc05
--- /dev/null
+++ b/dev-libs/tre/tre-0.8.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib
+
+DESCRIPTION="Lightweight, robust, and efficient POSIX compliant regexp matching library"
+HOMEPAGE="https://laurikari.net/tre/ https://github.com/laurikari/tre/"
+SRC_URI="https://laurikari.net/tre/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="nls static-libs"
+
+RDEPEND="
+ !app-text/agrep
+ !dev-ruby/amatch
+ !app-misc/glimpse"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}/${PV}-pkgcfg.patch" )
+
+src_prepare() {
+ default
+}
+
+src_configure() {
+ econf \
+ --enable-agrep \
+ --enable-system-abi \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ if locale -a | grep -iq en_US.iso88591; then
+ emake -j1 check
+ else
+ ewarn "If you like to run the test,"
+ ewarn "please make sure en_US.ISO-8859-1 is installed."
+ die "en_US.ISO-8859-1 locale is missing"
+ fi
+}
+
+src_install() {
+ local HTML_DOCS=( doc/*.{css,html} )
+
+ default
+
+ # 626480
+ mv "${ED%/}"/usr/bin/agrep{,-tre}$(get_exeext) || die
+}
+
+pkg_postinst() {
+ ewarn "app-misc/glimpse, app-text/agrep and this package all provide agrep."
+ ewarn "If this causes any unforeseen incompatibilities please file a bug"
+ ewarn "on https://bugs.gentoo.org."
+}