summaryrefslogtreecommitdiff
path: root/dev-libs/tinyxml2/tinyxml2-6.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/tinyxml2/tinyxml2-6.2.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/tinyxml2/tinyxml2-6.2.0.ebuild')
-rw-r--r--dev-libs/tinyxml2/tinyxml2-6.2.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/tinyxml2/tinyxml2-6.2.0.ebuild b/dev-libs/tinyxml2/tinyxml2-6.2.0.ebuild
new file mode 100644
index 000000000000..b6ae40344cf8
--- /dev/null
+++ b/dev-libs/tinyxml2/tinyxml2-6.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="A simple, small, efficient, C++ XML parser"
+HOMEPAGE="http://www.grinninglizard.com/tinyxml2/ https://github.com/leethomason/tinyxml2/"
+SRC_URI="https://github.com/leethomason/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/6"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
+IUSE="static-libs test"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake-utils_src_configure
+}