summaryrefslogtreecommitdiff
path: root/dev-libs/starpu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/starpu
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/starpu')
-rw-r--r--dev-libs/starpu/Manifest4
-rw-r--r--dev-libs/starpu/metadata.xml19
-rw-r--r--dev-libs/starpu/starpu-1.1.5-r1.ebuild78
-rw-r--r--dev-libs/starpu/starpu-1.1.5.ebuild81
4 files changed, 182 insertions, 0 deletions
diff --git a/dev-libs/starpu/Manifest b/dev-libs/starpu/Manifest
new file mode 100644
index 000000000000..e661e6f7536a
--- /dev/null
+++ b/dev-libs/starpu/Manifest
@@ -0,0 +1,4 @@
+DIST starpu-1.1.5.tar.gz 5209660 BLAKE2B 3caf313402a840b8196dc94b6c4f973f87a21878bcbfe1a44ce14218c02290c8701eb3829ce0b89f3029f768c7760ea94c4f307c850e6e42ec877be017c50b4a SHA512 e22a51c601c1997f6a9279e87b22a96f2b25a9c8bb4b715ee3a048ed8af638997610ba72c7b42f61d9401464464c57402feebc76368f9df6ca84fa1305baeedd
+EBUILD starpu-1.1.5-r1.ebuild 2005 BLAKE2B 1e249d69ca9b6ad097a472c6cc0e0ac0ec141bac968dbc291340c10815482a0c3ce64721c81c91f082789496d6ab247863646ed3dafbf780efaab9bcd54692dd SHA512 477d14b9a4a4269c0c61963feb8e7eced569365709128456ca75bae00c8bb30c6f3bdf1950097faf52ab4ab674d784a9a826f3bbbd8d50d622a724c0d374e325
+EBUILD starpu-1.1.5.ebuild 2060 BLAKE2B 265d77704570bc9832c2ee4274eb2e7c7a4ccfe77714ea2ae32b3947df738a971d79ca8ae8ab24bdb815f821f087dedc283042becff12b93c61e5283696e86c2 SHA512 201b79423b2f6b9ba2ae810853427a55e0758b9e8a5136f610f54fc1a4255673c3f78c8caab3099f6740739d0b83eb7c4f2e53c8400c96c66797f63669ae5df7
+MISC metadata.xml 853 BLAKE2B 5873820e19a10507aa381bdc5e80defaa2dac2e65fc923aff907c7c28795205c271b82f756c5255e64ec0147726b2a305573a49d0a7694bf583b59a3e1c5eddd SHA512 43b79ddb2dbc234bf4715ee5d7c7dbd78dd9828f1fbd930198eed2a8dea66ebc28d09c105d2d3fc0685ae8123496b360f20e11b4a199c99743373ad9774bc964
diff --git a/dev-libs/starpu/metadata.xml b/dev-libs/starpu/metadata.xml
new file mode 100644
index 000000000000..8e975146000a
--- /dev/null
+++ b/dev-libs/starpu/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+<longdescription lang="en">
+ StarPU is a runtime system that offers support for heterogeneous
+ multicore machines. While many efforts are devoted to design efficient
+ computation kernels for those architectures (e.g. to implement BLAS
+ kernels on GPUs or on Cell's SPUs), StarPU not only takes care of
+ offloading such kernels (and implementing data coherency across
+ the machine), but it also makes sure the kernels are executed as
+ efficiently as possible.
+</longdescription>
+<use>
+ <flag name="cuda">Enable NVIDIA CUDA toolkit support</flag>
+ <flag name="gcc-plugin">Enable GCC extension plugin (experimental)</flag>
+ <flag name="opencl">Enable OpenCL support</flag>
+</use>
+</pkgmetadata>
diff --git a/dev-libs/starpu/starpu-1.1.5-r1.ebuild b/dev-libs/starpu/starpu-1.1.5-r1.ebuild
new file mode 100644
index 000000000000..c6fda9dd478c
--- /dev/null
+++ b/dev-libs/starpu/starpu-1.1.5-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+FORTRAN_STANDARD=90
+
+inherit autotools toolchain-funcs cuda fortran-2
+
+DESCRIPTION="Unified runtime system for heterogeneous multicore architectures"
+HOMEPAGE="http://runtime.bordeaux.inria.fr/StarPU/"
+SRC_URI="${HOMEPAGE}/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/8"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="blas cuda debug doc examples fftw gcc-plugin mpi opencl opengl
+ static-libs test"
+
+RDEPEND="
+ sys-apps/hwloc:0=
+ sci-mathematics/glpk:0=
+ blas? ( virtual/blas )
+ cuda? ( dev-util/nvidia-cuda-toolkit
+ x11-drivers/nvidia-drivers
+ blas? ( sci-libs/magma ) )
+ fftw? ( sci-libs/fftw:3.0= )
+ mpi? ( virtual/mpi )
+ opencl? ( virtual/opencl )
+ opengl? ( media-libs/freeglut:0= )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen virtual/latex-base )
+ test? ( gcc-plugin? ( dev-scheme/guile ) )"
+
+src_prepare() {
+ default
+ # upstream did not want the patches so apply sed's
+ sed -i -e 's/-O3 $CFLAGS/$CFLAGS/' configure.ac || die
+ sed -i -e '/Libs.private/s/@LDFLAGS@//g' *.pc.in */*.pc.in || die
+ eautoreconf
+ use cuda && cuda_src_prepare
+}
+
+src_configure() {
+ use blas && export BLAS_LIBS="$($(tc-getPKG_CONFIG) --libs blas)"
+
+ econf \
+ --disable-build-examples \
+ --disable-starpu-top \
+ $(use_enable cuda) \
+ $(use_enable debug) \
+ $(use_enable doc build-doc) \
+ $(use_enable fftw starpufft) \
+ $(use_enable gcc-plugin gcc-extensions) \
+ $(use_enable opencl) \
+ $(use_enable opengl opengl-render) \
+ $(use_enable static-libs static) \
+ $(use_with mpi mpicc "$(type -P mpicc)") \
+ $(use cuda && use_enable blas magma) \
+ $(use mpi && use_enable test mpi-check)
+}
+
+src_test() {
+ emake -j1 showcheck
+}
+
+src_install() {
+ default
+ use doc && dodoc -r doc/doxygen/*.pdf doc/doxygen/html
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ fi
+ prune_libtool_files --all
+}
diff --git a/dev-libs/starpu/starpu-1.1.5.ebuild b/dev-libs/starpu/starpu-1.1.5.ebuild
new file mode 100644
index 000000000000..ce3ab4e90515
--- /dev/null
+++ b/dev-libs/starpu/starpu-1.1.5.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+FORTRAN_STANDARD=90
+
+inherit autotools-utils toolchain-funcs cuda fortran-2
+
+DESCRIPTION="Unified runtime system for heterogeneous multicore architectures"
+HOMEPAGE="http://runtime.bordeaux.inria.fr/StarPU/"
+SRC_URI="${HOMEPAGE}/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="blas cuda debug doc examples fftw gcc-plugin mpi opencl opengl
+ static-libs test"
+
+RDEPEND="
+ sys-apps/hwloc:0=
+ sci-mathematics/glpk:0=
+ blas? ( virtual/blas )
+ cuda? ( dev-util/nvidia-cuda-toolkit
+ x11-drivers/nvidia-drivers
+ blas? ( sci-libs/magma ) )
+ fftw? ( sci-libs/fftw:3.0= )
+ mpi? ( virtual/mpi )
+ opencl? ( virtual/opencl )
+ opengl? ( media-libs/freeglut:0= )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen virtual/latex-base )
+ test? ( gcc-plugin? ( dev-scheme/guile ) )"
+
+src_prepare() {
+ # upstream did not want the patches so apply sed's
+ sed -i -e 's/-O3 $CFLAGS/$CFLAGS/' configure.ac || die
+ sed -i -e '/Libs.private/s/@LDFLAGS@//g' *.pc.in */*.pc.in || die
+ autotools-utils_src_prepare
+ use cuda && cuda_src_prepare
+}
+
+src_configure() {
+ use blas && export BLAS_LIBS="$($(tc-getPKG_CONFIG) --libs blas)"
+
+ local myeconfargs=(
+ --disable-build-examples
+ --disable-starpu-top
+ $(use_enable cuda)
+ $(use_enable debug)
+ $(use_enable doc build-doc)
+ $(use_enable fftw starpufft)
+ $(use_enable gcc-plugin gcc-extensions)
+ $(use_enable opencl)
+ $(use_enable opengl opengl-render)
+ $(use_with mpi mpicc "$(type -P mpicc)")
+ $(use cuda && use_enable blas magma)
+ $(use mpi && use_enable test mpi-check)
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test -j1 showcheck
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use doc; then
+ dodoc "${BUILD_DIR}"/doc/doxygen/*.pdf
+ dohtml -r "${BUILD_DIR}"/doc/doxygen/html/*
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ fi
+}