summaryrefslogtreecommitdiff
path: root/dev-libs/squareball
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/squareball
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/squareball')
-rw-r--r--dev-libs/squareball/Manifest4
-rw-r--r--dev-libs/squareball/metadata.xml15
-rw-r--r--dev-libs/squareball/squareball-0.2.0.ebuild58
-rw-r--r--dev-libs/squareball/squareball-9999.ebuild58
4 files changed, 135 insertions, 0 deletions
diff --git a/dev-libs/squareball/Manifest b/dev-libs/squareball/Manifest
new file mode 100644
index 000000000000..5219fb12f04f
--- /dev/null
+++ b/dev-libs/squareball/Manifest
@@ -0,0 +1,4 @@
+DIST squareball-0.2.0.tar.xz 231844 BLAKE2B 831952ae3d3fb14abe978b04300b6e365217ab80b2cad863d6db33dc856816121cf2688adb56c59d50db9a62322c602eda57dd1fdeb830b97b557abc1157ece9 SHA512 be039d2e2120e87bb7289e75185c9ad46452fe6ae167dda2b60944d0a32f7ff7e89504f5ddd8343e0150d12ef22d71c51ab9290e90c43a930773bd39576bdf31
+EBUILD squareball-0.2.0.ebuild 1027 BLAKE2B 86f9deef705e8c63790844367a1d5160037cfd19a2e5aadb7f96b7240214374bb0f10527afbc0620b1735a18e85ca694a35205c3ff881ff5e8a904b0c5b7191e SHA512 f089f6f975b5aceb9a6cb618a57531451c87f5bc1dbdb84ab61c0762d8bcec7f346063e7380ce3aecdc9333fe92f8be76ebfbafa5f031ffadad030fb5ad9459f
+EBUILD squareball-9999.ebuild 1027 BLAKE2B 86f9deef705e8c63790844367a1d5160037cfd19a2e5aadb7f96b7240214374bb0f10527afbc0620b1735a18e85ca694a35205c3ff881ff5e8a904b0c5b7191e SHA512 f089f6f975b5aceb9a6cb618a57531451c87f5bc1dbdb84ab61c0762d8bcec7f346063e7380ce3aecdc9333fe92f8be76ebfbafa5f031ffadad030fb5ad9459f
+MISC metadata.xml 473 BLAKE2B b3f04b2657f7515a6b0801f67f44bbc63822f346e05cc9b9a8778d0a7f8393e74d6f481693b3d7bf5d2dd1b57c3dbea33349248c0f5696a397607dbc6bf5bb00 SHA512 d1dfca386535029bedde689a3b33678eab1ed345e823143384450cb4bb415f44e08922f2f6c38f97436cef684edbb3c0b2d27d7071a73dc764e47cc968682ebf
diff --git a/dev-libs/squareball/metadata.xml b/dev-libs/squareball/metadata.xml
new file mode 100644
index 000000000000..4b2e3e78af5b
--- /dev/null
+++ b/dev-libs/squareball/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>rafael@rafaelmartins.eng.br</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <remote-id type="github">rafaelmartins/squareball</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/squareball/squareball-0.2.0.ebuild b/dev-libs/squareball/squareball-0.2.0.ebuild
new file mode 100644
index 000000000000..ef32270e8cfd
--- /dev/null
+++ b/dev-libs/squareball/squareball-0.2.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/rafaelmartins/${PN}.git"
+ inherit git-r3 autotools
+fi
+
+inherit eutils
+
+DESCRIPTION="A general-purpose library for C99"
+HOMEPAGE="https://github.com/rafaelmartins/squareball"
+
+SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test static-libs"
+
+RDEPEND=""
+
+DEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-util/cmocka )
+ doc? (
+ app-doc/doxygen )"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc) \
+ $(use_enable test tests) \
+ $(use_enable static-libs static) \
+ --disable-valgrind
+}
+
+src_compile() {
+ default
+ use doc && emake docs
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/build/html/* )
+ default
+ prune_libtool_files --all
+}
diff --git a/dev-libs/squareball/squareball-9999.ebuild b/dev-libs/squareball/squareball-9999.ebuild
new file mode 100644
index 000000000000..ef32270e8cfd
--- /dev/null
+++ b/dev-libs/squareball/squareball-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/rafaelmartins/${PN}.git"
+ inherit git-r3 autotools
+fi
+
+inherit eutils
+
+DESCRIPTION="A general-purpose library for C99"
+HOMEPAGE="https://github.com/rafaelmartins/squareball"
+
+SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test static-libs"
+
+RDEPEND=""
+
+DEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-util/cmocka )
+ doc? (
+ app-doc/doxygen )"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc) \
+ $(use_enable test tests) \
+ $(use_enable static-libs static) \
+ --disable-valgrind
+}
+
+src_compile() {
+ default
+ use doc && emake docs
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/build/html/* )
+ default
+ prune_libtool_files --all
+}