summaryrefslogtreecommitdiff
path: root/dev-libs/squareball
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/squareball
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/squareball')
-rw-r--r--dev-libs/squareball/Manifest5
-rw-r--r--dev-libs/squareball/metadata.xml15
-rw-r--r--dev-libs/squareball/squareball-0.2.0.ebuild58
-rw-r--r--dev-libs/squareball/squareball-9999.ebuild58
4 files changed, 136 insertions, 0 deletions
diff --git a/dev-libs/squareball/Manifest b/dev-libs/squareball/Manifest
new file mode 100644
index 000000000000..865221770182
--- /dev/null
+++ b/dev-libs/squareball/Manifest
@@ -0,0 +1,5 @@
+DIST squareball-0.2.0.tar.xz 231844 SHA256 5ab3ce24a0a340a2f49e91b6474d4edac3a243cb063679a06a820f6172083f0c SHA512 be039d2e2120e87bb7289e75185c9ad46452fe6ae167dda2b60944d0a32f7ff7e89504f5ddd8343e0150d12ef22d71c51ab9290e90c43a930773bd39576bdf31 WHIRLPOOL 544ecd8e0f7639cf5ff0b1110a68673a5f4a1d46131b3d0d07e35400863fb6df01fe10a2f6219ddd3f80fc905d4c1e5d27080ad5453752a8592d8ca2d2185163
+EBUILD squareball-0.2.0.ebuild 1027 SHA256 e04aa030c757515808c937ccc69868599a397b79b259dd676bd9e1fdcf99ce18 SHA512 f089f6f975b5aceb9a6cb618a57531451c87f5bc1dbdb84ab61c0762d8bcec7f346063e7380ce3aecdc9333fe92f8be76ebfbafa5f031ffadad030fb5ad9459f WHIRLPOOL c27569da55676edc6f91de9af9e15ace6db75ee5980799f53e1583830608ed0a573948659b012d6d2b90abfd0542854212d2ef6d7a81e24fec3540d222de5853
+EBUILD squareball-9999.ebuild 1027 SHA256 e04aa030c757515808c937ccc69868599a397b79b259dd676bd9e1fdcf99ce18 SHA512 f089f6f975b5aceb9a6cb618a57531451c87f5bc1dbdb84ab61c0762d8bcec7f346063e7380ce3aecdc9333fe92f8be76ebfbafa5f031ffadad030fb5ad9459f WHIRLPOOL c27569da55676edc6f91de9af9e15ace6db75ee5980799f53e1583830608ed0a573948659b012d6d2b90abfd0542854212d2ef6d7a81e24fec3540d222de5853
+MISC ChangeLog 725 SHA256 d78d75e236fb7849b013876d976499d75495d81b60fdf73798ffc41fb0e4b24c SHA512 3b64e312a8bed04c890e3a04dfc98f96b05e2e99dbb9ba19a7462ad471536e92237d7c32ff41f08c39c2796966c84a6aed165e12f6741252e40bee94eeac0a42 WHIRLPOOL 23d0299c772c081039cb111e6f194382dea638f8c9c92cafee7a642fbd3c8b500de27306b3c12585ce6a790999b756fcdd358ce1ccf7377318f50854197d5dbe
+MISC metadata.xml 473 SHA256 0215363e4c34fd3f917b97a99183bc34ce66c2e87dd4a0c768bc2cd02ce07aa9 SHA512 d1dfca386535029bedde689a3b33678eab1ed345e823143384450cb4bb415f44e08922f2f6c38f97436cef684edbb3c0b2d27d7071a73dc764e47cc968682ebf WHIRLPOOL 58eb6f21e1dede2435cf5fb9e458e4a04d40a53c1a55b8078136f17c0190f45eb02f0bcd4127f57d148578f082566e18ee4d06994ab7b7eba2a173bf8536794b
diff --git a/dev-libs/squareball/metadata.xml b/dev-libs/squareball/metadata.xml
new file mode 100644
index 000000000000..4b2e3e78af5b
--- /dev/null
+++ b/dev-libs/squareball/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>rafael@rafaelmartins.eng.br</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <remote-id type="github">rafaelmartins/squareball</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/squareball/squareball-0.2.0.ebuild b/dev-libs/squareball/squareball-0.2.0.ebuild
new file mode 100644
index 000000000000..ef32270e8cfd
--- /dev/null
+++ b/dev-libs/squareball/squareball-0.2.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/rafaelmartins/${PN}.git"
+ inherit git-r3 autotools
+fi
+
+inherit eutils
+
+DESCRIPTION="A general-purpose library for C99"
+HOMEPAGE="https://github.com/rafaelmartins/squareball"
+
+SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test static-libs"
+
+RDEPEND=""
+
+DEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-util/cmocka )
+ doc? (
+ app-doc/doxygen )"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc) \
+ $(use_enable test tests) \
+ $(use_enable static-libs static) \
+ --disable-valgrind
+}
+
+src_compile() {
+ default
+ use doc && emake docs
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/build/html/* )
+ default
+ prune_libtool_files --all
+}
diff --git a/dev-libs/squareball/squareball-9999.ebuild b/dev-libs/squareball/squareball-9999.ebuild
new file mode 100644
index 000000000000..ef32270e8cfd
--- /dev/null
+++ b/dev-libs/squareball/squareball-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/rafaelmartins/${PN}.git"
+ inherit git-r3 autotools
+fi
+
+inherit eutils
+
+DESCRIPTION="A general-purpose library for C99"
+HOMEPAGE="https://github.com/rafaelmartins/squareball"
+
+SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test static-libs"
+
+RDEPEND=""
+
+DEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-util/cmocka )
+ doc? (
+ app-doc/doxygen )"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc) \
+ $(use_enable test tests) \
+ $(use_enable static-libs static) \
+ --disable-valgrind
+}
+
+src_compile() {
+ default
+ use doc && emake docs
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/build/html/* )
+ default
+ prune_libtool_files --all
+}