summaryrefslogtreecommitdiff
path: root/dev-libs/squareball
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-libs/squareball
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-libs/squareball')
-rw-r--r--dev-libs/squareball/Manifest4
-rw-r--r--dev-libs/squareball/squareball-0.2.0.ebuild27
-rw-r--r--dev-libs/squareball/squareball-9999.ebuild27
3 files changed, 22 insertions, 36 deletions
diff --git a/dev-libs/squareball/Manifest b/dev-libs/squareball/Manifest
index b591c8a3ad3d..48a9d2b6decd 100644
--- a/dev-libs/squareball/Manifest
+++ b/dev-libs/squareball/Manifest
@@ -1,4 +1,4 @@
DIST squareball-0.2.0.tar.xz 231844 BLAKE2B 831952ae3d3fb14abe978b04300b6e365217ab80b2cad863d6db33dc856816121cf2688adb56c59d50db9a62322c602eda57dd1fdeb830b97b557abc1157ece9 SHA512 be039d2e2120e87bb7289e75185c9ad46452fe6ae167dda2b60944d0a32f7ff7e89504f5ddd8343e0150d12ef22d71c51ab9290e90c43a930773bd39576bdf31
-EBUILD squareball-0.2.0.ebuild 1052 BLAKE2B 3bf262a428b7a27b51a928927ed73fea2213185fe83d4bfa1728f2d23656e7e8c33822b381fd3e7e14fea07701db4a91bbb128a4110cb975b25253744c49a77b SHA512 095ed75d8d1518ee50a9ef68ed6f61f3fab1090c61ba31ec00923dca4cec490f9f7f40d28632df569d31f6ccd7d9014140c29fa000de2f816f1f198da8748052
-EBUILD squareball-9999.ebuild 1052 BLAKE2B 3bf262a428b7a27b51a928927ed73fea2213185fe83d4bfa1728f2d23656e7e8c33822b381fd3e7e14fea07701db4a91bbb128a4110cb975b25253744c49a77b SHA512 095ed75d8d1518ee50a9ef68ed6f61f3fab1090c61ba31ec00923dca4cec490f9f7f40d28632df569d31f6ccd7d9014140c29fa000de2f816f1f198da8748052
+EBUILD squareball-0.2.0.ebuild 1023 BLAKE2B e89c104cc59be59ad66a35e392dfe891ad2ab718100b4584e82e0aaefa2fb927c073e151e6352278b395602904049c5115230c0065463c201836139d9cf4c87d SHA512 a140b2a2cffb41e999b844642d00c972acca1c730b4be255779322c87157bc675cea4f0514c29b9b5abe043c39d621f50d858182f3b5325a1789e65c1cbff9ee
+EBUILD squareball-9999.ebuild 1022 BLAKE2B 094597a6c931d6d6231e52679b4f47360b23e000b9324f65bde4b6f599785a3de95ba4609b65e7fb82141273863b58d9cae75ab08df11698de57743b68fd9350 SHA512 155d2766a297e3a1ef7031fd77676899001be75ad95b407abdb12fcabad75fdd4c17c7e8b69068b59dc90bf95242ab719eb7fb9ab1406113993539c865f97040
MISC metadata.xml 383 BLAKE2B 4e9d61cdfcdb1c7da5afe7d7f4461de640d9fa4e8f95195a87108cb823ad3bdb9d67f42ca0f45274590362c52a01cc61fca92d5e426af9ba8bd09d1f0a1f601d SHA512 8d9eeccdd5b6b77089b1840a52a5acd12dae224483a1af4a48fdd91bb9c0dd7fb16cf4a440970bb6eed3747c28d751be53740c2a27e878e2b97aa359c57d183e
diff --git a/dev-libs/squareball/squareball-0.2.0.ebuild b/dev-libs/squareball/squareball-0.2.0.ebuild
index aeb29384561f..f66cb329826c 100644
--- a/dev-libs/squareball/squareball-0.2.0.ebuild
+++ b/dev-libs/squareball/squareball-0.2.0.ebuild
@@ -1,22 +1,17 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/rafaelmartins/${PN}.git"
- inherit git-r3 autotools
+ inherit autotools git-r3
fi
-inherit eutils ltprune
-
DESCRIPTION="A general-purpose library for C99"
HOMEPAGE="https://github.com/rafaelmartins/squareball"
-
-SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.xz"
-if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
-else
+if ! [[ ${PV} = *9999* ]]; then
+ SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
fi
@@ -25,14 +20,11 @@ SLOT="0"
IUSE="doc test static-libs"
RESTRICT="!test? ( test )"
-RDEPEND=""
-
-DEPEND="
+BDEPEND="
virtual/pkgconfig
- test? (
- dev-util/cmocka )
- doc? (
- app-doc/doxygen )"
+ doc? ( app-doc/doxygen )
+"
+DEPEND="test? ( dev-util/cmocka )"
src_prepare() {
[[ ${PV} = *9999* ]] && eautoreconf
@@ -55,5 +47,6 @@ src_compile() {
src_install() {
use doc && HTML_DOCS=( doc/build/html/* )
default
- prune_libtool_files --all
+
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/dev-libs/squareball/squareball-9999.ebuild b/dev-libs/squareball/squareball-9999.ebuild
index aeb29384561f..28dcbab67e2f 100644
--- a/dev-libs/squareball/squareball-9999.ebuild
+++ b/dev-libs/squareball/squareball-9999.ebuild
@@ -1,22 +1,17 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/rafaelmartins/${PN}.git"
- inherit git-r3 autotools
+ inherit autotools git-r3
fi
-inherit eutils ltprune
-
DESCRIPTION="A general-purpose library for C99"
HOMEPAGE="https://github.com/rafaelmartins/squareball"
-
-SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.xz"
-if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
-else
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
fi
@@ -25,14 +20,11 @@ SLOT="0"
IUSE="doc test static-libs"
RESTRICT="!test? ( test )"
-RDEPEND=""
-
-DEPEND="
+BDEPEND="
virtual/pkgconfig
- test? (
- dev-util/cmocka )
- doc? (
- app-doc/doxygen )"
+ doc? ( app-doc/doxygen )
+"
+DEPEND="test? ( dev-util/cmocka )"
src_prepare() {
[[ ${PV} = *9999* ]] && eautoreconf
@@ -55,5 +47,6 @@ src_compile() {
src_install() {
use doc && HTML_DOCS=( doc/build/html/* )
default
- prune_libtool_files --all
+
+ find "${ED}" -name '*.la' -delete || die
}