summaryrefslogtreecommitdiff
path: root/dev-libs/spdlog/spdlog-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
commitf1bc537f089cc8477a9a18db597cb349e1b00e91 (patch)
treec48eb730c43e5f35729fabbe5cb4bfbe4a1bc794 /dev-libs/spdlog/spdlog-9999.ebuild
parentcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (diff)
gentoo resync : 16.06.2018
Diffstat (limited to 'dev-libs/spdlog/spdlog-9999.ebuild')
-rw-r--r--dev-libs/spdlog/spdlog-9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-libs/spdlog/spdlog-9999.ebuild b/dev-libs/spdlog/spdlog-9999.ebuild
index b22d880ad039..e42aaade7db6 100644
--- a/dev-libs/spdlog/spdlog-9999.ebuild
+++ b/dev-libs/spdlog/spdlog-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit cmake-utils
-DESCRIPTION="Very fast, header only, C++ logging library."
+DESCRIPTION="Very fast, header only, C++ logging library"
HOMEPAGE="https://github.com/gabime/spdlog"
if [[ ${PV} == *9999 ]]; then
@@ -21,18 +21,19 @@ SLOT="0"
IUSE="test"
DEPEND="
- dev-libs/libfmt
+ <=dev-libs/libfmt-4.1.0
"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${PN}-unbundle-fmt.patch" )
+PATCHES=( "${FILESDIR}/${PN}-0.17.0-unbundle-fmt.patch" )
src_configure() {
+ rm -r include/spdlog/fmt/bundled || die
+
local mycmakeargs=(
- -DSPDLOG_BUILD_EXAMPLES=no
- -DSPDLOG_BUILD_TESTING=$(usex test)
+ -DSPDLOG_BUILD_EXAMPLES=no
+ -DSPDLOG_BUILD_TESTING=$(usex test)
)
cmake-utils_src_configure
-
}