summaryrefslogtreecommitdiff
path: root/dev-libs/spdlog/spdlog-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-libs/spdlog/spdlog-1.5.0.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-libs/spdlog/spdlog-1.5.0.ebuild')
-rw-r--r--dev-libs/spdlog/spdlog-1.5.0.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-libs/spdlog/spdlog-1.5.0.ebuild b/dev-libs/spdlog/spdlog-1.5.0.ebuild
deleted file mode 100644
index a74feac620cf..000000000000
--- a/dev-libs/spdlog/spdlog-1.5.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Very fast, header only, C++ logging library"
-HOMEPAGE="https://github.com/gabime/spdlog"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/gabime/${PN}"
-else
- SRC_URI="https://github.com/gabime/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 x86"
-fi
-
-LICENSE="MIT"
-SLOT="0/1"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- virtual/pkgconfig
-"
-DEPEND="
- >=dev-libs/libfmt-5.3.0:=
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- cmake_src_prepare
- rm -r include/spdlog/fmt/bundled || die "Failed to delete bundled libfmt"
-}
-
-src_configure() {
- local mycmakeargs=(
- -DSPDLOG_BUILD_BENCH=no
- -DSPDLOG_BUILD_EXAMPLE=no
- -DSPDLOG_FMT_EXTERNAL=yes
- -DSPDLOG_BUILD_SHARED=no
- -DSPDLOG_BUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}