summaryrefslogtreecommitdiff
path: root/dev-libs/spdlog/spdlog-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-25 08:09:37 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-25 08:09:37 +0000
commit693cc9b6e847a01c1bb692153021aaf9fb0fab25 (patch)
treebb2f7c299a4149f841c37a1208c7ac861aa95640 /dev-libs/spdlog/spdlog-1.3.1.ebuild
parent09351e78166b5e864197c4456ebae3f89dd0bed9 (diff)
gentoo resync : 25.01.2019
Diffstat (limited to 'dev-libs/spdlog/spdlog-1.3.1.ebuild')
-rw-r--r--dev-libs/spdlog/spdlog-1.3.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/spdlog/spdlog-1.3.1.ebuild b/dev-libs/spdlog/spdlog-1.3.1.ebuild
new file mode 100644
index 000000000000..497e7da9b419
--- /dev/null
+++ b/dev-libs/spdlog/spdlog-1.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Very fast, header only, C++ logging library"
+HOMEPAGE="https://github.com/gabime/spdlog"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gabime/spdlog"
+else
+ SRC_URI="https://github.com/gabime/spdlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="test"
+
+DEPEND="
+ >=dev-libs/libfmt-5.0.0
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.0-unbundle-fmt.patch" )
+
+src_configure() {
+ rm -r include/spdlog/fmt/bundled || die
+
+ local mycmakeargs=(
+ -DSPDLOG_BUILD_EXAMPLES=no
+ -DSPDLOG_BUILD_BENCH=no
+ -DSPDLOG_BUILD_TESTS=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}