summaryrefslogtreecommitdiff
path: root/dev-libs/spdlog/spdlog-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-21 18:52:40 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-21 18:52:40 +0000
commitf29eb0598f62fc3b5f09f2de5a89c0437c6164d9 (patch)
treee33392cbdd10d91ad30cb2a65130c1fb1e5ca8ac /dev-libs/spdlog/spdlog-1.2.1.ebuild
parent032a3dbb5d4ea63ec6c2ceb39c067ea6424b5792 (diff)
gentoo resync : 21.01.2020
Diffstat (limited to 'dev-libs/spdlog/spdlog-1.2.1.ebuild')
-rw-r--r--dev-libs/spdlog/spdlog-1.2.1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-libs/spdlog/spdlog-1.2.1.ebuild b/dev-libs/spdlog/spdlog-1.2.1.ebuild
deleted file mode 100644
index 3d2b30260e2e..000000000000
--- a/dev-libs/spdlog/spdlog-1.2.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Very fast, header only, C++ logging library"
-HOMEPAGE="https://github.com/gabime/spdlog"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/gabime/spdlog"
-else
- SRC_URI="https://github.com/gabime/spdlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64"
-fi
-
-LICENSE="MIT"
-SLOT="0/1"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-libs/libfmt:0/5
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${PN}-1.0.0-unbundle-fmt.patch" )
-
-src_configure() {
- rm -r include/spdlog/fmt/bundled || die
-
- local mycmakeargs=(
- -DSPDLOG_BUILD_EXAMPLES=no
- -DSPDLOG_BUILD_TESTING=$(usex test)
- )
-
- cmake-utils_src_configure
-}