summaryrefslogtreecommitdiff
path: root/dev-libs/snowball-stemmer/snowball-stemmer-0.20140325.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/snowball-stemmer/snowball-stemmer-0.20140325.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/snowball-stemmer/snowball-stemmer-0.20140325.ebuild')
-rw-r--r--dev-libs/snowball-stemmer/snowball-stemmer-0.20140325.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/snowball-stemmer/snowball-stemmer-0.20140325.ebuild b/dev-libs/snowball-stemmer/snowball-stemmer-0.20140325.ebuild
new file mode 100644
index 000000000000..df7167c24bc9
--- /dev/null
+++ b/dev-libs/snowball-stemmer/snowball-stemmer-0.20140325.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils versionator
+
+# The version number here has been added by Gentoo since upstream does
+# not do any versioning. It is the latest date of files inside
+# http://snowball.tartarus.org/dist/libstemmer_c.tgz.
+PVDATE=$(get_after_major_version)
+
+DESCRIPTION="All you need to include the snowball stemming algorithms into a C project"
+HOMEPAGE="https://snowballstem.org/"
+SRC_URI="https://dev.gentoo.org/~graaff/libstemmer_c-${PVDATE}.tgz"
+
+# This will probably be different if this ebuild ends up being used for both
+# Java and C.
+S="${WORKDIR}/libstemmer_c"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+
+# This could be used to package both libstemmer_c and libstemmer_java together.
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}/libstemmer_c-shared-library.patch"
+}
+
+src_compile() {
+ CC=$(tc-getCC) emake libstemmer.so stemwords || die "Make failed!"
+
+ if use static-libs; then
+ CC=$(tc-getCC) AR=$(tc-getAR) emake libstemmer.a || die "Make failed!"
+ fi
+}
+
+src_install() {
+ dodoc README
+
+ dobin stemwords
+
+ doheader include/libstemmer.h
+
+ dolib.so libstemmer.so.0d.0.0
+ dolib.so libstemmer.so.0d
+ dolib.so libstemmer.so
+
+ use static-libs && dolib.a libstemmer.a
+}