summaryrefslogtreecommitdiff
path: root/dev-libs/sink/sink-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/sink/sink-0.5.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/sink/sink-0.5.0.ebuild')
-rw-r--r--dev-libs/sink/sink-0.5.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/sink/sink-0.5.0.ebuild b/dev-libs/sink/sink-0.5.0.ebuild
new file mode 100644
index 000000000000..d83a654f28bb
--- /dev/null
+++ b/dev-libs/sink/sink-0.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="false" # build breaks otherwise. tests not isolated.
+inherit kde5
+
+DESCRIPTION="A data access layer handling synchronization, caching and indexing"
+SRC_URI="https://github.com/KDE/sink/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64"
+IUSE=""
+
+# qtgui is bogus but is required because something else in the deptree
+# uses it as a public dependency but doesn't search for it properly
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kmime)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ dev-db/lmdb:=
+ dev-libs/flatbuffers
+ dev-libs/kasync
+ net-libs/kdav2
+ net-libs/kimap2
+ net-misc/curl
+ sys-libs/readline:0=
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+"
+
+# fails to build
+RESTRICT+=" test"
+
+src_prepare() {
+ kde5_src_prepare
+ # FIXME: sink is useless without its 'examples'. Workaround our eclass
+ sed -i -e "/add_subdirectory(examples)/ s/#DONOTCOMPILE //" \
+ CMakeLists.txt || die "Failed to fix CMakeLists.txt"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libgit2=ON
+ )
+ kde5_src_configure
+}