summaryrefslogtreecommitdiff
path: root/dev-libs/simde
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-25 17:40:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-25 17:40:36 +0000
commit85809279ceef66e68b25eac8c3918bee6762f6cc (patch)
tree9ecee133212467e7b1402b70a11c5d6fb3ea817d /dev-libs/simde
parent4215622c05ed14d30fdad5a4d0feba6d94b0d046 (diff)
gentoo auto-resync : 25:02:2024 - 17:40:36
Diffstat (limited to 'dev-libs/simde')
-rw-r--r--dev-libs/simde/Manifest3
-rw-r--r--dev-libs/simde/metadata.xml11
-rw-r--r--dev-libs/simde/simde-0.7.6.ebuild32
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/simde/Manifest b/dev-libs/simde/Manifest
new file mode 100644
index 000000000000..2f9857e477e9
--- /dev/null
+++ b/dev-libs/simde/Manifest
@@ -0,0 +1,3 @@
+DIST simde-0.7.6.tar.gz 6125123 BLAKE2B 96378e81a2e2a2d797289d26b3d0c1ea72288b51094e8c5fde75ecbef34a0c1d4dc029d5974281e2f9f938b190b4a648225fcb486205cc496ba57b1ec528cee4 SHA512 de17fca563c4db6766881e1c73142ad129a57febe55fa8ea1ae780226e60a84891b13d387e75574f2722d77e4013176e3c7dfaf17bccd8682b7d3d3ec8e92a54
+EBUILD simde-0.7.6.ebuild 776 BLAKE2B 9988810834a8355addbd78a8382a1678950048c8c3e3288e46f125423be823397f269b7d067ab500b09df6989421d521c73a787aa6701de8dc211afc6b8f63f1 SHA512 a1a01b5f5019feed17ad08eeb21652e2ed59d62937205db2615c0e05fb9c48079b2c0c049dfafcae1b227a356e8a3851533adeeb34d415a89305f3cd81b9cad8
+MISC metadata.xml 332 BLAKE2B d617fc3761fcdd13bfb89430ff299ebfff73c7ddf292c6695256e2a9b20b20e91830ce968e10df506cafd6ec61d863ecaa9bb0aad54b48025ba5e0bcfb07b1f5 SHA512 47c6c2b56e6299057413cb698bf78cd566843507df12215d1b359fff33ee004efad2b9194f830c3ede2f88dcc1dbf8206fc833172cfc5e1db71560c709b2d5bb
diff --git a/dev-libs/simde/metadata.xml b/dev-libs/simde/metadata.xml
new file mode 100644
index 000000000000..f92dc4d96537
--- /dev/null
+++ b/dev-libs/simde/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ionen@gentoo.org</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">simd-everywhere/simde</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/simde/simde-0.7.6.ebuild b/dev-libs/simde/simde-0.7.6.ebuild
new file mode 100644
index 000000000000..8d8a8be32a7a
--- /dev/null
+++ b/dev-libs/simde/simde-0.7.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Header-only library providing implementations of SIMD instruction sets"
+HOMEPAGE="https://simd-everywhere.github.io/blog/"
+SRC_URI="
+ https://github.com/simd-everywhere/simde/archive/refs/tags/v${PV/_/-}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ # *FLAGS are only used for tests (nothing that is installed), and
+ # upstream tests with specific *FLAGS and is otherwise flaky with
+ # -march=native, -mno-*, and such -- unset to be spared headaches.
+ unset {C,CPP,CXX,LD}FLAGS
+
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+
+ meson_src_configure
+}