summaryrefslogtreecommitdiff
path: root/dev-libs/serd/serd-0.30.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-02 13:12:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-02 13:12:50 +0100
commitb0378783c1929d283116fe183089c123dba5869c (patch)
treeefe69bfa7e38c36238f6e5a9341f6194b949e6f5 /dev-libs/serd/serd-0.30.16.ebuild
parente374e165c2ee372e9c6d10860ea6ef47f180f6b2 (diff)
gentoo auto-resync : 02:10:2022 - 13:12:50
Diffstat (limited to 'dev-libs/serd/serd-0.30.16.ebuild')
-rw-r--r--dev-libs/serd/serd-0.30.16.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/serd/serd-0.30.16.ebuild b/dev-libs/serd/serd-0.30.16.ebuild
new file mode 100644
index 000000000000..dbddac1ca319
--- /dev/null
+++ b/dev-libs/serd/serd-0.30.16.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="Library for RDF syntax which supports reading and writing Turtle and NTriples"
+HOMEPAGE="https://drobilla.net/software/serd.html"
+SRC_URI="https://download.drobilla.net/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc static-libs test +tools"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ dev-python/sphinx
+ dev-python/sphinx_lv2_theme
+)
+"
+
+src_prepare() {
+ default
+
+ # fix doc installation path
+ sed -i "s/versioned_name/'${PF}'/g" doc/c/meson.build || die
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_feature doc docs)
+ $(meson_use static-libs static)
+ $(meson_feature test tests)
+ $(meson_feature tools)
+ )
+
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ local DOCS=( AUTHORS NEWS README.md )
+ einstalldocs
+}