summaryrefslogtreecommitdiff
path: root/dev-libs/satyr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-libs/satyr
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-libs/satyr')
-rw-r--r--dev-libs/satyr/Manifest2
-rw-r--r--dev-libs/satyr/satyr-0.39.ebuild101
2 files changed, 103 insertions, 0 deletions
diff --git a/dev-libs/satyr/Manifest b/dev-libs/satyr/Manifest
index 4c1261a970f0..547e889f898d 100644
--- a/dev-libs/satyr/Manifest
+++ b/dev-libs/satyr/Manifest
@@ -1,3 +1,5 @@
DIST satyr-0.38.tar.gz 433626 BLAKE2B 682d28a932758353e986d2906baf294183756d60a063ce03ba79506b58c92e4fc039c2246c0d43910f6d27d62dd674ffd3b772eeb6e8de46d8080735754b3d3a SHA512 09168050ca7bae00fb3d39f23f8c1e0adcf9cc4d3e491aa002bf9a0a7a265df980d12e430ea7f3eaa9010e0432821b106db5ce3b1e8d935d78b1e56d37110051
+DIST satyr-0.39.tar.gz 434581 BLAKE2B 7b4e11d8027877aa3b9e8144f8917f03b489b157c1112794a3c2bea9998a4367a7ec06cdec6c144fd96ecdabc83a85c5fb2644df02d59086ea3a113b1402fabe SHA512 f6d24ae054867ccdbb2dabdd63c6b351f7eec9ffe5426bdeffa86d585a52d13b07dd31e26b7d14e4850a1fdca748b0d5e23bb51fbc2843af79bf306f09d3145f
EBUILD satyr-0.38.ebuild 1907 BLAKE2B d10c50fa965196a2ba4ba6eed912e0d2a3c0e586659f6c6a82634790b458227c68752930a45f011bef9466efc10e5cdb85fd4b5c10265f436b659f229d2e6388 SHA512 446133195a7f681e2d344f60959539d9257be1b1d1f8f2c2b8297c34ab9b4f885d5e66e06da5330486284211b81abe2941257b12beb6f95e7e37da7f3661de8f
+EBUILD satyr-0.39.ebuild 1907 BLAKE2B d10c50fa965196a2ba4ba6eed912e0d2a3c0e586659f6c6a82634790b458227c68752930a45f011bef9466efc10e5cdb85fd4b5c10265f436b659f229d2e6388 SHA512 446133195a7f681e2d344f60959539d9257be1b1d1f8f2c2b8297c34ab9b4f885d5e66e06da5330486284211b81abe2941257b12beb6f95e7e37da7f3661de8f
MISC metadata.xml 240 BLAKE2B 1f4d972fe6e8f4096f8905fe5ec3f77b8689f3b0e01ac676ae4e55ce3aa66c18473cc82b5766131f155b9f4cd3fa6c541ab3bd32bfd233ff89722937105f968a SHA512 2e9f28bd0e525aa062cb098048dd176668b1ca2220e0018279ec4779eb80a2e8ad4f1ea73899aded97b7d27379e88d2f60cc80af4a6992880edf6e301b7e1090
diff --git a/dev-libs/satyr/satyr-0.39.ebuild b/dev-libs/satyr/satyr-0.39.ebuild
new file mode 100644
index 000000000000..754906da9469
--- /dev/null
+++ b/dev-libs/satyr/satyr-0.39.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit autotools multiprocessing python-r1
+
+DESCRIPTION="Satyr is a collection of low-level algorithms for program failure processing"
+HOMEPAGE="https://github.com/abrt/satyr"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/4"
+
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+ >=dev-libs/elfutils-0.158
+ dev-libs/glib:2
+ dev-libs/json-c:=
+ dev-libs/nettle:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ dev-util/gperf
+"
+
+src_prepare() {
+ default
+ ./gen-version || die # Needs to be run before full autoreconf
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ use python && python_setup
+
+ local myargs=(
+ --localstatedir="${EPREFIX}/var"
+ --without-rpm
+ $(usex python "--with-python3" "--without-python3")
+ )
+
+ if use python; then
+ python_configure() {
+ econf "${myargs[@]}"
+ }
+ python_foreach_impl run_in_build_dir python_configure
+ else
+ econf "${myargs[@]}"
+ fi
+}
+
+src_compile() {
+ if use python; then
+ python_foreach_impl run_in_build_dir default
+ else
+ default
+ fi
+
+}
+
+src_test() {
+ local extra_args
+
+ # In order to pass --jobs to the test runner
+ run_tests() {
+ cd tests || die
+ emake testsuite
+ ./testsuite --jobs=$(makeopts_jobs) ${extra_args[@]} $@
+
+ # Only run the python bindings tests for other python impls
+ extra_args=('-k' 'python3_bindings.*')
+ }
+
+ if use python; then
+ python_foreach_impl run_in_build_dir run_tests
+ else
+ run_tests SKIP_PYTHON3=yes
+ fi
+}
+
+src_install() {
+ if use python; then
+ python_install() {
+ default
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir python_install
+ else
+ default
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+}