summaryrefslogtreecommitdiff
path: root/dev-libs/satyr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-libs/satyr
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-libs/satyr')
-rw-r--r--dev-libs/satyr/Manifest2
-rw-r--r--dev-libs/satyr/satyr-0.30.ebuild99
2 files changed, 101 insertions, 0 deletions
diff --git a/dev-libs/satyr/Manifest b/dev-libs/satyr/Manifest
index 037d3cd2df73..7407b7c22c07 100644
--- a/dev-libs/satyr/Manifest
+++ b/dev-libs/satyr/Manifest
@@ -1,3 +1,5 @@
DIST satyr-0.27.tar.gz 435341 BLAKE2B ade40bc6a1c48e6fc0af7913ff94ed044c63fdb63b8d86ba010bebcfd2098831bc6c7361d116851aee88f49c640d1457dd8953becad60b6ff6dc32deec6c7942 SHA512 7b01cf16489644fbfbe2150477279a94c6fa9b3310edebc84b83bab58d1058df0be478ab6bf4c6910b4168122721dde10d573711abb983b0eb5ccda09cb80710
+DIST satyr-0.30.tar.gz 427940 BLAKE2B 97fedef59cc77b2ae81857c491532552c352a272658d02564d2661d06a4ccc99c18bcd57e5e68e5a612e9e65c5878f19b2f18bbe74066874a7295e2f65d64149 SHA512 ebc6e9c0fd8cd130cf1701573c8ecdadf73fe54efa563759a47f990a91b217cf1dec01045be624d15cfa96b1370ddf2412b0537e57ed628dc27e860be46e21cf
EBUILD satyr-0.27.ebuild 998 BLAKE2B 08132e235be3f21deab7abccc2ddb5021851839f4012d985144bd89a7078a09bcf0e854e6e6c4626f9817c20a2aded73303892451e26001792b812b1e007dfaf SHA512 4c8108312645f67c1da4aafdf5693295d4706c7ca1c2f63fe7933c2283488411c30e485d188b64eb9ccffd3caf5c0927608218de5075429309cd82e06d11388b
+EBUILD satyr-0.30.ebuild 1888 BLAKE2B ab7808b568723b16e7122f9e592312954bd7677dade8b17717295578ecd71466a0f8e124675f2c47826178cfac5004cfae2f3f0e9e12324a84949f5b7b132bde SHA512 9388875827aa9d2325328394f7f79ad5c11cae9c2e5e019dc61da7ea6569b72ee5e231dc533f9750873754b34630cd283ef0885d3c6bdc750f33acfab7976f74
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/dev-libs/satyr/satyr-0.30.ebuild b/dev-libs/satyr/satyr-0.30.ebuild
new file mode 100644
index 000000000000..f654d70e26bb
--- /dev/null
+++ b/dev-libs/satyr/satyr-0.30.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit autotools multiprocessing python-r1
+
+DESCRIPTION="Satyr is a collection of low-level algorithms for program failure processing"
+HOMEPAGE="https://github.com/abrt/satyr"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/4"
+
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ >=dev-libs/elfutils-0.158
+ dev-libs/json-c:=
+ dev-libs/nettle:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ dev-util/gperf
+"
+
+src_prepare() {
+ default
+ ./gen-version || die # Needs to be run before full autoreconf
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ use python && python_setup
+
+ local myargs=(
+ --localstatedir="${EPREFIX}/var"
+ --without-rpm
+ $(usex python "--with-python3" "--without-python3")
+ )
+
+ if use python; then
+ python_configure() {
+ econf "${myargs[@]}"
+ }
+ python_foreach_impl run_in_build_dir python_configure
+ else
+ econf "${myargs[@]}"
+ fi
+}
+
+src_compile() {
+ if use python; then
+ python_foreach_impl run_in_build_dir default
+ else
+ default
+ fi
+
+}
+
+src_test() {
+ local extra_args
+
+ # In order to pass --jobs to the test runner
+ run_tests() {
+ cd tests || die
+ emake testsuite
+ ./testsuite --jobs=$(makeopts_jobs) ${extra_args[@]} $@
+
+ # Only run the python bindings tests for other python impls
+ extra_args=('-k' 'python3_bindings.*')
+ }
+
+ if use python; then
+ python_foreach_impl run_in_build_dir run_tests
+ else
+ run_tests SKIP_PYTHON3=yes
+ fi
+}
+
+src_install() {
+ if use python; then
+ python_install() {
+ default
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir python_install
+ else
+ default
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+}