summaryrefslogtreecommitdiff
path: root/dev-libs/satyr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-25 15:22:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-25 15:22:17 +0100
commit22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (patch)
tree808b5701901fb54b53ec3ecf6f33272e933f3ea6 /dev-libs/satyr
parent91c0ec2d7067f6ab1ef578bd9967b32ca07eb502 (diff)
gentoo resync : 25.05.2018
Diffstat (limited to 'dev-libs/satyr')
-rw-r--r--dev-libs/satyr/Manifest3
-rw-r--r--dev-libs/satyr/metadata.xml8
-rw-r--r--dev-libs/satyr/satyr-0.26.ebuild45
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/satyr/Manifest b/dev-libs/satyr/Manifest
new file mode 100644
index 000000000000..67ca6c8c9f05
--- /dev/null
+++ b/dev-libs/satyr/Manifest
@@ -0,0 +1,3 @@
+DIST satyr-0.26.tar.gz 434820 BLAKE2B 4463c69e6ac2eb8237f599bfeed308265a906c6e3efa154b14eb6ee7acdc65580da9baf5ecb99e4efa4f8c00f7656ff2a747e607f2293b12a513ed680986fe08 SHA512 45dfc42e05e93fa0417c8c5d6811097cabaa0f4dcfb79df13d3840d789cfd41c84382ae84882ca120b1a3120987123a306656324cf39f306046a5d30547db656
+EBUILD satyr-0.26.ebuild 1009 BLAKE2B b90d8ad64db0a0547e2cba96fab7a7ced1173efe729b002c24758f15c8b9622e0a7496df37c9fa9ecc9f51f6730e4e68342067353f805d1d6c8ac8e72d1d6bae SHA512 71e35c0ae1e4b085b4032450a75ee5e0ea80b55e4db22dfc9c955a71baf382be491dd56424e518d9db13a123962bcd95f91db510a61778ae0806410e248eb3f6
+MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/dev-libs/satyr/metadata.xml b/dev-libs/satyr/metadata.xml
new file mode 100644
index 000000000000..39980802b1da
--- /dev/null
+++ b/dev-libs/satyr/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-libs/satyr/satyr-0.26.ebuild b/dev-libs/satyr/satyr-0.26.ebuild
new file mode 100644
index 000000000000..400a2a442d4a
--- /dev/null
+++ b/dev-libs/satyr/satyr-0.26.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit autotools python-r1 toolchain-funcs
+
+DESCRIPTION="Satyr is a collection of low-level algorithms for program failure processing"
+HOMEPAGE="https://github.com/abrt/satyr"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/3"
+
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ >=dev-libs/elfutils-0.158
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ ./gen-version || die # Needs to be run before full autoreconf
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ local myargs=(
+ --localstatedir="${EPREFIX}/var"
+ --without-rpm
+ # Build breaks without and we aren't supporting Python2 anyway
+ --without-python2
+ $(usex python "--with-python3" "--without-python3")
+ )
+
+ econf "${myargs[@]}"
+}