summaryrefslogtreecommitdiff
path: root/dev-libs/satyr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
commit16449a80e28af2209916cc66d19c9a44ca2b90d9 (patch)
treeb4cfe2332c7a6c5da27b6985bf05db4508df1a92 /dev-libs/satyr
parent79599515788b85b18aa655e7b7f8cc05c1bbddd8 (diff)
gentoo resync : 20.02.2019
Diffstat (limited to 'dev-libs/satyr')
-rw-r--r--dev-libs/satyr/Manifest2
-rw-r--r--dev-libs/satyr/satyr-0.27.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/satyr/Manifest b/dev-libs/satyr/Manifest
index 7b80e67fb4d8..16ee197a9e5d 100644
--- a/dev-libs/satyr/Manifest
+++ b/dev-libs/satyr/Manifest
@@ -1,3 +1,5 @@
DIST satyr-0.26.tar.gz 434820 BLAKE2B 4463c69e6ac2eb8237f599bfeed308265a906c6e3efa154b14eb6ee7acdc65580da9baf5ecb99e4efa4f8c00f7656ff2a747e607f2293b12a513ed680986fe08 SHA512 45dfc42e05e93fa0417c8c5d6811097cabaa0f4dcfb79df13d3840d789cfd41c84382ae84882ca120b1a3120987123a306656324cf39f306046a5d30547db656
+DIST satyr-0.27.tar.gz 435341 BLAKE2B ade40bc6a1c48e6fc0af7913ff94ed044c63fdb63b8d86ba010bebcfd2098831bc6c7361d116851aee88f49c640d1457dd8953becad60b6ff6dc32deec6c7942 SHA512 7b01cf16489644fbfbe2150477279a94c6fa9b3310edebc84b83bab58d1058df0be478ab6bf4c6910b4168122721dde10d573711abb983b0eb5ccda09cb80710
EBUILD satyr-0.26.ebuild 1004 BLAKE2B b5d3f80e47de950bfe174b8a2740edb7c06b39bbbcfa654f67d953fec8be553179c639f1457c12482033a6dc4059e53f04511a9d24ad6d3cb0d50af95b60ad02 SHA512 9bea552420ef0dbc15e86873c89b44c4b92d42387504f737cb786f8677791a0c61475fbb54e1b02c38ea2f2d6a905a70527c47f215dd9e9285f1d9ae456d80c4
+EBUILD satyr-0.27.ebuild 1006 BLAKE2B 1d09128f62dab8399f78e6144e6c890b6ca726b2bbc846942af2a6133326c772e093f3d0838319dcf4045b7fc4b3d3c41308f89c157e4365f56a0c1049dfeafc SHA512 036069f7095ac9b7363f6507c12eff56fb58f81702faf512ada23604d1ad3213cd7fa6f04e107f1a55a2bac86a91baea6f0f8fb59c21e19d87b3a82869772410
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/dev-libs/satyr/satyr-0.27.ebuild b/dev-libs/satyr/satyr-0.27.ebuild
new file mode 100644
index 000000000000..2ff1248e54fc
--- /dev/null
+++ b/dev-libs/satyr/satyr-0.27.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit autotools python-r1 toolchain-funcs
+
+DESCRIPTION="Satyr is a collection of low-level algorithms for program failure processing"
+HOMEPAGE="https://github.com/abrt/satyr"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/3"
+
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ >=dev-libs/elfutils-0.158
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ ./gen-version || die # Needs to be run before full autoreconf
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ local myargs=(
+ --localstatedir="${EPREFIX}/var"
+ --without-rpm
+ # Build breaks without and we aren't supporting Python2 anyway
+ --without-python2
+ $(usex python "--with-python3" "--without-python3")
+ )
+
+ econf "${myargs[@]}"
+}